Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning > Open Source Reflashes

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-29-2013, 11:54 AM   #1
Faster_Gun
Scooby Specialist
 
Member#: 180217
Join Date: May 2008
Chapter/Region: MWSOC
Location: Bingham Farms, MI
Vehicle:
2004 WRX WGN 348whp
1977 GMC Brodozer

Default Newbie problems

I just posted this over at RomRaider, but i didn't realize it would need approval first. Whoops.


Hi all, just picked up a tactrix cable Wednesday. Im diving in head first, so sorry if the answer seems obvious.

I just picked up a 2005 Saab 9-2x Aero. The previous owner killed the EJ205 and replaced it with a EJ255 and got rid of AVCS. The car has a catless turbo back, but the rest is stock. I ran a LV (snap attached) on it and the AF learning is maxed in A and C (and probably B) and I dont think im getting into D much because the car goes into limp mode. I was thinking okay, sweet, I have a boost leak, so I did a leak check and I didn't find anything.* At this point I pulled the ROM and compared it to the stock ROM listed here. They're the same, but I flashed on the stock ROM with P0420 turned off for ****s and giggles. During light driving the CEL stays away, its only when trying to beat on it that it throws a CEL.
My two questions:
Is the injector scaling off? The EJ205 light blues are 440cc v the EJ255 dark blues at 565cc. Wouldn't the car always want to throw a lean CEL if this were the case?
This car is auto, can I flash a 05 MT base tune into it? I didn't see any TCU parameters.

*I capped my lower purge valve line and capped the turbo inlet to valve cover breather hose. Then ran system up to 20psi.

Thoughts?
* Registered users of the site do not see these ads.
Faster_Gun is offline   Reply With Quote
Old 11-29-2013, 02:31 PM   #2
Saabaru300
Scooby Specialist
 
Member#: 334105
Join Date: Oct 2012
Chapter/Region: MWSOC
Location: Southeast Michigan
Vehicle:
2005 Saab 9-2x Aero
Stage 2 Red

Default

The injector size should be the only difference between the ej205 and the EJ255 in the eyes of the ecu especially if the avcs is disabled. I would think so? Is the compression ratio different between the 2 motors?
Saabaru300 is online now   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 10:28 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.