Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-19-2013, 11:53 AM   #1
MattBrown0761
Scooby Specialist
 
Member#: 150611
Join Date: Jun 2007
Location: Gardner, MA
Default HELP: Part number for IAC Gasket 2006/2007 Impreza 2.5i

I can't seem to find the part number for JUSt the gasket for the IAC. I was told when I clean it I should have a new gasket in hand to put in. Is this true? If so does anyone have the part number. Car is a 2006/2007 Impreza N/A 2.5i. Thanks if you can pm me the part # it would be hugely appreciated...also do you clean it with the same spray you use to clean the MAF sensor?
* Registered users of the site do not see these ads.
MattBrown0761 is offline   Reply With Quote
Old 12-19-2013, 12:07 PM   #2
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Didn't they go to drive-by-wire in 2005, in which case there is no separate IACV?
Patrick Olsen is offline   Reply With Quote
Old 12-19-2013, 12:57 PM   #3
MattBrown0761
Scooby Specialist
 
Member#: 150611
Join Date: Jun 2007
Location: Gardner, MA
Default

Quote:
Originally Posted by Patrick Olsen View Post
Didn't they go to drive-by-wire in 2005, in which case there is no separate IACV?
I don't know?? haha. What would cause my idle problem then if not the IACV?
MattBrown0761 is offline   Reply With Quote
Old 12-19-2013, 02:24 PM   #4
JohnM10
Scooby Newbie
 
Member#: 244231
Join Date: Apr 2010
Chapter/Region: NESIC
Location: Providence, RI, USA
Vehicle:
2006 Impreza 2.5i 5M
Crystal Grey Metallic

Default

You can clean the throttle plate in the throttle body. If it gets gunked up it can't close completely and can cause idle issues.
If you remove it to clean it, you should replace the gasket. I used a Felpro gasket #61500 from Advance Auto Parts.
JohnM10 is offline   Reply With Quote
Old 12-19-2013, 08:35 PM   #5
MattBrown0761
Scooby Specialist
 
Member#: 150611
Join Date: Jun 2007
Location: Gardner, MA
Default

Quote:
Originally Posted by JohnM10 View Post
You can clean the throttle plate in the throttle body. If it gets gunked up it can't close completely and can cause idle issues.
If you remove it to clean it, you should replace the gasket. I used a Felpro gasket #61500 from Advance Auto Parts.
haha i did that actually upon reading here on the forums. i sprayed it good, wiped around the edges of the plate...it said spray it then lightly rev the engine which i did. and i repeated that a couple of times till black stuff stopped coming off on the rag. maybe i will give it another shot.

in the morning when it's cold i can hear the engine surging like every 10-15 seconds. and i don't know if this is related but the heater in the car surges as well. i just replaced the battery too but that didn't change anything.
MattBrown0761 is offline   Reply With Quote
Old 12-20-2013, 08:43 AM   #6
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Quote:
Originally Posted by MattBrown0761 View Post
I don't know?? haha. What would cause my idle problem then if not the IACV?
haha Blind troubleshooting is a good way to throw away money. haha There are a variety of things that affect the idle. Without any explanation of what symptoms you're seeing it's awfully hard to offer you any advice.

Quote:
Originally Posted by MattBrown0761 View Post
in the morning when it's cold i can hear the engine surging like every 10-15 seconds. and i don't know if this is related but the heater in the car surges as well. i just replaced the battery too but that didn't change anything.
Hopefully you didn't replace the battery hoping that was going to cure an idle surge. haha

You said this is happening when you start the car on a cold morning. haha Do you have the defrost on when this surging is happening? Defrost uses the A/C, so that 10-15sec surging could be the A/C compressor cycling.
Patrick Olsen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 11:22 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.