Welcome to the North American Subaru Impreza Owners Club Wednesday September 3, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-13-2014, 08:24 PM   #1
bitterWRX
Scooby Specialist
 
Member#: 49624
Join Date: Dec 2003
Location: CA
Vehicle:
04 AW WRX
13 SWP STi

Default Rally Armor UR Mudflap sag

Hey, I noticed that my front passenger mudflap started sagging. My other three flaps are perfectly fine. I tried loosening and retightening, but it still sags. Anyone else experiencing this same issue? Anyone know of a way to fix this?



* Registered users of the site do not see these ads.

Last edited by HinshawWRX; 07-13-2014 at 08:44 PM. Reason: Fixed photo embedding
bitterWRX is offline   Reply With Quote
Old 07-13-2014, 09:12 PM   #2
The Fugin Guy
NASIOC Supporter
 
Member#: 392193
Join Date: May 2014
Chapter/Region: MAIC
Location: Central VA
Vehicle:
2015 WRX Premium CVT
Lightning Red

Default

I would email them.
sales@rallyarmor.com
The Fugin Guy is offline   Reply With Quote
Old 07-14-2014, 12:26 AM   #3
bitterWRX
Scooby Specialist
 
Member#: 49624
Join Date: Dec 2003
Location: CA
Vehicle:
04 AW WRX
13 SWP STi

Default

That was going to be my next step. I wanted to see if anyone else has this issue and/or if this is a common problem.
bitterWRX is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 01:20 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.