Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Impreza Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-05-2014, 10:06 PM   #1
scoobaru2.5rs
Scooby Newbie
 
Member#: 323356
Join Date: Jun 2012
Default Hesitation problem

Hey guys I have a 1998 subaru impreza 2.5rs rounding in on 160,000 miles and it has a hesitation problem, I've replaced the spark plugs, wires, idle air control valve, mass air flow sensor. When I'm driving and start to let go of the gas the car drops rpms and I try to press the gas and it has no response but then kicks in out of no where. I don't really know what else it could be. Thanks for your time
* Registered users of the site do not see these ads.
scoobaru2.5rs is offline   Reply With Quote
Old 01-06-2014, 06:27 AM   #2
Guzzi 1
Scooby Newbie
 
Member#: 338666
Join Date: Nov 2012
Chapter/Region: MWSOC
Location: Northeast Ohio
Vehicle:
2013 Impreza Premium
Dark Grey Metalic CVT

Default

It might be worth getting someone t plug in a diag puter.

Just a wild guess on my part, but it sounds a lot like a partial open in the TPS. (Throttle Position Sensor)

John
Guzzi 1 is offline   Reply With Quote
Old 01-06-2014, 08:22 AM   #3
scoobaru2.5rs
Scooby Newbie
 
Member#: 323356
Join Date: Jun 2012
Default

Yeah I forgot to mention I actually replaced my tps, but maybe there's a way to put it in wrong? Or setup it wrong
scoobaru2.5rs is offline   Reply With Quote
Old 01-24-2014, 11:52 AM   #4
DrunkTruck
Scooby Newbie
 
Member#: 375699
Join Date: Dec 2013
Default

If it's not spark, and it's not air, it could be fuel. Have you measured fuel pressure yet?
DrunkTruck is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 02:48 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.