Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.5L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-10-2014, 08:43 PM   #1
SatinWhiteSTi
Scooby Newbie
 
Member#: 351141
Join Date: Mar 2013
Default 2011 STI Boost Leak Test HELP! Cap off locations...PICS!

Hi all...

My Stage 2+ STI was tuned for about 22PSI, and was making around 320WHP/395WTQ.

I recently data-logged some pulls with my AP and I'm maxing out around 19PSI. My AEM wideband is also showing i'm steady at 10.1 while at full throttle (WOT), so I'm rich.

So I'm trying to find a boost leak and need help understanding what I need to cap off...

Here's the car before I changed the oil yesterday with winter rims:


What I've capped off so far:



And here:



Still unable to build any pressure in the system. Can anyone find pics or draw arrows for my dumb ass :/

Ask anything you think could help!
* Registered users of the site do not see these ads.
SatinWhiteSTi is offline   Reply With Quote
Old 03-11-2014, 12:32 PM   #2
Razgeiz
NASIOC Supporter
 
Member#: 358782
Join Date: Jun 2013
Chapter/Region: MWSOC
Location: Springfield, Illinois
Vehicle:
2013 STi
DGM

Default

Have you checked your turbo inlet for a tear? They are pretty common to get a rip in them causing decent boost leaks.
Razgeiz is online now   Reply With Quote
Old 06-06-2014, 03:57 PM   #3
b16h22
Scooby Newbie
 
Member#: 90824
Join Date: Jul 2005
Location: CA
Vehicle:
2009 STI

Default

did you ever figure out the problem? i have the exact same issue right now and was about to do my own leak test also.
b16h22 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 12:56 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.