Welcome to the North American Subaru Impreza Owners Club Sunday September 21, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Rocky Mountains Impreza Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Chapters > Rocky Mountains Impreza Club Forum -- RMIC

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-18-2001, 02:56 PM   #1
Scoober01
Scooby Newbie
 
Member#: 3649
Join Date: Jan 2001
Location: Englewood, CO, USA
Vehicle:
2001 Impreza 2.5 RS
Blue Ridge Pearl-Red acc

Post What Octain gas do you all use here in CO.

I'm haveing a problem looseing power above 4500rpm at 110mph in 4th or 5th, it will just hang at 4500. I just installed the full borla exhaust system, header, mid-pipe and exhaust all 2.5
Somone suggested I might be useing too good of gas. I've always run 91 and had no problems till the install of the exhaust.
I wouldn't think that better gas would cause this though.

What type of gas do you all use?
and anyone have any suggestions.
Thanxs
Ryan D.
* Registered users of the site do not see these ads.
Scoober01 is offline   Reply With Quote
Old 04-18-2001, 03:06 PM   #2
Strepto
Scooby Specialist
 
Member#: 252
Join Date: Sep 1999
Location: San Antonio, TX
Vehicle:
2001 Arctic White
Camaro SS #1800

Post

87
Strepto is offline   Reply With Quote
Old 04-18-2001, 04:23 PM   #3
dougwendel
Scooby Newbie
 
Member#: 4213
Join Date: Feb 2001
Location: Boulder, CO USA
Post

I'm using 91 in mine... it's totally stock but seems to do okay above 4500. There is definitely a drop in power, but I think that's just an engine charateristic rather than a fuel issue.
dougwendel is offline   Reply With Quote
Old 04-18-2001, 04:35 PM   #4
Strepto
Scooby Specialist
 
Member#: 252
Join Date: Sep 1999
Location: San Antonio, TX
Vehicle:
2001 Arctic White
Camaro SS #1800

Post

if anyone is using less than 91 in their WRX they should be shot. poor little motor
Strepto is offline   Reply With Quote
Old 04-18-2001, 04:57 PM   #5
bratmantlz
Scooby Specialist
 
Member#: 3231
Join Date: Dec 2000
Chapter/Region: RMIC
Location: colorado springs colorado usa
Vehicle:
88 626 Turbo
white

Thumbs up

i use the 87 octane until i boost then i will use 91
bratmantlz is offline   Reply With Quote
Old 04-18-2001, 05:04 PM   #6
DaveK
Scooby Newbie
 
Member#: 2338
Join Date: Sep 2000
Location: Colorado
Vehicle:
1988 323 GTX
black

Post

93.5 + octane booster for race days!!!

The gas station is called Petro Stop and its on Parker Road in Aurora.
DaveK is offline   Reply With Quote
Old 04-18-2001, 05:04 PM   #7
DaveK
Scooby Newbie
 
Member#: 2338
Join Date: Sep 2000
Location: Colorado
Vehicle:
1988 323 GTX
black

Post

Oh yeah, when N/A I only used 87.
DaveK is offline   Reply With Quote
Old 04-19-2001, 09:15 PM   #8
ImprezaRS dot com
over boosted again
Moderator
 
Member#: 1458
Join Date: May 2000
Chapter/Region: RMIC
Location: Colorado Springs CO USA
Vehicle:
2015 Forester 2.0 XT
2005 2.5 RS, 2013 Tribeca

Post

Well, it is now getting warm enough that I can't go past 7 psi of boost on 91 octane. I am using a bottle of octane booster and still can't go past 8 psi...

Larry
ImprezaRS dot com is offline   Reply With Quote
Old 04-20-2001, 12:06 AM   #9
SHADOWES
Scooby Newbie
 
Member#: 4427
Join Date: Feb 2001
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
1998 Legacy GT
silver for now

Post

I use 91 and have no problems in a stock engine.
SHADOWES is offline   Reply With Quote
Old 04-20-2001, 11:34 AM   #10
DaveK
Scooby Newbie
 
Member#: 2338
Join Date: Sep 2000
Location: Colorado
Vehicle:
1988 323 GTX
black

Post

Even with your extra injectors?
I'm still running 6psi no probs due to the weather.
DaveK is offline   Reply With Quote
Old 04-22-2001, 02:55 PM   #11
JJTheSubeDriver
Scooby Specialist
 
Member#: 391
Join Date: Oct 1999
Location: The land of many Subies
Vehicle:
2004 STi Blue/Gold
2000 RS BRP

Post

I use Amoco 91 in mine exclusively. I think the extra money is worth the insurance that I will have no knock or ping, and the car actually gets better mileage and runs better- so in the end I pretty much break even.

JJTheSubeDriver is offline   Reply With Quote
Old 04-23-2001, 09:02 AM   #12
Scoober01
Scooby Newbie
 
Member#: 3649
Join Date: Jan 2001
Location: Englewood, CO, USA
Vehicle:
2001 Impreza 2.5 RS
Blue Ridge Pearl-Red acc

Post

Alright well it seem there is no issue with 91 on a NA car. I didn't think there would be. better gas=slower burn=power right.

I really don't see how better gas can make your car run worse, unless your running 110/oc gas in a 82 geo.
Scoober01 is offline   Reply With Quote
Old 04-23-2001, 09:58 AM   #13
HamFist
Scooby Specialist
 
Member#: 2112
Join Date: Aug 2000
Chapter/Region: MWSOC
Vehicle:
2000 Impreza 2.5RS
BRP

Post

I noticed you haven't posted anything about a CE light with your borla header. how many miles has it been since you put it on?(shhh...don't let it hear you )

Gary
HamFist is offline   Reply With Quote
Old 04-23-2001, 05:24 PM   #14
bratmantlz
Scooby Specialist
 
Member#: 3231
Join Date: Dec 2000
Chapter/Region: RMIC
Location: colorado springs colorado usa
Vehicle:
88 626 Turbo
white

Post

uhh so 91 octane will reduce knock or ping.....or what ever???
bratmantlz is offline   Reply With Quote
Old 04-23-2001, 07:13 PM   #15
eastbaysubaru
Scooby Specialist
 
Member#: 4110
Join Date: Feb 2001
Chapter/Region: BAIC
Location: No. So. Co.
Vehicle:
04 FXT
PSM

Post

I have always used 91 in my legacy turbo, and I put it in my girlfriend's '00 RS as well. I don't know why, I guess just preventative measures early on I guess, probably no logic in it. An once of prevention = a pound of cure.

-Brian
eastbaysubaru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What spark plugs do you all use? emsmap Service & Maintenance 27 03-13-2009 03:17 PM
What torrent sites do you all use? greenshoes3 Off-Topic 27 07-24-2008 04:13 PM
What Octane Gas do YOU Use? Gil Legacy Forum 20 04-01-2005 10:04 AM
What grade oil do you all use? codemunky Service & Maintenance 23 04-17-2002 01:19 PM
OT: What Cell Phone cariers do you all use? IMPREZAmike New England Impreza Club Forum -- NESIC 12 10-04-2000 12:34 AM


All times are GMT -4. The time now is 08:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.