Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 10-22-2002, 09:27 PM   #1
corallo99
Visiting NASIOC Timeout
 
Member#: 7217
Join Date: Jun 2001
Location: Virginia USA
Vehicle:
2002 WRX
WRB

Default Who has had their radiator replaced or has one that leaks

I just had mine replaced, just wondering who else has. The whole top part of it leaked coolant, where the radiator is crimped together.
* Registered users of the site do not see these ads.
corallo99 is offline   Reply With Quote
Old 10-22-2002, 09:53 PM   #2
1fastwrx
Scooby Newbie
 
Member#: 9828
Join Date: Aug 2001
Location: NJ
Vehicle:
2002 wrx
plat silver

Default

my friends 02 leaks he getting it replaced. but even the top mount broke off. He ,ost likly geting an aftermarket one. It leaks above the top and I think some were else.
1fastwrx is offline   Reply With Quote
Old 10-23-2002, 12:03 AM   #3
WRX-72
Scooby Newbie
 
Member#: 9038
Join Date: Aug 2001
Location: Duluth MN
Vehicle:
2004 Sti
Platinum Silver

Default

I have gone through two of them booth leaked at the top.
The problem was a bad radiator cap.
WRX-72 is offline   Reply With Quote
Old 10-23-2002, 03:20 AM   #4
andygold
Scooby Newbie
 
Member#: 7347
Join Date: Jun 2001
Location: North Country, New York
Vehicle:
2002 Impreza WRX
WR Blue

Default

I too had one that was leaking from the crimp on the top. It was replaced under warranty.

Andy
andygold is offline   Reply With Quote
Old 10-23-2002, 09:25 AM   #5
jaywrx
Scooby Newbie
 
Member#: 16254
Join Date: Mar 2002
Chapter/Region: RMIC
Location: AZ then UT now TX next CO
Vehicle:
'02 WRX WRB
'07 Tribeca OBP

Default

Mine took a crap a few months ago. They replaced it under warranty, but I got a PWR radiator anyways....just didn't trust the stock one anymore.
jason
jaywrx is offline   Reply With Quote
Old 10-24-2002, 10:36 PM   #6
corallo99
Visiting NASIOC Timeout
 
Member#: 7217
Join Date: Jun 2001
Location: Virginia USA
Vehicle:
2002 WRX
WRB

Default

Well my friend had one that leaked and then put the sti cap on and it pretty much exploded. Cant they make good radiators, i guess its the same guy who made my first gear syncro.
F U C K E R S !!!!!
corallo99 is offline   Reply With Quote
Old 10-24-2002, 10:39 PM   #7
GLwagon
Scooby Specialist
 
Member#: 16696
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Baraboo, WI
Vehicle:
2002 WRX Sedan Stg2
2013 OBW roll'n at 30+mpg

Default

Dude you'd better edit that or you'll get bounced hard!!!

use this --->:monkey:
GLwagon is offline   Reply With Quote
Old 10-24-2002, 11:49 PM   #8
Schleppy
Scooby Specialist
 
Member#: 15858
Join Date: Feb 2002
Chapter/Region: NESIC
Location: Boston
Vehicle:
SPB

Default

Is it really obvious if you have a bad radiator?

It seems like my coolant is low, but I am JUST about to hit 15k, so it doesn't seem right that I would be low on coolant already. I mean, isn't it supposed to last a WHILE?

Thanks!
Schleppy is offline   Reply With Quote
Old 10-25-2002, 12:41 AM   #9
ChrisW
Scooby Specialist
 
Member#: 4181
Join Date: Feb 2001
Location: keeping santa cruz weird
Vehicle:
2003 Lancer Evo 8
It's Blue, ok?

Default

Quote:
Originally posted by andygold
I too had one that was leaking from the crimp on the top. It was replaced under warranty.

Andy
same here.
ChrisW is offline   Reply With Quote
Old 10-25-2002, 12:49 AM   #10
Cosworth
Scooby Specialist
 
Member#: 3887
Join Date: Jan 2001
Chapter/Region: Tri-State
Location: Middletown, NJ
Vehicle:
08 Taco, 98 M3/4/5
'00 RC51, '08 KTM

Default

Quote:
Originally posted by andygold
I too had one that was leaking from the crimp on the top. It was replaced under warranty.

Andy
Same here also.
Cosworth is offline   Reply With Quote
Old 10-25-2002, 03:28 AM   #11
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

Quote:
Originally posted by corallo99
Well my friend had one that leaked and then put the sti cap on and it pretty much exploded. Cant they make good radiators, i guess its the same guy who made my first gear syncro.
F U C K E R S !!!!!
you'll be spending time it TO....that F-bomb is a no no....and yes do NOT use the STi radiator cop on a STOCK radiator, you WILL blow the tank apart(it's not the radiators fault)

1.1bar=15.95 psi
1.3bar=18.85 psi

Jeremy
HndaTch627 is offline   Reply With Quote
Old 10-25-2002, 08:06 AM   #12
Redleader
Scooby Newbie
 
Member#: 14430
Join Date: Jan 2002
Location: Tacoma, Wa. USA
Vehicle:
'02 WRX Wagon WRB
STi swap luvin it!!!

Default

Been there done that...
Redleader is offline   Reply With Quote
Old 10-25-2002, 08:28 AM   #13
SleeperWRX
Scooby Specialist
 
Member#: 8179
Join Date: Jul 2001
Location: Legacy Sport Sedan (Turbo)
Default

mine blew at the top too...
SleeperWRX is offline   Reply With Quote
Old 10-25-2002, 09:15 AM   #14
SilverBoosted
Scooby Specialist
 
Member#: 7764
Join Date: Jun 2001
Chapter/Region: MAIC
Location: State of Confusion
Vehicle:
11 Edge Sport
Kona Blue Metallic

Default

Had mine go at less than 5000 miles repl under warr... no problems since then (with the radiator)..............
SilverBoosted is offline   Reply With Quote
Old 10-25-2002, 10:31 AM   #15
speedbuggy67
Scooby Specialist
 
Member#: 9041
Join Date: Aug 2001
Chapter/Region: Tri-State
Location: Jersey Shore
Vehicle:
2002 WRX
blaze yellow 1-450

Default

yup mine went around 8k miles splitting around the sides and leaking. No problems since and got 17k now, and about a year later.

SCott
speedbuggy67 is offline   Reply With Quote
Old 10-25-2002, 01:45 PM   #16
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

corallo99 - sent you an email...

you'd best get back to me if you wish to continue posting...

cheers
Jamie
www.subiegalracing.com
Subie Gal is offline   Reply With Quote
Old 03-23-2003, 06:34 PM   #17
is2scooby
Scooby Specialist
 
Member#: 19851
Join Date: Jun 2002
Location: Honolulu, HI
Vehicle:
02 WRX
Aspen White/12.75@105.67

Default

Top tank starting to leak on mine as well...
is2scooby is offline   Reply With Quote
Old 03-23-2003, 08:53 PM   #18
WRX_02_227
Scooby Specialist
 
Member#: 12434
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: PA
Vehicle:
2002 WRX, 2015 WRX
2011 BMW 135i

Default

Just had mine replaced in February...coolant was all over the top where the crimp is.
WRX_02_227 is offline   Reply With Quote
Old 03-23-2003, 09:15 PM   #19
Redleader
Scooby Newbie
 
Member#: 14430
Join Date: Jan 2002
Location: Tacoma, Wa. USA
Vehicle:
'02 WRX Wagon WRB
STi swap luvin it!!!

Angry

Yup! Mine blew at the top to
Redleader is offline   Reply With Quote
Old 03-23-2003, 09:24 PM   #20
davidm_sh
Scooby Specialist
 
Member#: 5994
Join Date: Apr 2001
Location: Fort Collins, CO
Vehicle:
2004 Impreza WRX STi
Java Black

Default

Quote:
Originally posted by andygold
I too had one that was leaking from the crimp on the top. It was replaced under warranty.

Andy
Same here. Happened around 15,000 miles ... now I have about 48000 miles and the new one seems to be fine.
davidm_sh is offline   Reply With Quote
Old 03-23-2003, 09:41 PM   #21
WRX4FUN
Scooby Newbie
 
Member#: 24173
Join Date: Sep 2002
Location: Dallas, GA
Vehicle:
2002 WRX Sedan
Blaze Yellow & Enkei RPM2

Default

Had mine replaced at 22k
WRX4FUN is offline   Reply With Quote
Old 03-23-2003, 10:40 PM   #22
Blue02WRX
Scooby Newbie
 
Member#: 5841
Join Date: Apr 2001
Location: Concord, North Carolina, USA
Vehicle:
2002 WRX
WRB

Default

me too, about 30k i guess right at the top
Blue02WRX is offline   Reply With Quote
Old 03-24-2003, 03:10 PM   #23
omahasubaru
Scooby Guru
 
Member#: 1594
Join Date: Jun 2000
Chapter/Region: MWSOC
Location: Gretna, NE
Vehicle:
1995 WRX
2002 Legacy

Default

Interesting how I don't see an '03 WRX owners expressing the same problem. Did they make a parts change?
omahasubaru is offline   Reply With Quote
Old 03-24-2003, 04:30 PM   #24
Cosworth
Scooby Specialist
 
Member#: 3887
Join Date: Jan 2001
Chapter/Region: Tri-State
Location: Middletown, NJ
Vehicle:
08 Taco, 98 M3/4/5
'00 RC51, '08 KTM

Default

Quote:
Originally posted by omahasubaru
Interesting how I don't see an '03 WRX owners expressing the same problem. Did they make a parts change?
Either that or they addressed a process issue in thier assembly/parts line.
Cosworth is offline   Reply With Quote
Old 03-31-2003, 11:25 AM   #25
Varanont
Scooby Newbie
 
Member#: 25195
Join Date: Sep 2002
Chapter/Region: SCIC
Vehicle:
2007 STI

Default

were you guys moded? I have an sti upipe and a bosal downpipe, will they deny my warranty.
Varanont is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Who has had their windshield replaced? ESmooth Interior & Exterior Modification 14 04-30-2007 10:39 PM
Who here has had their Trunk Monkey fly off their spoiler? BLK REX Interior & Exterior Modification 30 02-21-2006 10:04 AM
ATTN: ppl who had their windshield replaced migs76 Tri-State Area Forum 17 04-26-2005 04:51 PM
Has anyone ever had their tranny replaced by the dealership under warranty? skyredrex Transmission (AT/MT) & Driveline 70 03-18-2004 05:51 PM
('93-'01) Who has had their wheels powder coated? JasonRan Impreza Forum 4 07-18-2001 10:28 AM


All times are GMT -4. The time now is 11:32 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.