Welcome to the North American Subaru Impreza Owners Club Wednesday September 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 08-29-2014, 07:58 PM   #1
gfautt
Scooby Newbie
 
Member#: 369576
Join Date: Sep 2013
Location: Texas
Vehicle:
2005 STI Built :)
450WHP

Default trouble shooting input on weird AFR during 4th gear pull

So recently I installed water meth injection and I have been running a 50/50 mix. Had it tuned and etc and all was well at 25.9 PSI max boost in 4th gear with an AFR of 11.3-11.4.

Last week my 4th gear pull AFR was 12.6 and very slowly dropping to 11.8 and I was getting about -2 knock sometimes. I cleaned my meth injector but that didn't help. So my tuner added a little more fuel and I dropped the max PSI to 25 and it fixed that issue but I'm curious as to why that happened.

Maybe I didn't clean the water meth injector well enough or my water meth mix wasn't perfect but I added a little extra meth to see if that would fix it temporary but only my tuner adding more fuel and dropping the boost to 25 fixed it. no drastic weather changes.

Ya I loose a little power with richer AFR but id rather be safe with no knock obviously. Please let me know what you guys think.




MY Engine setup:
2005 STI
built motor
gt 30 76 rotated turbo
850 cc injectors
front mount inter cooler
down pipe
cat back
cobb access port w custom tune 91 octane / 50/50 water meth
* Registered users of the site do not see these ads.
gfautt is offline   Reply With Quote
Old 08-30-2014, 09:56 AM   #2
dirtcollector
Scooby Newbie
 
Member#: 357347
Join Date: May 2013
Chapter/Region: SCIC
Location: east county san diego
Vehicle:
2005 wrx sti
aspen white

Default

Wrong section d00d.
Try posting here...
http://forums.nasioc.com/forums/forumdisplay.php?f=145

Oh and why don't you just ask your tuner why he had to make the changes he did? He will know more than any of us dweebs on the internet.

Last edited by dirtcollector; 08-30-2014 at 10:10 AM.
dirtcollector is offline   Reply With Quote
Old 08-30-2014, 03:30 PM   #3
gfautt
Scooby Newbie
 
Member#: 369576
Join Date: Sep 2013
Location: Texas
Vehicle:
2005 STI Built :)
450WHP

Default

He said it could be the sprayer but it's hard to tell. Ya I agree I just wanted to know if anyone might have had this same issue. Thanks for the link man
gfautt is offline   Reply With Quote
Old 08-30-2014, 08:09 PM   #4
Eyedeas
Scooby Newbie
 
Member#: 359202
Join Date: Jun 2013
Location: Oklahoma City
Vehicle:
2013 E85 WRX
Tangerine Orange Pearl

Default

Quote:
Originally Posted by dirtcollector View Post
Wrong section d00d.
Try posting here...
http://forums.nasioc.com/forums/forumdisplay.php?f=145

Oh and why don't you just ask your tuner why he had to make the changes he did? He will know more than any of us dweebs on the internet.
Scotty?
Eyedeas is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -4. The time now is 09:10 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.