Welcome to the North American Subaru Impreza Owners Club Sunday December 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Interior & Exterior Modification

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-04-2002, 01:03 AM   #1
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Does anyone even read
Vehicle:
this anymore???

Default Does anyone else have issues with their H3 fog lightblubs?

Like the subject says, do your H3's go out after a few weeks?

I'm starting to get sick of my Xenon white foglights burning out. I have a pocket full of H3's that have burned out within the past 4 months.

A friend of mine stated that he's always had issues with H3's. He said he never used the blue/white either.

I wanna know if anyone is having problems with these?
* Registered users of the site do not see these ads.
obyone is online now   Reply With Quote
Old 11-04-2002, 12:31 PM   #2
AKUFC
Scooby Newbie
 
Member#: 23463
Join Date: Aug 2002
Location: Dallas.TX
Vehicle:
I am
carless now :o(

Default

So you are using HID immitation bulbs? What company?

Dont use that company anymore would be one thing

Try getting a stock bulb and see how long it lasts in there, if it doesnt blow than you were getting the ghetto bulbs like so many people do
AKUFC is offline   Reply With Quote
Old 11-04-2002, 01:12 PM   #3
ATX25RS
Scooby Guru
 
Member#: 4597
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Laredo, Texas
Vehicle:
2011 Mitsu Outlander
Sport (Ex-Suby owner X3)

Default

no problems here...i am runnning 85W hella yellowstars.....before that...nokya 100w bulbs..and before that topspeed 100W.....changed because of preference, not because they blew out.....check the sealing on your fogs, and make sure they dont have any cracks....then you might wanna try the upgraded harness...
ATX25RS is offline   Reply With Quote
Old 11-04-2002, 01:15 PM   #4
Impreza Rider
Scooby Specialist
 
Member#: 756
Join Date: Jan 2000
Chapter/Region: MAIC
Location: Ashburn, Va
Vehicle:
2003 Legacy L wagon
2009 Kawasaki C14

Default

Also, when you install them, make sure that you don't touch the blub itself. That will cause them to burn out fast too.
Impreza Rider is offline   Reply With Quote
Old 11-04-2002, 05:17 PM   #5
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Does anyone even read
Vehicle:
this anymore???

Default

I've tried 3 different brands. They all go out within a few weeks.

I swear, I can predict which side will go out. If my left bulb goes and I replace it, I know that the next to go is the right side.

My housings don't have any cracks. Or at least, not any that I can see. The cover seems to close securely. I can feel the rubber seal seat when I close it. (there's that little bit of resistance when twisting) And I use gloves when changing out the bulbs. Even with gloves on, I try not to touch the bulb itself. I only grab it by the metal frame.

When my Xenon white (fake HID) headlight went out, (the head light lasted 4x as long as the fog lights) I replaced them with Sylvania Cool blues. I actually like these. Do you know if they make any Cool blues in H3, or if another manufacturer makes an equivilant in H3?
obyone is online now   Reply With Quote
Old 11-06-2002, 12:18 AM   #6
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Does anyone even read
Vehicle:
this anymore???

Default

bump.

Still need your advice.
obyone is online now   Reply With Quote
Old 11-06-2002, 12:31 AM   #7
au112
Scooby Specialist
 
Member#: 4412
Join Date: Feb 2001
Location: Port Moody BC Canada
Vehicle:
MY01 Impreza 2.5RS
BRP

Default

I think Sylvania has Cool Blue in H3.

Andy
au112 is offline   Reply With Quote
Old 11-06-2002, 12:49 AM   #8
ATX25RS
Scooby Guru
 
Member#: 4597
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Laredo, Texas
Vehicle:
2011 Mitsu Outlander
Sport (Ex-Suby owner X3)

Default

so what wattage are they?.....like i said maybe some high power harnesses
ATX25RS is offline   Reply With Quote
Old 11-08-2002, 09:23 PM   #9
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Does anyone even read
Vehicle:
this anymore???

Default

Quote:
Originally posted by ATX25RS
so what wattage are they?.....like i said maybe some high power harnesses
I thought that had to do with your harness going out? Higher wattage bulbs would want to draw more current than your harness could handle. Thing is, my harnesses are perfectly fine. I make sure not to install 130 + watt bulbs on there. I've only used 80 watt bulbs. (stock is 55)

Where can I find some "cool blue" H3's that arnt' crap and won't leave me poorer than my last girlfriend did?
obyone is online now   Reply With Quote
Old 11-08-2002, 10:55 PM   #10
WRXtasy227
Scooby Newbie
 
Member#: 25131
Join Date: Sep 2002
Location: New York
Vehicle:
2002 Impreza WRX
WR Blue Pearl

Default

PIAA!!!! Super expensive but the best brand out there for lighting.
WRXtasy227 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
does anyone else have problems with their hybrid? ted dibiase Built Motor Discussion 9 10-07-2007 09:21 PM
Anyone else having issues with Nasioc? 302@12psi General Community 4 02-07-2006 05:03 PM
does anyone else have problems with blowing hoses?? wrxstistunna Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 8 08-23-2004 07:47 AM
Anyone else having issues with Autometer fuel gauges? Revision Mid West Subaru Owners Club Forum -- MWSOC 2 03-27-2002 05:34 PM


All times are GMT -4. The time now is 05:49 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.