Welcome to the North American Subaru Impreza Owners Club Saturday August 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-17-2002, 09:15 PM   #1
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default HKS wastegate problem

I got a HKS standard wastegate and I can't seem to get the right amount of boost from it. I've changed the spring already but it still reads 10 pound of boost when I go WOT. Any idea what else I could do? Thanks.


BTW I'm reading it from an autometer gauge that is tee from my BOV line.
* Registered users of the site do not see these ads.
Avenger is offline   Reply With Quote
Old 11-18-2002, 02:08 AM   #2
Aspen
Scooby Specialist
 
Member#: 145
Join Date: Aug 1999
Chapter/Region: MWSOC
Location: The Windy City
Vehicle:
Banned to
Housework for Summer

Default

It would help if you told us what spring tension you have.
Aspen is offline   Reply With Quote
Old 11-18-2002, 11:04 AM   #3
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

It is a 5.7 psi spring.
Avenger is offline   Reply With Quote
Old 11-18-2002, 03:26 PM   #4
Aspen
Scooby Specialist
 
Member#: 145
Join Date: Aug 1999
Chapter/Region: MWSOC
Location: The Windy City
Vehicle:
Banned to
Housework for Summer

Default

You should have two ports on your wastegate. Make sure you are only using the side one and leave the top one alone unless you are using a boost controller, which then you want to tap into the top port with.

Also, verify your spring color is white.

Last edited by Aspen; 11-18-2002 at 03:32 PM.
Aspen is offline   Reply With Quote
Old 11-18-2002, 09:30 PM   #5
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

Yes the spring is white. Right now I got the side port connected to the turbo (in between turbo and throttle plate) and the top port connected to the intake manifold after the throttle plate.

So I just remove the top, or do I have the connection wrong?

Thanks
Avenger is offline   Reply With Quote
Old 11-18-2002, 11:22 PM   #6
Aspen
Scooby Specialist
 
Member#: 145
Join Date: Aug 1999
Chapter/Region: MWSOC
Location: The Windy City
Vehicle:
Banned to
Housework for Summer

Default

Just remove the top and you should be good to go.
Aspen is offline   Reply With Quote
Old 11-19-2002, 12:54 AM   #7
Avenger
Scooby Specialist
 
Member#: 1234
Join Date: Apr 2000
Location: Vancouver, Canada
Vehicle:
2000

Default

Thanks! I can finally go WOT with out worrying too much now.
Avenger is offline   Reply With Quote
Old 11-20-2002, 12:44 AM   #8
Aspen
Scooby Specialist
 
Member#: 145
Join Date: Aug 1999
Chapter/Region: MWSOC
Location: The Windy City
Vehicle:
Banned to
Housework for Summer

Default

no problemo. This is a common mistake on the HKS and Tial units...
Aspen is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
50mm HKS wastegate fs jdmworx Private 'For Sale' Classifieds 0 03-30-2006 11:53 PM
Some items on eBay, HKS wastegate, Turbonetics, Standalone EMS rebo0t Private 'For Sale' Classifieds 4 02-17-2006 02:11 PM
40mm HKS wastegate mdcmotorsports Private 'For Sale' Classifieds 1 12-14-2005 08:05 PM
Need help with HKS wastegate problem rhdude Normally Aspirated with bolt-on Forced Induction Powertrain 5 06-22-2002 12:34 PM
HKS wastegate Avenger Normally Aspirated with bolt-on Forced Induction Powertrain 17 12-26-2001 12:30 PM


All times are GMT -4. The time now is 04:57 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.