Welcome to the North American Subaru Impreza Owners Club Thursday September 18, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-26-2002, 11:51 PM   #1
ychan
Scooby Newbie
 
Member#: 9418
Join Date: Aug 2001
Location: nyc
Vehicle:
2002 2.5rs
aspen white

Default MRT system installed on me MY02 :)

somebody with a MY 02 asked me about the MRT setup (headers-back). langston subaru sent me another set of headers, since the last pair was an 1/8" off from port to port (by no fault of their own), and i installed it today in less than 1.5 hrs.

easy install-- except the CEL fix i bought didn't work, because i threw a CEL in about 2 miles. but man, is it sweet. noticeble gains. very noticeble. any suggestions on the CEL? the wire colors didn't match up. i'll do a search later, if no one has anything to say
-y
* Registered users of the site do not see these ads.
ychan is offline   Reply With Quote
Old 11-27-2002, 01:18 AM   #2
Dolphin Overton
Scooby Specialist
 
Member#: 1925
Join Date: Jul 2000
Chapter/Region: RMIC
Location: denver
Vehicle:
01 Allroad 6spd
13 Daytona 675R 99 Sprint

Default

wrap the headers....
Dolphin Overton is offline   Reply With Quote
Old 11-27-2002, 11:23 AM   #3
Julian
Scooby Specialist
 
Member#: 1182
Join Date: Mar 2000
Location: Ventura, CA
Vehicle:
MY00 RS
BRP

Default

Enjoy the power, live with the CE. I wrapped, ceramic coated, and relocated the O2 sensor on my MRT system. I still have the CE light. I have a CE eliminator, just haven't wired it in.
Julian is offline   Reply With Quote
Old 11-27-2002, 11:25 AM   #4
dpjef
Scooby Newbie
 
Member#: 18984
Join Date: May 2002
Location: Belgium
Vehicle:
2002 Impreza 2.0
dark blue

Default

I'm getting MRT's header put on very soon too, and I bought
my CEL fix from Scoobysport in the UK.
It hasn't been put on yet, but my dealer is not sure it will
work with my 2.0 litre Impreza.

Anyone else got a problem with their CEL fix not working ?
dpjef is offline   Reply With Quote
Old 12-02-2002, 10:19 AM   #5
ychan
Scooby Newbie
 
Member#: 9418
Join Date: Aug 2001
Location: nyc
Vehicle:
2002 2.5rs
aspen white

Default

anybody have any success with the CEL eliminator? i got it, but it must be installed wrong.
-y
ychan is offline   Reply With Quote
Old 12-02-2002, 12:41 PM   #6
Osgood30
Scooby Specialist
 
Member#: 20437
Join Date: Jun 2002
Chapter/Region: Tri-State
Location: West Chester, PA
Vehicle:
1999 Impreza STI
Version 7

Default

where did you guys got you CEL fixes?

ILPperformance make thier own fixes, people say that they actually work

Alex
Osgood30 is offline   Reply With Quote
Old 12-02-2002, 01:39 PM   #7
legacyej22
Scooby Newbie
 
Member#: 23385
Join Date: Aug 2002
Location: PDX
Default

Does anybody know what all the applications are for MRT header back systems? Thanks

Josh
legacyej22 is offline   Reply With Quote
Old 12-02-2002, 04:01 PM   #8
ychan
Scooby Newbie
 
Member#: 9418
Join Date: Aug 2001
Location: nyc
Vehicle:
2002 2.5rs
aspen white

Default

i got mine from http://www.ponyexpressperformance.co...liminator.html

i've herad this worked, too, but the wire colors didn't match up. i was wonderin' if anybody could help with this. anybody?

-y
ychan is offline   Reply With Quote
Old 12-02-2002, 06:33 PM   #9
ychan
Scooby Newbie
 
Member#: 9418
Join Date: Aug 2001
Location: nyc
Vehicle:
2002 2.5rs
aspen white

Default

they sent me an email. i guess i got it before there was an installation guide for the 2.5RS, since it's used for the rex, also. but, they sent me the 2.5RS guide.
-y
ychan is offline   Reply With Quote
Old 12-02-2002, 08:13 PM   #10
obyone
Scooby Specialist
 
Member#: 16523
Join Date: Mar 2002
Chapter/Region: MWSOC
Location: Inbetween Hesco's and T-walls
Vehicle:
JDM Maxxpro

Default

Quote:
Originally posted by ychan
i got mine from http://www.ponyexpressperformance.co...liminator.html

i've herad this worked, too, but the wire colors didn't match up. i was wonderin' if anybody could help with this. anybody?

-y
That's the same one I have. Did you tell them your car was an RS? It's the same part but comes with different installation instructions for the WRX and RS. That may be why your's didn't work.

Mine worked flawlessly.

(mods: Cobb intake, MRT header back.)
obyone is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
WWOTD: Security system installers crushed my chest freezer m750 Off-Topic 30 02-25-2010 10:16 PM
questions about my header install on my 2.5i 2.5EYE Normally Aspirated Powertrain 4 08-11-2009 08:34 AM
Greddy lip painted, and my Tein Mono Flex coilovers installed on my 06 bhhamblin Member's Car Gallery 60 03-07-2008 09:31 PM
*PICS* of my new Pioneer AVIC-D2 installed on my '06 STI Jag32 Car Audio, Video & Security 35 10-14-2006 04:42 PM
Need instructions on how to install on my clutch BLUETURBOWRX Transmission (AT/MT) & Driveline 15 10-10-2002 04:39 PM


All times are GMT -4. The time now is 09:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.