Welcome to the North American Subaru Impreza Owners Club Wednesday April 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 11-27-2002, 01:00 PM   #1
Equinox
Scooby Newbie
 
Member#: 29623
Join Date: Nov 2002
Location: Reston, VA
Vehicle:
2002 WRX
Blue

Default Odd smell from under hood, steam.

I appear to have a strange, dirty water/burning rubber smell coming from the general vicinity of my turbo. There is no performance decrease, and no fluid level change.
Im frankly afraid to drive my car, any help is appreciated.

Mods are: Injen CAI, TXS Turbo back, freedom design strut tower brace, TXS BOV, TXS dual stage boost controller.
* Registered users of the site do not see these ads.
Equinox is offline   Reply With Quote
Old 11-27-2002, 01:29 PM   #2
DammitBevis
Scooby Newbie
 
Member#: 3569
Join Date: Jan 2001
Chapter/Region: MWSOC
Location: Murphysboro, IL, USA
Vehicle:
2006 STi
AW

Default

Sounds like a coolant leak. An oil leak will usually drip since the oil doesn't evaporate. They can be irritating to track down. Look for a white residue left behind by evaporating coolant, or puffs of steam while the cooling system is fully heated up. When it's hot squeeze the radiator hose to make sure the system is under pressure (be careful). First place I'd check is under the turbo heat shield.
DammitBevis is offline   Reply With Quote
Old 11-27-2002, 02:05 PM   #3
I drive a WRX wagon
Scooby Specialist
 
Member#: 9219
Join Date: Aug 2001
Location: OC...like the TV show
Vehicle:
02 IS300 5sp

Default

yep, i had the same problem and took my car to the dealer. The dealer said that it was a loose fitting coolant hose that was leaking on to the turbo. They fixed it under warranty
I drive a WRX wagon is offline   Reply With Quote
Old 11-28-2002, 12:33 AM   #4
KKL
Scooby Newbie
 
Member#: 10220
Join Date: Sep 2001
Chapter/Region: VIC
Location: N49 13' W123 03'
Vehicle:
2010 STI
World Rally Blue Pearl

Default

Quote:
Originally posted by I drive a WRX wagon
yep, i had the same problem and took my car to the dealer. The dealer said that it was a loose fitting coolant hose that was leaking on to the turbo. They fixed it under warranty
Odd, I had the exact same problem a few months after I got my car, also a wagon. I kept seeing these little wisps of steam coming from the hood scoop and couldn't figure out what it was at first.
KKL is offline   Reply With Quote
Old 11-28-2002, 12:20 PM   #5
savka
Scooby Specialist
 
Member#: 12737
Join Date: Nov 2001
Location: Bean-Town
Vehicle:
MY02 wagon 325/300
MBP

Default

Quote:
Originally posted by KKL


Odd, I had the exact same problem a few months after I got my car, also a wagon. I kept seeing these little wisps of steam coming from the hood scoop and couldn't figure out what it was at first.
me too!!

any danger in ignoring the occasional white wisp of smoke?
savka is offline   Reply With Quote
Old 11-28-2002, 12:25 PM   #6
aphex twin
Scooby Newbie
 
Member#: 10426
Join Date: Sep 2001
Location: Central NJ
Vehicle:
2002 WRX
Midnight Pearl Black

Default

damn! i posted about this not too long ago. i was having the same problem. it wasnt a regular occurance so i couldnt figure it out. coolant makes sense. does it happen sporadically for you guys too?
aphex twin is offline   Reply With Quote
Old 11-28-2002, 06:14 PM   #7
KKL
Scooby Newbie
 
Member#: 10220
Join Date: Sep 2001
Chapter/Region: VIC
Location: N49 13' W123 03'
Vehicle:
2010 STI
World Rally Blue Pearl

Default

In my case, it started out as very small puffs of white smoke that I would catch out of the corner of my eye. I thought I was seing things for a while. It eventually got a little worse, enough that I could tell for sure that it was steam coming out of the hood scoop. By that time, I could smell the burning anti-freeze, not a nice smell. The dealer found the cause was a loose hose clamp underneath the turbo causing coolant to spray onto the turbo itself. They replace the clamp under warranty and it hasn't done it again in over a year.
KKL is offline   Reply With Quote
Old 11-28-2002, 07:49 PM   #8
Equinox
Scooby Newbie
 
Member#: 29623
Join Date: Nov 2002
Location: Reston, VA
Vehicle:
2002 WRX
Blue

Default

Aphex, on mine it has been sporadic, occasionally, it wont happen for long periods of time, and then it will just REEK in my car.
Equinox is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help: Gas smell from under hood. ChrisF Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 103 05-06-2010 02:04 AM
gas smell from under hood! tcooper Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 23 12-05-2009 09:43 PM
Steam from under hood Thtwudbeme Outback Forum 0 12-14-2003 11:21 PM
Steam from under hood, and excess coolant consumption ErikAnderson Normally Aspirated with bolt-on Forced Induction Powertrain 4 11-15-2003 11:36 AM
Showoff Q: Mist/Steam from under hood when revving? Brian Broz Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 10 06-25-2003 06:43 PM


All times are GMT -4. The time now is 12:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.