Welcome to the North American Subaru Impreza Owners Club Monday October 5, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Thread Tools Display Modes
Old 12-02-2002, 08:37 AM   #1
Slalom RS
Scooby Specialist
Member#: 25577
Join Date: Oct 2002
Chapter/Region: NESIC
Location: Hooksett, NH, USA
2004 TS Wagon

Default Purolator Air Filter made my car loud :(

Did the oil and wipers and a few other knicknacks on Saturday...figured I'd change the air filter, too. This looming holiday made a K&N a future mod instead of a today mod, so I went with the next best (ok, so it was the only other brand). I got a Purolator.

The install seemed straightforward, but when I was driving home from my dad's, it appeared that this filter was much louder. Seemed to resonate something at anything higher than 4k rpms. A really loud buzzing is all it is. I'm pretty sure it shouldn't sound like this...if it does, I'm taking it out pronto...the clips all snapped pretty tight, I thought...did I miss something?

Also, my car kinda stank after like 10 minutes of driving...do new air filters smell a bit funny at first? This is my first change, so I don't really know...could be in my head I guess...

* Registered users of the site do not see these ads.
Slalom RS is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 12-02-2002, 10:47 AM   #2
Scooby Guru
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
2009 Acura MDX Sport


your air intake filter has nothing to do with the air in your cabin
check all hoses and connectors...
rhdude is offline   Reply With Quote
Old 12-02-2002, 11:20 AM   #3
Scooby Guru
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Team Broken: V6 GF


an air filter is not going to make a sound differnce, It sounds like you might have left something loose, or knocked off the silencer, recheck everything and make sure all the intake tubing is connected securly.

munkis is offline   Reply With Quote
Old 12-02-2002, 02:56 PM   #4
Scooby Guru
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
'01 GC8 Dinged STM
'09 Concours 14 ABS Black


you didn't get the bottom clipped in correctly, it's still open to the engine bay making it resonate more.

HndaTch627 is offline   Reply With Quote
Old 12-02-2002, 03:49 PM   #5
Scooby Guru
Member#: 16803
Join Date: Mar 2002
Chapter/Region: International
Location: London, England

Originally posted by HndaTch627
you didn't get the bottom clipped in correctly, it's still open to the engine bay making it resonate more.


Bingo! I never knew about this until I took it to my dealer and had a guy drive it (for a clutch problem) and he asked me if I had an aftermarket intake because my bottom clip wasn't on. It's hard to get it clipped back on, take it to your dealer, they should be able to snap it back on in under a minute.
MattDell is offline   Reply With Quote
Old 12-02-2002, 08:33 PM   #6
Scooby Specialist
Member#: 15135
Join Date: Feb 2002
Chapter/Region: NWIC
Location: Bend, Or. USA


Always let a factory trained tech do all of thew work on your car...

If you can't do it yourself.

Lucky the CEL didn't come on, they would have charged you $50 to clear the code.
outback2.5HO is offline   Reply With Quote
Old 12-03-2002, 10:53 AM   #7
Scooby Newbie
Member#: 10801
Join Date: Oct 2001
Chapter/Region: NESIC
Location: Corrupticut
2008 Outback


Yes, check the clips on your air box. As for the stank, you probably spilled some oil somewhere in the engine bay and now it's burning off. Happens to the best of us. If not, tell your friends to lay off the Old Spice!
live311 is offline   Reply With Quote

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FS: NEW Fram Airhog Air Filter, fits many cars indelible Engine/Power/Exhaust 3 07-24-2008 10:19 AM
My Rallitek intake made my car slower!?!?! powerlabs Normally Aspirated Powertrain 49 12-09-2003 08:56 AM
helix d/p made my car slower :( teck7droid Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 18 09-13-2003 05:56 PM
Purolator air filter = much louder? Slalom RS New England Impreza Club Forum -- NESIC 5 12-02-2002 11:36 AM
second air filter in MY 99 tcmo Legacy Forum 1 01-14-2002 01:24 PM

All times are GMT -4. The time now is 06:53 PM.

Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.