Welcome to the North American Subaru Impreza Owners Club Sunday April 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Warranty Issues & SOA Problems

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-04-2002, 03:27 PM   #1
TwinkE
Scooby Newbie
 
Member#: 11011
Join Date: Oct 2001
Chapter/Region: MAIC
Location: Severn, Md
Vehicle:
2007 Legacy Spec B
Gray

Angry Boost gauge shorting out electrical so car wont start

So yesterday my friend and I were going to go to the Wizards game to watch Jordan kick a little ass. I come out to start my car after work and it wont start. The starter *may* have tried to start for a second or two but I really don't think it did. I try start it lots more times and the only thing that happens is that all the lights on the dash flash really fast and a clicking noise comes from what sounds like the dash. I think maybe the battery is dead, but no because the dome light can be manually turned on and my radar detector and radio are both on.

The weird thing is that my clock reset itself around 1:30pm that afternoon(the clock was off by 30 minutes).

I got it towed to the dealership this morning after trying again after I get a ride in to work and the same thing happens. They call me up today and say my Greddy Boost Gauge has shorted out and drained the battery so low that it won't start the car. They say the short (I think this is what it was) caused the clock to reset and it drained the battery too low.

I think this is total BS because if the gauge was shorting out, the clock would never come on because it would always be bypassed. So now they're trying to charge me for that "diagnosis" and the tow truck (apparently a $20 premium even when I set up the tow truck).

Has anyone else experienced a similar problem, i.e. the clicking sound? This is at the new "Signature" dealership for the Washington-Baltimore area. I expect a lot more from Subaru from a dealership of this caliber.
* Registered users of the site do not see these ads.
TwinkE is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Took out ac compressor, car wont start sanovichleo Electrical & Lighting 2 04-29-2010 04:46 PM
Car wont start after boost gauge install burnrubber Electrical & Lighting 0 04-18-2010 04:24 PM
Car wont start. Shorting problem? UFoFuN04 Newbies & FAQs 26 03-31-2009 11:18 PM
Electrical/Battery Problem? Car Wont Start Help! illmattic016 Factory 2.0L Turbo Powertrain 11 07-21-2006 05:34 AM
Electrical problem.car wont start. Any Suggestions? zerog Electrical & Lighting 2 05-01-2005 04:54 PM


All times are GMT -4. The time now is 06:13 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.