Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-14-2002, 01:41 PM   #1
miRo009
Scooby Newbie
 
Member#: 19618
Join Date: Jun 2002
Location: syracuse university
Vehicle:
1999 Impreza 2.5rs
white

Default Help my car out

I was driving my car to school one morning when my car did somehting really wierd. I was in second gear barely pressing the gas, and then i pressed the peddle about 75 percent. My car started to go but then around 4k rpms my car jerked and it was like the fuel cut out. It happened a week later except i was in 4th and was barely pressing hte gas then floored it and the same thing happened. Each time it happend i got scared and put it in neutral immediatly and i dont know wut exactly happened. Maybe it could be from the cold, but my car was at the normal temperature both times. My car is a 99 rs with 50k miles on it. Another thing is about a week before the first time i took out the intake snorkus stuff, but i havent had time to recet the ecu. Any help would be greatly appreciated, cuz at the moment i feel like i have to drive like a grandma. _MIKE
* Registered users of the site do not see these ads.
miRo009 is offline   Reply With Quote
Old 12-14-2002, 02:40 PM   #2
HndaTch627
Scooby Guru
 
Member#: 6551
Join Date: May 2001
Chapter/Region: MWSOC
Location: Carol Stream, IL
Vehicle:
'01 GC8 Dinged STM
'09 Concours 14 ABS Black

Default

sounds kind of like a bad MAF to me...99's were famous for it, the only other possiblity is you have a MAJOR vaccum leak that's causing the car to lean out under load and the ECU is just getting confused and enabling fuel cut to defend itself from damage.

Jeremy
HndaTch627 is offline   Reply With Quote
Old 12-14-2002, 04:57 PM   #3
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

www.mysubaru.com

you can put your information in there and see if you car is part of the 99s MAF recall.

Jay McDade
munkis is offline   Reply With Quote
Old 12-14-2002, 05:47 PM   #4
miRo009
Scooby Newbie
 
Member#: 19618
Join Date: Jun 2002
Location: syracuse university
Vehicle:
1999 Impreza 2.5rs
white

Default

Hey, i just remembered, when i took my snorkus out, i also took the maf off. There was a rubber ring that went in between the maf and the filter. I forgot to put that back in. Could that be the answer. Oh, and i already got the new maf about 2 months ago. Hopefully this is nothing serious.
miRo009 is offline   Reply With Quote
Old 12-14-2002, 07:23 PM   #5
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Put that back in, I doubt that would affect it too much because its before the MAF, it would have to be a substantial vacuum leak 'after' the MAF, as in air being introduced into the engine that the MAF doesnt register, there for the ECU does not 'see' the air, causing it to run lean...

reset the ECU also, check all your other connections.

it could also be an ignition system problem, such as a misfire, your miles getting pretty high and the subaru oem wires are not known for longevity and tend to go bad pretty early.

Thats what I would be looking at next if your not throwing a CEL.

Jay McDade
munkis is offline   Reply With Quote
Old 12-15-2002, 12:03 AM   #6
MattDell
Scooby Guru
 
Member#: 16803
Join Date: Mar 2002
Chapter/Region: International
Location: London, England
Default

My car is doing the same thing, but I've got a MY02. I thought it was just stalling, but when you said "fuel cut," that sounds more like what it is. But I've got a CEL and I'm pretty sure it's my MAP sensor.
MattDell is offline   Reply With Quote
Old 12-15-2002, 08:28 AM   #7
scoobyimprza
Scooby Guru
 
Member#: 24956
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Littlestown PA
Vehicle:
1997 Impreza WRX
Steel Blue Mica

Default

i would get a "fuel cut" too, and it ended up being my coolant temp sensor. get ur CEL code checked though.

Brent
scoobyimprza is offline   Reply With Quote
Old 12-15-2002, 04:08 PM   #8
miRo009
Scooby Newbie
 
Member#: 19618
Join Date: Jun 2002
Location: syracuse university
Vehicle:
1999 Impreza 2.5rs
white

Default

Thanks for all the input. Well i took apart all the intake and maf stuff and put it back on nice and securly. I did notice my filter was all wet, so i guess i was sucking up some water. Then i noticed my inner fender wall, those plastic peices were all falling off, and it must have been sucking up water right off the street, I treid fixing them but all the srews and stuff are broke. Is there a part number for those peices so i could just order new ones, cuz im sure if i bring it to the dealer there gonna charge me an arm and a leg. Im reseting hte ecu now, and if i dont drive in the rain i wont suck up ne water. I also am due for an ignition tune up, so that could be it too. Well, i hope itll be all right. _MIKE
miRo009 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! My car is crapping out on me synickle General Community 4 12-03-2005 12:27 PM
HELP!My car topped out at 140 today. Rickyh Off-Topic 31 10-29-2003 11:40 PM
Im decking my car out...I need a few parts kevinsUBARU Tri-State Area Forum 8 06-25-2001 05:37 PM
Is my car out of the question for a turbo? GregBolby General Forum Archive 4 01-12-2001 07:58 PM


All times are GMT -4. The time now is 07:49 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.