Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-26-2002, 07:35 PM   #1
red of the sun
Scooby Newbie
 
Member#: 17565
Join Date: Apr 2002
Location: Paterson
Vehicle:
2002 wrx sportwagon
red sedona pearl

Default help overheat

my car overheated last night in the snow. i did a search and came up empty handed. this is what happened: i hit a small snow man and was having fun in the snow doin donuts and driftsand what not, then my tirbo is glowin red hot and my car is steamin. what the heck happened? i took the car to the dealership to get it checked out. anyone know what happened?

i know i cant type
so what jus help me plase

thanks
jaime
* Registered users of the site do not see these ads.
red of the sun is offline   Reply With Quote
Old 12-26-2002, 07:43 PM   #2
tekfoc
Scooby Specialist
 
Member#: 21392
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: NEW YORK CITY
Vehicle:
2014 45 AMG MB
WHITE /07 STI IS SOLD

Default

kiss that turbo good bye and maybe your engine also. had that happen to me in my old conquest tsi
tekfoc is offline   Reply With Quote
Old 12-26-2002, 07:44 PM   #3
armand1
Scooby Guru
 
Member#: 10309
Join Date: Sep 2001
Chapter/Region: NWIC
Location: Seattle, WA
Vehicle:
'02 OBS 2-tone!
'95 Montego Miata

Default

Maybe all the snow blocked the air from getting through your radiator, so no cooling, so overheating. You should also check to make sure your fans are working.
armand1 is offline   Reply With Quote
Old 12-26-2002, 07:51 PM   #4
Gil
Scooby Specialist
 
Member#: 20872
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
t3h rubber-neckers
must die!

Default

in addition to having snow packed in your radiator, also take a look at your intercooler.

Did you notice your engine temp??
Gil is offline   Reply With Quote
Old 12-26-2002, 07:53 PM   #5
red of the sun
Scooby Newbie
 
Member#: 17565
Join Date: Apr 2002
Location: Paterson
Vehicle:
2002 wrx sportwagon
red sedona pearl

Default

i let the car cool down for about an hour afterwards.
i started the car back up and no problems what so ever.
weird. but this morning it the gauge went to hot but it did not overheat. it was low on antifreeze so i filled it back up. the gauge went down and again it was fine. i dunno, its actin funny.
i hope nothing is wrong. i will find out from the dealer soon.

Jaime
red of the sun is offline   Reply With Quote
Old 12-26-2002, 07:55 PM   #6
Gil
Scooby Specialist
 
Member#: 20872
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
t3h rubber-neckers
must die!

Default

hmmm. sounds like it COULD get complicated.
Gil is offline   Reply With Quote
Old 12-26-2002, 07:58 PM   #7
red of the sun
Scooby Newbie
 
Member#: 17565
Join Date: Apr 2002
Location: Paterson
Vehicle:
2002 wrx sportwagon
red sedona pearl

Default

the fan was actin funny and no ...in all the fun i did not notice my engine temp.
red of the sun is offline   Reply With Quote
Old 12-26-2002, 08:00 PM   #8
Gil
Scooby Specialist
 
Member#: 20872
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: Rochester, NY
Vehicle:
t3h rubber-neckers
must die!

Default

I think the first question you need to ask is what happened to the coolant. If it got into your engine for whatever reason, then it's gonna be pricey.

good luck with the dealer.
Gil is offline   Reply With Quote
Old 12-27-2002, 09:26 AM   #9
T-WRX
Scooby Specialist
 
Member#: 2468
Join Date: Sep 2000
Chapter/Region: South East
Location: JAX
Vehicle:
08 RS4
05 STi

Default

When you hit the snowman, you may have damaged the radiator, or dislodged a hose. Hopefully the coolant was just spilled due to a loose hose. If the turbo ate it, you are in big trouble.
T-WRX is offline   Reply With Quote
Old 12-27-2002, 12:58 PM   #10
SilverBullet'02
Scooby Newbie
 
Member#: 15835
Join Date: Feb 2002
Location: Louisville, KY
Vehicle:
2002 WRX
Silver

Default

You may want to check the bottom hose and clamp on the radiator. Mine was loose and caused my car to lose coolant and overheat. Luckily, it was discovered before any real problems occured.
SilverBullet'02 is offline   Reply With Quote
Old 12-27-2002, 07:39 PM   #11
red of the sun
Scooby Newbie
 
Member#: 17565
Join Date: Apr 2002
Location: Paterson
Vehicle:
2002 wrx sportwagon
red sedona pearl

Smile

got my car back from the dealer.
no leaks, no radiator problems.
turns out the snowman bent my ac condensor back a bit and my cooling fans were out of allignment.
got it fixed and my problem went away.i wowuld like to thnk u guys for all your help
i really appreiciate it

Jaime
red of the sun is offline   Reply With Quote
Old 12-27-2002, 10:07 PM   #12
Skyline
Scooby Specialist
 
Member#: 6074
Join Date: Apr 2001
Location: New Jersey
Vehicle:
2002 Impreza WRX
Sedona Red Pearl

Default

How much did it cost to repair?

Sounds like you lucked out.
Skyline is offline   Reply With Quote
Old 12-27-2002, 10:50 PM   #13
nqwan
Scooby Specialist
 
Member#: 2916
Join Date: Nov 2000
Chapter/Region: SCIC
Location: OC
Vehicle:
02 duburu arr exu

Default

Quote:
Originally posted by armand1
Maybe all the snow blocked the air from getting through your radiator, so no cooling, so overheating.
happened to makinen in the subaru iirc, heh.
nqwan is online now   Reply With Quote
Old 12-27-2002, 10:56 PM   #14
Skyline
Scooby Specialist
 
Member#: 6074
Join Date: Apr 2001
Location: New Jersey
Vehicle:
2002 Impreza WRX
Sedona Red Pearl

Default

Quote:
Originally posted by nqwan


happened to makinen in the subaru iirc, heh.
Yup, Rally of Sweden. Richard Burns hit a snowbank too, but he stopped to clear the radiator. Tommi didn't and DNF'd.



Skyline is offline   Reply With Quote
Old 12-27-2002, 11:17 PM   #15
Mike Wevrick
RIP 1/19/64 - 7/23/11
Scooby Guru
 
Member#: 24654
Join Date: Sep 2002
Chapter/Region: NESIC
Location: saraseager.com
Vehicle:
1957 Taggart Comet
atlasshruggedpart1.com

Default

I guess now you know not to run over snowmen.
Mike Wevrick is offline   Reply With Quote
Old 12-28-2002, 11:24 AM   #16
red of the sun
Scooby Newbie
 
Member#: 17565
Join Date: Apr 2002
Location: Paterson
Vehicle:
2002 wrx sportwagon
red sedona pearl

Default

it was fun but your right, i don`t plan on doin that again
It cost me 200 bucks. They did a complete check on my cooling system and flushed my radiator too. They also replaced the fans ...i could tell that they are new.
red of the sun is offline   Reply With Quote
Old 12-28-2002, 11:25 AM   #17
red of the sun
Scooby Newbie
 
Member#: 17565
Join Date: Apr 2002
Location: Paterson
Vehicle:
2002 wrx sportwagon
red sedona pearl

Thumbs up

i would like to thank you guys again for all your help and concern.
i posted on the other site too and no one replied to me to help me out. guess i know where to go now for advice.
thanks again everyone
red of the sun is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!! Overheat after tranny work ?? frederik Factory 2.0L Turbo Powertrain 4 03-28-2009 12:23 PM
Overheat?? pls help rip_sti_ra Service & Maintenance 4 08-12-2007 09:49 PM
Car overheats at idle when AC is on--HELP! wjc04wrx Service & Maintenance 5 05-06-2007 08:48 PM
Overheat Help sigma69pi Factory 2.5L Turbo Powertrain 7 09-30-2006 08:21 PM
Help car wants to overheat at idle seven881 Normally Aspirated Powertrain 5 03-16-2003 09:58 PM


All times are GMT -4. The time now is 02:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.