Welcome to the North American Subaru Impreza Owners Club Sunday February 1, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-26-2002, 11:09 PM   #1
Murray
Scooby Guru
 
Member#: 11312
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: ghettoville, PA
Vehicle:
2009 Gray
Legacy 2.5i

Default replaced motor(2.2 to 2.5) and now clutch pedal is on floor!

i was jsut about to start my car for the first time with the 2.5 motor installed, but when i went to push the clutch pedal, i noticed it was about 1 inch from the floor..when you push it, it does move the fork a tiny bit..no where near enough.

the clutch is a cable-operated type(MY97 AWD Impreza L)

anyone have any ideas on what went wrong?

Murray (also posted in Trans. forum)
* Registered users of the site do not see these ads.
Murray is offline   Reply With Quote
Old 12-27-2002, 03:03 AM   #2
Slack
Scooby Specialist
 
Member#: 17548
Join Date: Apr 2002
Location: Atlanta, Ga
Default

Did you make sure to reinstall the clutch spring? I just did a clutch job on my 2.2 and I saw a spring, so I looked it up in the service manual and found out that it was the ?clutch release spring? or something to that effect. I'm guessing when you release the clutch it pulls it back. Also, I'm not sure if this has anything to do with it but the RS clutch pedal sits much lower to the floor than the L.


Mick
Slack is offline   Reply With Quote
Old 12-27-2002, 05:21 AM   #3
Kostamojen
Scooby Guru
 
Member#: 2272
Join Date: Sep 2000
Chapter/Region: BAIC
Location: haha XD
Vehicle:
2013 Subaru 599 :P
Galaxy Blue Sexy

Default

Quote:
Originally posted by Slack
Also, I'm not sure if this has anything to do with it but the RS clutch pedal sits much lower to the floor than the L.
The RS is hydrolic and moves far less of a distance for operation.

Im wondering if there is a compatibility issue between the RS flywheel and the older clutch...
Kostamojen is offline   Reply With Quote
Old 12-27-2002, 06:21 AM   #4
ChicksDigWagons
Scooby Specialist
 
Member#: 20508
Join Date: Jun 2002
Chapter/Region: MWSOC
Location: Ishpeming, MI
Vehicle:
1998 Red Wagon
New Turbo Project...

Default

Just adjust the cable. If the flywheel is placed slightly futher forward than on the 2.2 then a little adjustment should fix it up.
-Brad
ChicksDigWagons is offline   Reply With Quote
Old 12-27-2002, 11:15 AM   #5
Murray
Scooby Guru
 
Member#: 11312
Join Date: Oct 2001
Chapter/Region: Tri-State
Location: ghettoville, PA
Vehicle:
2009 Gray
Legacy 2.5i

Default

i had forgotten about the cable-type clutches needing adjustments after installation..last few clutches i did were cable type, but i dropped the trans, which meant the cable had to come off anyway..and those people actually replacedth e cables as well..in mine the trans stayed, but hte motor, flywheel, clutch and presure plate are "new".
i will go out and adjust the cable shortly..still have to get an O-Ring for #3 injector...
Murray is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
clutch pedal stays on floor when under load? ta ace Transmission (AT/MT) & Driveline 11 12-28-2009 01:04 AM
Help! Rebuilt my motor and now clutch pedal not coming up? mokujin22 Transmission (AT/MT) & Driveline 4 07-24-2007 09:44 AM
Rinsed engine and now oil light is on... ? gopsu Electrical & Lighting 6 04-19-2006 10:18 AM
WRX down for 3 months now and the clutch pedal is dead? Si2WRX Transmission (AT/MT) & Driveline 4 07-12-2004 01:11 AM
replaced motor (2.2 to 2.5) and now clutch pedal is on floor! Murray Transmission (AT/MT) & Driveline 6 12-28-2002 04:45 AM


All times are GMT -4. The time now is 08:46 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.