Welcome to the North American Subaru Impreza Owners Club Wednesday October 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 12-29-2002, 11:48 AM   #1
jkjersey
Scooby Newbie
 
Member#: 8399
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: Mount Laurel, NJ
Vehicle:
GC8 JDM STI V swap
cardinal red

Default Jerky acceleration and sputter all of a sudden

hello, my car is a NA impreza 1995 L I am having problem with
sputter almost like backfire around 200 0 rpm it started 2 days ago it happens in any gear the the car is in @ first it just happened in 2nd now it does 1st -5th.
I baby the car and it has 115k on it. When I first got the car a year and a half ago I put new bosch platinum spark plugs in the car @ around 90,000 miles. Today it got worse happening @ around 2800 rpm and if I tap the gas sharply while it is parked with the parking brake up in neeutral (manual car) it can sputter for a second it feels like a backfire without the backfire sound could it be a sparkplug issue? MAF sensor? Could a PCV valve cause this @ just a certain rpm? please help this car is my daily driver.

thanks,
jay k
* Registered users of the site do not see these ads.
jkjersey is offline   Reply With Quote
Old 12-29-2002, 11:59 AM   #2
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default

Subaru's hate bosch plugs.... Also, have you changed your spark plug wires?
fuel filter?
rhdude is offline   Reply With Quote
Old 12-29-2002, 01:47 PM   #3
jkjersey
Scooby Newbie
 
Member#: 8399
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: Mount Laurel, NJ
Vehicle:
GC8 JDM STI V swap
cardinal red

Default wires?

wires could cause this problem and plugs going foul could cause this problem and the problem would become worse all of a sudden not gradual? Yes I changed the fuel filter. About say 10,000 miles ago. What tools do I need do change the spark plugs? I may be able to ride up to autozone or pepboys and ride back to do it. I mean as far as hands on experience I can change my oil ... Are the spark plugs right behind the wire? I do not have a wrench here, the tools are @ my family's house which is a ways from here. What would be the size wrench I would need to change plugs?
jkjersey is offline   Reply With Quote
Old 12-29-2002, 06:35 PM   #4
rayc
Scooby Guru
 
Member#: 21960
Join Date: Jul 2002
Chapter/Region: Tri-State
Location: Catskill, NY
Vehicle:
2012 Audi S4
09 WRX DGM

Default

Hey, It should be the same as a 2.5. So you would need a 5/8 spark plug socket and at least a 5 to 6 inch extension. Pull the plug wires and plugs are under them.. Very easy job.
rayc is offline   Reply With Quote
Old 12-29-2002, 08:10 PM   #5
ej25power
Scooby Specialist
 
Member#: 14771
Join Date: Jan 2002
Chapter/Region: NWIC
Location: Washington's Mexico aka Tigard
Vehicle:
02 RS
All Silver!

Default

Did you push the plug wires onto the plugs HARD? It might seem like they're on, but they might not be. I made that mistake when I changed my plugs. Cost 100 bucks to figure out I didn't push hard enough. But the symptoms you describes are what I had


Geoff
ej25power is offline   Reply With Quote
Old 12-29-2002, 08:36 PM   #6
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

I would start with the plug wires, especially if they are OEM. Check the plug gap, I would change them with some NGK copper core plugs, you will have to change them every 30k, but they perform better than platinum plugs.

Jay McDade
Lincoln/Mercury/Jaguar Tech
munkis is offline   Reply With Quote
Old 01-04-2003, 12:42 AM   #7
m750
Scooby Guru
 
Member#: 2278
Join Date: Sep 2000
Chapter/Region: NESIC
Location: Pepperell MA
Vehicle:
8Sti | 07 allez
White | Comp

Default

things to check:
plugs
wires
coil
02 sensor

I had similar symptoms when my o2 sensor was bad, and my plugs were loose.

AO
m750 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Whine noise all of a sudden in WRX - all gears at certain times Civ2Sub311 General Community 33 10-20-2014 06:36 PM
No changes to car in 20k and now all of the sudden 18psi spike. MO REX Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 7 05-15-2005 04:44 PM
What's with all the dog killing all of a sudden? now with a sword mr_disco Off-Topic 10 09-02-2004 10:00 PM
24k miles on car and all of a sudden weird grinding noise when braking cold. Eric SS Brakes, Steering & Suspension 5 04-14-2003 07:00 PM
I'm a Subaru pimp and why is AlfaBill's wallet $185 lighter all of the sudden? Opie South East Region Forum 0 11-02-2001 11:19 AM


All times are GMT -4. The time now is 12:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.