Welcome to the North American Subaru Impreza Owners Club Thursday August 28, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-20-2001, 04:33 PM   #1
LaxCat RS
Scooby Newbie
 
Member#: 1815
Join Date: Jul 2000
Location: Bloomfield, Mi, US
Vehicle:
2005 Subaru WRX STi
Blue w/ Gold BBS

Post Weird clutch problem when starting?

I intsalled a j-pipe intake two weeks ago. Ever since then when i start my car i get a loud clunking sound before i let out the clutch. It also happens when im at a stop sometimes. Also what should be my idling rpm?

Thanks Guys!

Kevin Burgess
* Registered users of the site do not see these ads.
LaxCat RS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird clutch problem, similar to my previous if you read it Anhdalai Transmission (AT/MT) & Driveline 6 11-05-2007 02:52 AM
Clutch question when starting from a dead stop Checkered24 Newbies & FAQs 4 10-06-2007 09:45 PM
Weird Clutch Problem bluethomas Transmission (AT/MT) & Driveline 0 02-17-2007 11:13 PM
Weird Clutch Problem lionhearts Normally Aspirated Powertrain 0 10-23-2006 06:05 AM
clutch problem when cold?? Bugsie1 General Forum Archive 3 08-07-2000 12:53 AM


All times are GMT -4. The time now is 10:31 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.