Welcome to the North American Subaru Impreza Owners Club Friday July 25, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 01-06-2003, 10:26 PM   #1
mrmcderm
Scooby Newbie
 
Member#: 25294
Join Date: Sep 2002
Location: Downers
Vehicle:
2003 LR Infiniti G35
WRB WRX Wagon (Sold)

Default Engine Hesitation

I'm getting a weird engine hesitation around 5k-5.5k rpms in all gears in my '03 wrx wagon and was wondering if it was always there and is normal, or if I should be concerned. The only engine mod I have done is to pull the silencer.

I'm running 93oct from various vendors in central illinois, so maybe it's winter gas causing the ecu to pull timing?

I don't have an OBDII connector, or an auxillary ecu so I haven't been able to pull any codes to see if i'm det'ing or not, but I am not hearing anything.

I suppose 5250rpms is about the top of the stock torque curve, but torque isn't droping off smoothly, it feels like the car just stops accelerating until I shift again.

Anyone else have this kind of hesitation? Is this normal?

tia,
m
* Registered users of the site do not see these ads.
mrmcderm is offline   Reply With Quote
Old 01-07-2003, 03:21 PM   #2
mrmcderm
Scooby Newbie
 
Member#: 25294
Join Date: Sep 2002
Location: Downers
Vehicle:
2003 LR Infiniti G35
WRB WRX Wagon (Sold)

Default

bump
mrmcderm is offline   Reply With Quote
Old 01-07-2003, 04:06 PM   #3
Nutter
Scooby Specialist
 
Member#: 7185
Join Date: Jun 2001
Chapter/Region: MWSOC
Location: LITH, IL
Vehicle:
2009 MINI Cooper S
British Racing Green

Default

I get this from time to time on my 03, but when I Drive-It-Like-I-Stole-It it clears up ! But then I only have 2k miles on the car so I have been easy on it until a few weeks ago.

Nothing to worry about unless you start throughing codes/lighting CE lights.
Nutter is offline   Reply With Quote
Old 01-09-2003, 03:05 PM   #4
mrmcderm
Scooby Newbie
 
Member#: 25294
Join Date: Sep 2002
Location: Downers
Vehicle:
2003 LR Infiniti G35
WRB WRX Wagon (Sold)

Default

I'm not getting a CEL, but I still don't think it is normal which is why I asked about it. Any one else experience this or have any insights?
mrmcderm is offline   Reply With Quote
Old 01-09-2003, 03:24 PM   #5
robtmc
Scooby Newbie
 
Member#: 23659
Join Date: Aug 2002
Chapter/Region: HIIC
Location: Kailua Kona HI
Vehicle:
2002 WRX Sport Wagon
Platinum Silver

Default

This post may or may not be applicable. I don't get a hesitation, but my 02 with 91 octane sure feels flat up there at WOT. I started a thread to see if anyone knew if 91 would cause timing to be pulled, but no resolution yet......


http://forums.nasioc.com/forums/show...hreadid=282589
robtmc is offline   Reply With Quote
Old 01-09-2003, 07:03 PM   #6
SubbyRS
Scooby Newbie
 
Member#: 17193
Join Date: Apr 2002
Location: Brisbane, Australia
Vehicle:
1991 Legacy RS
White

Default

does it hesitate beyond 5500rpm? in other words is it a flat spot as opposed to running out of puff....
SubbyRS is offline   Reply With Quote
Old 01-10-2003, 12:10 AM   #7
mrmcderm
Scooby Newbie
 
Member#: 25294
Join Date: Sep 2002
Location: Downers
Vehicle:
2003 LR Infiniti G35
WRB WRX Wagon (Sold)

Default

It really feels it instantly stops pulling...I can let the rpms build up through 6k, but I don't bother...there is a noticible drop in torque at around 5250 and I don't think it was there before. I'm going to try resetting my ECU and see what that does for me.
mrmcderm is offline   Reply With Quote
Old 01-10-2003, 01:37 AM   #8
swan
Scooby Newbie
 
Member#: 31621
Join Date: Jan 2003
Location: Jhb, SA
Vehicle:
2002 WRX
white

Default

Does it feel as if the engine totally cuts out? Could be the ECU detecting overboost and cutting fuel?
swan is offline   Reply With Quote
Old 01-13-2003, 12:55 PM   #9
mrmcderm
Scooby Newbie
 
Member#: 25294
Join Date: Sep 2002
Location: Downers
Vehicle:
2003 LR Infiniti G35
WRB WRX Wagon (Sold)

Default

No, it is definately not cutting fuel...I know what that feels like, and it wouldn't be from overboost...the only thing aftermarket on the car is the boost gauge and it has never gone above 15psi.

Not really sure what the problem is, I suppose I'll just have to get the OBDII kit and software and see if it's pulling timing.
mrmcderm is offline   Reply With Quote
Old 01-13-2003, 08:28 PM   #10
Bardiel
Scooby Newbie
 
Member#: 11435
Join Date: Oct 2001
Location: NY, PA
Vehicle:
2002 Sleeper Impreza
Blackie:)

Default Yup same thing happen to me

Yeah, this also happened to me. I did the grounding mod and it took care of that. Apparently, some of the the WRX models that came out wasn't grounded good enough. So, I bought some 8 gauge wires and ground it in 5 different places in the engine bay and the hesitation is gone....at least I don't feel it anymore.

Bardiel
Bardiel is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Hesitation and Check Engine Light Bricoleur Outback Forum 2 03-22-2004 08:09 AM
engine hesitation, revisited (no enginemanagement) vile Factory 2.0L Turbo Powertrain 8 02-05-2003 03:16 AM
Engine hesitation at shift? DtownIan Factory 2.0L Turbo Powertrain 1 01-09-2003 06:01 PM
Stupid Engine Hesitation Rags Normally Aspirated Powertrain 12 02-26-2002 09:19 PM
Weird engine hesitation and CEL Impreza25RS Normally Aspirated Powertrain 1 01-08-2002 03:24 AM


All times are GMT -4. The time now is 09:42 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.