Welcome to the North American Subaru Impreza Owners Club Sunday September 14, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-28-2001, 06:59 PM   #1
scottsubarus
Scooby Newbie
 
Member#: 5336
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: Omaha, Nebraska
Vehicle:
1992 SVX
Black

Angry intake problem/question please help

JCsports intake has been on my wife's 97 Legacy GT(auto) for a couple weeks and she loves the sound! last night my son drove the car to work and said that on HARD accleration from a dead stop he thought the moter had died. He said that he has done that b4 and it took off fine. I checked all clamps/fittings ect all seemed tight still has anyone else had this happen? what should I check next?? Thanks!
* Registered users of the site do not see these ads.
scottsubarus is offline   Reply With Quote
Old 04-28-2001, 07:51 PM   #2
SkToBe
Ghost Mod
Moderator
 
Member#: 1278
Join Date: Apr 2000
Chapter/Region: MAIC
Location: Manassas, VA
Vehicle:
2001 RS
Aspen White

Post

Was she hitting the rev limiter?
SkToBe is offline   Reply With Quote
Old 04-28-2001, 08:25 PM   #3
scottsubarus
Scooby Newbie
 
Member#: 5336
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: Omaha, Nebraska
Vehicle:
1992 SVX
Black

Post

No it didn't take off acted like nothing was there for a few seconds, when you backed off the gas it took off fine
scottsubarus is offline   Reply With Quote
Old 04-28-2001, 08:36 PM   #4
SkToBe
Ghost Mod
Moderator
 
Member#: 1278
Join Date: Apr 2000
Chapter/Region: MAIC
Location: Manassas, VA
Vehicle:
2001 RS
Aspen White

Post

Sorry, no experience with auto's... (never owned one, but I'm sure someone here has some thoughts on what the problem might be)
SkToBe is offline   Reply With Quote
Old 04-28-2001, 09:37 PM   #5
Really_Soaked
Scooby Newbie
 
Member#: 4992
Join Date: Mar 2001
Location: Revelstoke BC, CANADA
Vehicle:
2000 Impreza 2.5 RS
Blue Ridge Pearl

Post

This happened to a friend of mine with his legacy wagon.

It just acted like really bad throttle response. Check the airflow sensor (MAF or MAP). You can also try just re-setting the ECU (unplug the negative terminal of the battery for 30 mins).

Best of luck.
-Simon
Really_Soaked is offline   Reply With Quote
Old 04-28-2001, 11:38 PM   #6
bratmantlz
Scooby Specialist
 
Member#: 3231
Join Date: Dec 2000
Chapter/Region: RMIC
Location: colorado springs colorado usa
Vehicle:
88 626 Turbo
white

Smile

its an auto? it bogs down on hard WOT starts? am i right or am i correct? usually the jcsports intakes do loose some low end. i have a S-AFC to correct it.
Brian
bratmantlz is offline   Reply With Quote
Old 04-29-2001, 10:41 AM   #7
scottsubarus
Scooby Newbie
 
Member#: 5336
Join Date: Mar 2001
Chapter/Region: MWSOC
Location: Omaha, Nebraska
Vehicle:
1992 SVX
Black

Post

Yes it's an automatic. when it acts up it's like someone shut off the engine for 2/3 seconds. I would have never noticed it but I don't romp on the gas from a dead stop with her car, but with a 16yr old son it's a diffrent story! I'll try resetting the ECU and see what happens
scottsubarus is offline   Reply With Quote
Old 04-29-2001, 10:45 AM   #8
AccidenT
Scooby Specialist
 
Member#: 2024
Join Date: Aug 2000
Chapter/Region: NESIC
Location: South Portland, ME
Vehicle:
2005 Legacy 2.5i
Atlantic Blue Pearl

Post

I have a weapon*R intake (similar to JC-Sports). The other day I was starting from a stop on a hill and I thought my car was going to die. It was bogging and bucking so I pushed in the clutch, let off the gas, gave it gas and then shifted into first. After that it was fine. I don't know if it was fuel starvation or what. I've had the problem one other time starting from a stop on a very slight hill...
AccidenT is offline   Reply With Quote
Old 04-29-2001, 03:09 PM   #9
HamFist
Scooby Specialist
 
Member#: 2112
Join Date: Aug 2000
Chapter/Region: MWSOC
Vehicle:
2000 Impreza 2.5RS
BRP

Post

umm...the only two things I've messed with for bogging and such were the fuel filter, plugs, and o2 sensor. It's got 27k on it already and I've had it a year and a half. The sensor was a warranty issue, and the plugs and fuel filter were just maintenance/tuning. Runs fine so far, mods and all. If it's a bad MAF, I'd be very surprised. Check the simple stuff first.

Gary
HamFist is offline   Reply With Quote
Old 04-29-2001, 03:18 PM   #10
KeithRS
Scooby Newbie
 
Member#: 3436
Join Date: Jan 2001
Location: Bongistan
Vehicle:
1987 Rockhopper
Yellow

Exclamation

Sounds like a classic clogged fuel filter- when was the lsat time it was replaced?

When they get old and clogged, you start to get a little bit of hesitation on hard acceleration or sustained high speed driving. Then the engine starts to cut out when you are accelerating from a stop. Try replacing it before you do anything else if you haven't already.
KeithRS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
INTAKE QUESTION please help nayank24 Factory 2.5L Turbo Powertrain 2 09-19-2007 01:08 PM
Intake question... please help! blt Factory 2.5L Turbo Powertrain 10 02-01-2006 08:57 PM
Intake Silencer Removal Question, Please HELP!! Inprogress Newbies & FAQs 28 08-06-2004 10:00 PM
('93-'01) please help!! 98 GC8 bumper conversion question, please help!! nateconnella Impreza Forum 10 05-13-2003 05:50 PM
('93-'01) please help!! 98 GC8 bumper conversion question, please help!! nateconnella Impreza Forum 1 05-05-2003 10:11 PM


All times are GMT -4. The time now is 10:43 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.