Welcome to the North American Subaru Impreza Owners Club Sunday August 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-29-2001, 09:18 PM   #1
RebelINS
Scooby Specialist
 
Member#: 2953
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Rochester, MI, USA
Vehicle:
2000 Impreza 2.5RS
2005 Impreza WRX STi

Post Rich run condition causing CE light

My CE light seems to come on about once a week, and today when it came on I looked over at my Air/Fuel ratio gauge, and it said my car was running as rich as the gauge could register. I was thinking that maybe this rich run condition was causing bad emissions, and my o2 sensor was setting off the CE light. Does this sound right to anyone else? The light will come on only when I am at WOT. I had my CE light come on for no reason before, and I took it too the my car to the dealership, and all they did was replace the o2 sensor. If it is coming on from a rich run condition, is there anything that Subaru can do to fix this problem. My car is still under warranty, so I would like to get rid of this problem. Also, when the light comes on it stays on for only like a day, so when I get to the Subaru delearship with no CE light, are they just going to tell me that nothing is wrong? I know I am asking alot of questions but I just have one or two more. If Subaru doesn't do anything would a S-AFC work to lean out my mixture, even though I have a 2000 with a MAP sensor? If that won't work, is there anything else I could do to lean out my mixture up top. The only mod I have is an intake.
* Registered users of the site do not see these ads.
RebelINS is offline   Reply With Quote
Old 03-30-2001, 05:17 AM   #2
dlkennedy
Scooby Newbie
 
Member#: 3005
Join Date: Nov 2000
Location: State College, PA, USA
Post

My guess is that you have another bad O2 sensor and that is what is causing the rich condition.
dlkennedy is offline   Reply With Quote
Old 03-30-2001, 07:25 AM   #3
Jaxx
NASIOC Supporter
 
Member#: 177
Join Date: Aug 1999
Chapter/Region: NWIC
Location: Boise,Idaho,USA
Vehicle:
The 93 Imp W/EJ20K
flat black

Post

yeah back to dealer .. when they are done change your spark plugs...if you have been running rich for a long time they will be.. well..... icky ...plus its only $8
Jaxx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Could rich condition cause CEL (UTEC)? ScoobieSnaX Engine Management & Tuning 3 10-09-2002 10:09 AM
CE light, car runs fine? ilmaestro Normally Aspirated Powertrain 9 04-05-2002 10:41 AM
My car is running BETTER with the CE light on..!!??(kinda long) Aaron'z 2.5RS Normally Aspirated Powertrain 10 01-23-2002 12:48 AM
('93-'01) Turbo kit and CE light issues - what causes it and how to prevent it? Jessie James Impreza Forum 4 06-05-2001 09:12 AM
Someone running an ITC without a CE light TMR Impreza Normally Aspirated Powertrain 6 10-16-2000 12:49 AM


All times are GMT -4. The time now is 04:08 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.