Welcome to the North American Subaru Impreza Owners Club Tuesday July 29, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-05-2003, 09:43 PM   #1
aj's25rs
Scooby Newbie
 
Member#: 30160
Join Date: Nov 2002
Location: l.i n.y
Vehicle:
9900 2.5rs
rbp,srp

Default piaa bulbs went out!!

went to start the car tonight and turned the lights on to see both low beams blew. i pulled every fuse relay to check but its the bulbs. so $65 down the drain. i done with these bulbs im just going to put basic bulbs in the car they seem to last longer.
* Registered users of the site do not see these ads.
aj's25rs is offline   Reply With Quote
Old 02-06-2003, 05:55 PM   #2
scoobyimprza
Scooby Guru
 
Member#: 24956
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Littlestown PA
Vehicle:
1997 Impreza WRX
Steel Blue Mica

Default

PIAAs are under a one year warranty. i had a low beam go out and took them back to where i got them and they replaced them for free. what u'll actually have to do is send them back to PIAA and they will send u new ones. where i bought them, i just gave them cash to ship them back and they gave me new ones.

Brent
scoobyimprza is offline   Reply With Quote
Old 02-06-2003, 06:02 PM   #3
kenchan
Scooby Guru
 
Member#: 15106
Join Date: Feb 2002
Default

hummmm... im not saying that you made an error during
installation, but mine are lasting longer than 16months.

its always best to turn off your lights before firing up or
shutting off your engine.
kenchan is offline   Reply With Quote
Old 02-06-2003, 06:10 PM   #4
JOHN16V
Scooby Newbie
 
Member#: 21491
Join Date: Jul 2002
Chapter/Region: NWIC
Location: Minneapolis, MN
Vehicle:
2000 Subaru Impreza
2.5RS BRP Sedan

Default

So, what's new?? ( I give up on those $80.00 bulb long time ago......when money stop coming out of the ATM)

Just go with the GE Cool Blue, they are much bighter than the stock .....I install a pair 2 year ago and it still burning!!

JOHN16V is offline   Reply With Quote
Old 02-06-2003, 06:20 PM   #5
scoobyimprza
Scooby Guru
 
Member#: 24956
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Littlestown PA
Vehicle:
1997 Impreza WRX
Steel Blue Mica

Default

hmm, thats not a bad idea, i leave my lights on when i turn my car off. u also wanna be careful not to touch the bulb, that might have happened since they both went out at the same time. u can also get cheap bulbs off ebay.

Brent
scoobyimprza is offline   Reply With Quote
Old 02-07-2003, 02:40 AM   #6
CosmoTheCat
Scooby Newbie
 
Member#: 3409
Join Date: Jan 2001
Chapter/Region: NWIC
Location: Woolley
Vehicle:
1998 Ram 2500
Green.

Default

I'm going to take a stab in the dark (rim-shot please?)

Did you by any chance buy higher wattage bulbs than stock/legal (ie 80/100, and I'm not talking about the 55=80 xtra technology crap).

I buy Hella H4 80/100s and they last a month or three then burn out. When one goes the other usually follows. They burn out fast because they're a lot hotter than the headlight assembly was designed for, therefore they're overheating. I accept this with my Hellas, but at $12 a piece I can live with it.
CosmoTheCat is offline   Reply With Quote
Old 02-07-2003, 08:19 AM   #7
scoobyimprza
Scooby Guru
 
Member#: 24956
Join Date: Sep 2002
Chapter/Region: MAIC
Location: Littlestown PA
Vehicle:
1997 Impreza WRX
Steel Blue Mica

Default

mine are the 125/135w and when my one low beam went out, i changed back to the stock bulbs like 2 days later and the other bulb hadn't burned out.

Brent
scoobyimprza is offline   Reply With Quote
Old 02-07-2003, 01:57 PM   #8
cRayZee
Scooby Specialist
 
Member#: 6271
Join Date: May 2001
Location: San Jose
Vehicle:
2001 2.5RSTi
2007 Legacy Spec B

Default

I had PIAA extreme whites on my car... They lasted about 10k mi or so, but I do that distance in ~3-4 months. Instead of paying $50 per set and replacing them every couple months, I bought a set of HID's instead. They're much much brighter and last a lot longer

-vic
cRayZee is offline   Reply With Quote
Old 02-08-2003, 02:51 AM   #9
Basshead
Scooby Specialist
 
Member#: 112
Join Date: Jul 1999
Chapter/Region: NWIC
Location: Snohomish, WA
Vehicle:
2011 Jetta TDI
Black

Default

ditto, after paying over $400 over the past few years for PIAA's it's time to spring for HID's....coulda bought em already!!..
Basshead is offline   Reply With Quote
Old 02-08-2003, 09:21 AM   #10
aj's25rs
Scooby Newbie
 
Member#: 30160
Join Date: Nov 2002
Location: l.i n.y
Vehicle:
9900 2.5rs
rbp,srp

Default

mine were the stock wattage. they werent touched or anything and both went oput the same time. i put stockers in since they dont go out as fast. im tired of driving places and people telling me i have a light out.
aj's25rs is offline   Reply With Quote
Old 02-17-2003, 10:15 PM   #11
wrxracer
Scooby Specialist
 
Member#: 5275
Join Date: Mar 2001
Location: corpus christi texas U.S.
Vehicle:
2002 impreza WRX
WR BLUE

Default piaa's

knock on wood.. i have the extreme whites also. now for right at a year and no probs... i have good luck with all my PIAA bulbs..wife's dodge has them also 3years+....good luck either way, replace or HID's..
wrxracer is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
both High beam and Fog light bulb went out at the same time :( Mike7 Electrical & Lighting 1 09-28-2009 11:30 AM
bulb went out again :( Osram Nightbreaker +90 MyScoobie28 Electrical & Lighting 10 07-11-2009 03:01 PM
PIAA bulbs vs Philips.. Whats a good bulb? ThreeSheets2116 Electrical & Lighting 7 10-31-2008 09:50 AM
My 1st and 2nd gear went out! Need help went taking out tranny? Kavaoski_08 Transmission (AT/MT) & Driveline 4 09-29-2007 10:16 PM
morette bulbs, mine went out teamslow wrx Electrical & Lighting 1 08-13-2003 08:02 AM


All times are GMT -4. The time now is 04:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.