Welcome to the North American Subaru Impreza Owners Club Saturday December 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-11-2003, 08:48 PM   #1
MrSwede
Scooby Specialist
 
Member#: 9487
Join Date: Aug 2001
Location: SW MO
Vehicle:
2002 Impreza WRX
Silver Surfer

Default Fuse for tail lights keep blowing?

As the title says. I have a TXS Stage 2 and a boost gauge, can these cause the problem? The fuse keeps blowing every couple of weeks. Help please.
* Registered users of the site do not see these ads.
MrSwede is offline   Reply With Quote
Old 02-11-2003, 09:50 PM   #2
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default Re: Fuse for tail lights keep blowing?

Quote:
Originally posted by MrSwede
As the title says. I have a TXS Stage 2 and a boost gauge, can these cause the problem? The fuse keeps blowing every couple of weeks. Help please.
Did you grab power off of something on the taillight circuit? If so, check the connection for a possible short/exposed wire - check the connectors and see if there is any way a ground wire could contact a power wire.
DrD is online now   Reply With Quote
Old 02-12-2003, 08:36 PM   #3
SubbyRS
Scooby Newbie
 
Member#: 17193
Join Date: Apr 2002
Location: Brisbane, Australia
Vehicle:
1991 Legacy RS
White

Default

In my experience tail light problems like this are mostly caused by wiring (usually ground) issues.....usually an easy place to start looking too...
SubbyRS is offline   Reply With Quote
Old 02-13-2003, 03:29 PM   #4
kenchan
Scooby Guru
 
Member#: 15106
Join Date: Feb 2002
Default

or did you hook up an aftermarket horn directly to your
hornharness? i think they run off the same fuse if im not mistaken.
kenchan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Looking for Tail Light Swap WI / IL 07 for 05 HELPr Mid West Subaru Owners Club Forum -- MWSOC 0 11-20-2009 01:53 PM
Any options for tail lights for an 02 wagon? Sir Mangina III Interior & Exterior Modification 2 12-21-2006 03:51 PM
fuse for 4eat to keep it from shifting? snipes Transmission (AT/MT) & Driveline 2 04-21-2005 10:16 PM
question for tail light fitment q0Y0p Electrical & Lighting 2 04-24-2004 03:27 PM
black outs for tail light? smjkxsnoopy Interior & Exterior Modification 9 02-12-2003 06:31 PM


All times are GMT -4. The time now is 03:53 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.