Welcome to the North American Subaru Impreza Owners Club Friday August 26, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 06-25-2015, 10:00 AM   #1
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default Lug nut help please

I just bought tenzo type m wheels used and obviously my stock lug nuts are to fat. That would just be to easy

I read I need the tuner lugs because we they're thinner . I'm pretty sure my 13 WRX is a m12- 1.5 thread

http://m.pepboys.com/product/details/9167643/00054

Will these work and are they too cheap or are they decent?

Thanks , heading to pep boys in an hour
* Registered users of the site do not see these ads.
Jcerillo70 is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 06-25-2015, 10:13 AM   #2
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default

Or if I waited and got good ones from rally sport any suggestions? Stock studs
Jcerillo70 is offline   Reply With Quote
Old 06-25-2015, 10:44 AM   #3
Mach V Dan
NASIOC Vendor
 
Member#: 12029
Join Date: Nov 2001
Chapter/Region: MAIC
Location: Sterling, VA
Default

Quote:
I'm pretty sure my 13 WRX is a m12- 1.5 thread
Your Subaru uses a M12 x 1.25 thread pitch, not 1.5.

--Dan
Mach V
Mach V Dan is offline   Reply With Quote
Old 06-25-2015, 10:57 AM   #4
ctfo1885
NASIOC Supporter
 
Member#: 413997
Join Date: Feb 2015
Chapter/Region: MAIC
Location: Alexandria, Va
Vehicle:
2013 STI Hatch
Plasma Blue Pearl

Default

Quote:
Originally Posted by Mach V Dan View Post
Your Subaru uses a M12 x 1.25 thread pitch, not 1.5.

--Dan
Mach V
^^ This and check with our local vendors like Mach V and see if they have any they can sell you.
ctfo1885 is offline   Reply With Quote
Old 06-25-2015, 12:41 PM   #5
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default

Jcerillo70 is offline   Reply With Quote
Old 06-25-2015, 12:41 PM   #6
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default

I ordered these on Amazon , hope they work
Jcerillo70 is offline   Reply With Quote
Old 06-25-2015, 03:23 PM   #7
Tire Rack Moderator
 
Member#: 1215
Join Date: Apr 2000
Location: The Tire Rack
Vehicle:
800 -428-8355
ext. 4362

Default

Your car uses a M12 x 1.25 thread pitch

check out these lugs that would meet your needs
Luke@tirerack is offline   Reply With Quote
Old 06-25-2015, 07:24 PM   #8
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default Lug nut help please

Will the ones I bought work for the small holes?
Jcerillo70 is offline   Reply With Quote
Old 07-02-2015, 08:48 AM   #9
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default

Update: the lugs I bought on Amazon somehow self loosened themselves. After I hit a bump during roadwork I heard the wheel banging back and forth against the hub. What a night mare. All lugs were tight and torqued except the front passenger.

I can only think someone loosened them, or the lugs I bought were such junk they didn't seat.

I'm gonna order the ones from tire rack now, since they're a confirmed fit
Jcerillo70 is offline   Reply With Quote
Old 07-02-2015, 11:57 AM   #10
Kami Speed
NASIOC Vendor
 
Member#: 96479
Join Date: Sep 2005
Chapter/Region: South East
Location: Orlando, Fl.
Vehicle:
2013 WRX
S2000, Yaris, CR-Z

Default

We sell Muteki lug nuts all the time, never had a problem. They must not have been properly torqued down and/or someone loosened them and forgot to tighten them back up.
Kami Speed is offline   Reply With Quote
Old 07-02-2015, 01:09 PM   #11
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default

Someone had to loosen them, the back lot should be in camera
Jcerillo70 is offline   Reply With Quote
Old 07-03-2015, 08:23 PM   #12
vision.dynamix
Scooby Guru
 
Member#: 139955
Join Date: Feb 2007
Chapter/Region: NESIC
Location: Boston
Vehicle:
2015 Subaru STI
Stage e

Default

Or you didnt torque them properly.
vision.dynamix is offline   Reply With Quote
Old 07-03-2015, 11:25 PM   #13
Patrick Olsen
NASIOC Supporter
 
Member#: 120
Join Date: Jul 1999
Chapter/Region: AKIC
Location: Where the Navy sends me...
Vehicle:
1997 Legacy 2.5GT
QuickSilver Metallic

Default

Quote:
Originally Posted by Jcerillo70 View Post
Update: the lugs I bought on Amazon somehow self loosened themselves. After I hit a bump during roadwork I heard the wheel banging back and forth against the hub. What a night mare. All lugs were tight and torqued except the front passenger.

I can only think someone loosened them, or the lugs I bought were such junk they didn't seat.
Apparently only 5 of the 20 were such junk they didn't seat, and through some amazing coincidence you managed to put those 5 all on the same wheel.

Or you didn't torque them properly.

Hmmmm, which is the more likely explanation... ???
Patrick Olsen is offline   Reply With Quote
Old 07-06-2015, 03:18 AM   #14
Jcerillo70
Scooby Newbie
 
Member#: 406715
Join Date: Nov 2014
Chapter/Region: Tri-State
Location: Freehold, NJ
Vehicle:
2013 WRX
WR Blue

Default

And that's always a scenario as well. But I used a Torque wrench.

When I went to switch all the wheels the next day back to stock, all the lugs were not tight as when the stock lugs and wheels are on. With the smaller hole for the tuner lugs on the universal wheels I don't have experience with.

Another thing is I ordered the hub rings, wondering if that's something I need for it to work better?

A guy at work who is a self proclaimed expert on everything mentioned that the wheel could be bent... They're used wheels so who knows, I have to research what to look for in that
Jcerillo70 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

All times are GMT -4. The time now is 02:23 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.