Welcome to the North American Subaru Impreza Owners Club Sunday November 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Tri-State Area Club
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Regional Areas > Tri-State Area Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-25-2003, 09:45 PM   #1
speedrkj
Scooby Specialist
 
Member#: 14482
Join Date: Jan 2002
Location: King of Prussia, PA
Vehicle:
2002 WRX Sedan
Aspen White

Default Check engine Light Question P1443

Driving home tonight my check engine light came on so I pulled out my scanner and it read code P1443. I cleared the code and all seems ok but just thought I would ask to make sure....

Looked up in code database and it said:

* Evaporative emission control system vent control function problem

Can someone tell me what this is and if I should take it in for service??


Thanks
* Registered users of the site do not see these ads.
speedrkj is offline   Reply With Quote
Old 02-25-2003, 10:22 PM   #2
RidinLow
Scooby Guru
 
Member#: 329
Join Date: Sep 1999
Chapter/Region: Tri-State
Location: NJ
Vehicle:
1995 325i
Arctic Gray

Default

Isn't that the loose gas cap one?
RidinLow is offline   Reply With Quote
Old 02-25-2003, 10:34 PM   #3
vadim
Scooby Newbie
 
Member#: 31981
Join Date: Jan 2003
Location: Smoke Stacks and Factories
Vehicle:
2003 WRX Sedan
Silver

Default

where did you get the scanner? I want one too.
vadim is offline   Reply With Quote
Old 02-25-2003, 11:15 PM   #4
speedrkj
Scooby Specialist
 
Member#: 14482
Join Date: Jan 2002
Location: King of Prussia, PA
Vehicle:
2002 WRX Sedan
Aspen White

Default

I have a palm m105 running pocketlogger software

www.pocketlogger.com
speedrkj is offline   Reply With Quote
Old 02-26-2003, 12:49 PM   #5
PerformanceAutoSolutions
Former Vendor
 
Member#: 853
Join Date: Feb 2000
Chapter/Region: Tri-State
Location: Deer Park, NY, USA
Vehicle:
2011 STI Sedan
Satin White Pearl

Default

you will need a reflash from the dealer for that code
dave
PerformanceAutoSolutions is offline   Reply With Quote
Old 02-26-2003, 05:34 PM   #6
garface
Scooby Guru
 
Member#: 1581
Join Date: Jun 2000
Chapter/Region: Tri-State
Location: yonkers, ny
Vehicle:
MY00 RS/STi7
MY01 RS Both Silverthorne

Default

Quote:
Originally posted by M.S.P.T
you will need a reflash from the dealer for that code
dave
Why do you say that? It's the code for: "Evaporative emission control system vent control function problem". Go tighten your gas cap and drive around for a few days to a week. It could be a leak in the system or that PCV valve or whatever it's called on the engine, but I doubt it. I get it all the time because the Sunoco guy can't tighten the damn gas cap properly.
garface is offline   Reply With Quote
Old 02-26-2003, 07:08 PM   #7
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

the vent control has nothing to do with the gas cap.

Gas cap codes are usually along the lines of "Evap emmissions, small leak deak detected, or gross leak detected''.

This is a malfunction of the evap emmisions purgre valve, or vent solonoid what ever subaru uses.

basically what has happned is the PCM said, yo vent solenoid open up and let all those evap emmissions you've been storing in the charcol canister..back into the engine (usually at highway cruise), but alas the the vent sol wasnt listening..or coudnt open..or didnt get the signal from the pcm....pcm says uh oh something is wrong with my friend the vent solenoid...RED ALERT, trips CEL....hoping someone can fix his friend the vent solenoid.

My guess since M.S.P.T is a subaru dealer, that there is a TSB or special service action, for updating the pcm calibration, if this code is present and no fault can be found with the vent solenoid.

right?

Jay
munkis is offline   Reply With Quote
Old 02-26-2003, 07:30 PM   #8
N'CTRL
Scooby Specialist
 
Member#: 29871
Join Date: Nov 2002
Chapter/Region: Tri-State
Location: Long Island
Vehicle:
2OO2 ~WRX~ Macadamia
Metallic

Default

So that's what those voices are when I'm driving.

Oh, and yes, M.S.P.T. = Metric.

Mike~~
N'CTRL is offline   Reply With Quote
Old 02-26-2003, 08:39 PM   #9
garface
Scooby Guru
 
Member#: 1581
Join Date: Jun 2000
Chapter/Region: Tri-State
Location: yonkers, ny
Vehicle:
MY00 RS/STi7
MY01 RS Both Silverthorne

Default

I got that code read 3 times, always comes on right after I get gas and goes off a few days after I tighten up the cap. I've had it happen close to ten times, but only had it checked three. This was after I got the service bulleting reflash performed as well.
garface is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
check engine light question jlam86 Vancouver Impreza Club Forum -- VIC 7 11-28-2006 07:06 PM
check engine light question - 05 STi STIGuy116 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 06-16-2006 11:25 PM
2005 STi check engine light question STIGuy116 Factory 2.5L Turbo Powertrain (EJ Series Factory 2.5L Turbo) 4 02-27-2006 08:40 PM
Check engine light question.... just one blunt Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 09-26-2004 09:04 PM
[B]Check Engine Light question regarding uppipe/downpipe[/B] Moshpit552 Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 2 08-21-2004 03:36 AM


All times are GMT -4. The time now is 08:23 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.