Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-28-2003, 03:28 AM   #1
S-WRX
Scooby Specialist
 
Member#: 9193
Join Date: Aug 2001
Location: California
Vehicle:
2002 WRX
Silver

Default HKS Downpipe owners - how is the downpipe so far?

Well I would like to know how everyone's HKS downpipe holding up until now.
I got mine roughly about 8 months ago, and its still running great. Although I suspect I have a leak somewhere, the boost is holding up just fine @ 0.9 bar. (No boost controller). I am currently running catless w/ prodrive muffler and the whistle noise is extremely loud after 8 months of running catless.
wondering if its a leak?
* Registered users of the site do not see these ads.
S-WRX is offline   Reply With Quote
Old 02-28-2003, 09:00 AM   #2
ellisz
Scooby Newbie
 
Member#: 15870
Join Date: Feb 2002
Location: S. Indiana
Vehicle:
2002 Impreza WRX
Sedona Red Pearl

Default

I have had mine on since December. I have no leaks and no complaints so far.
ellisz is offline   Reply With Quote
Old 02-28-2003, 11:12 AM   #3
2.5GT
Scooby Specialist
 
Member#: 2697
Join Date: Oct 2000
Location: Olney, MD. Work in McLean, VA
Vehicle:
2000 Celica GT-S
Spectra Blue

Default

I have one on my turbo leg. I didn't have any problems until I started turning up the boost above 1bar. I'm now running 1.15 bar and I'll get some spikes up to 1.18bar, only when boosting, letting off real quick, and then boosting again.
2.5GT is offline   Reply With Quote
Old 02-28-2003, 11:21 AM   #4
Kitt
Scooby Specialist
 
Member#: 24621
Join Date: Sep 2002
Chapter/Region: Tri-State
Location: Long Island, NY
Vehicle:
2006 Legacy GT
2011 Forester XT

Default

Had one on my car for 3,000 mi and no problems, my car runs great!
Kitt is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Momentum EJ5-40T owners, how is it holding up so far? WeloReX Factory 2.0L Turbo Powertrain 8 02-26-2006 10:41 PM
how is rally school so far? spdracr00 North West Impreza Club Forum -- NWIC 5 09-25-2005 03:59 PM
Prodrive Spring owners. How is the ride with the stock struts? mattjk Off-Topic 31 09-25-2004 10:41 AM
Bel radar detector owners - how is the digital voice? ImportVenom Electrical & Lighting 11 08-08-2003 04:33 PM


All times are GMT -4. The time now is 09:33 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.