Welcome to the North American Subaru Impreza Owners Club Thursday April 24, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 02-28-2003, 12:15 PM   #1
tcs007
Scooby Specialist
 
Member#: 4103
Join Date: Feb 2001
Chapter/Region: MWSOC
Location: Madtown
Vehicle:
2003 WRX Wagon
Reddish

Talking Finally got rid of my little yellow friend

About a year ago, I got my exhaust (Brullen headers, custom cat back), and promptly got the 0420 code (No surprise there).
Brullen did a few things, and eventually sent me out their "fix" which consisted of a new cat with a bung welded both before and after, rear O2 wiring to be spliced in (Has a small mylar cap in it), and wiring to extend the front O2 sensor to the new place.
After finally getting off my butt and moving the front O2 sensor to in front of the cat, and replacing replacing both O2 sensors, I no longer have my CE light (I DID NOT replace the rear cap, just to see if it would work).
It's been 12 days, and so far, so good. And now, midrange power is up, bottom torque is good, and my gas mileage has increased dramatically (50 more miles out of the last tankful).


And for those of you who ask "why did you wait so long?"

I'm lazy.
* Registered users of the site do not see these ads.
tcs007 is online now   Reply With Quote
Old 02-28-2003, 04:01 PM   #2
Opie
Floresbian
Moderator
 
Member#: 470
Join Date: Oct 1999
Chapter/Region: South East
Location: Riverview, Florida - U.S.A.
Vehicle:
2015 Forester 2.0XT
'14 XV Crosstrek Ltd

Default Re: Finally got rid of my little yellow friend

Quote:
Originally posted by tcs007
rear O2 wiring to be spliced in (Has a small mylar cap in it),
Do they just sell the capacitor ready to be wired in? ...and which wire did the capacitor get spliced into?

TIA!
Opie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
YAY!!! I finally got rid of my neighbor. Beer:30 Off-Topic 16 10-04-2006 01:51 PM
Finally got rid of the Unichip and got tuned japslapr Mid Atlantic Impreza Club -- MAIC 0 09-21-2006 07:59 PM
Finally got rid of my 19" tv and got this. imdrew12 Off-Topic 16 09-09-2004 07:44 PM
Finally got rid of my RS Fido Tri-State Area Forum 8 07-23-2003 11:52 AM
Awwwww....My little yellow friend came back. And (CEL) is his name. obyone Normally Aspirated Powertrain 8 06-18-2002 08:48 AM


All times are GMT -4. The time now is 07:24 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.