Welcome to the North American Subaru Impreza Owners Club Tuesday September 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-07-2003, 10:14 PM   #1
live311
Scooby Newbie
 
Member#: 10801
Join Date: Oct 2001
Chapter/Region: NESIC
Location: Middletown, CT
Vehicle:
2008 Outback

Question Question about the problem with Magnecor's

I've done lots of searches and found that most people speak very highly of Magnecor spark plug wires. The rest complain about the boots popping off the plugs constantly. It seems that the problem was with the length of the Magnecor boots being about 1/4" shorter than the stock ones. People who had longer plugs didn't have this problem, but others simply couldn't get them to work and had to return the wires.

My question is, does anyone know for sue if Magnecor has resolved this known issue? I have a set of NGK coppers and I was looking for a set of wires to mate them with, and I don't want to deal with the hassle of the wires popping off while I'm driving.

Thanks guys.
* Registered users of the site do not see these ads.
live311 is offline   Reply With Quote
Old 03-08-2003, 02:31 PM   #2
joefocker20
Scooby Specialist
 
Member#: 13745
Join Date: Dec 2001
Chapter/Region: RMIC
Location: Colorado Springs, CO
Vehicle:
2004 STI
Silver

Default

You have to ensure that there is no air under the boot, thats what causes it to pop off.
joefocker20 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Newbie question about the STI pinging problem waploom STi Forum Archive 1 07-28-2003 02:08 AM
a few questions about the GC8 with the EJ20, and USDM scoobies SubyNewbie Mid Atlantic Impreza Club -- MAIC 3 10-28-2002 11:47 AM
Question about the tranny problem HT1 Newbies & FAQs 1 08-13-2002 09:44 AM
Problem with Magnecor's ? Jademonkey Normally Aspirated Powertrain 4 04-19-2002 09:58 AM


All times are GMT -4. The time now is 04:46 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.