Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-12-2003, 02:56 PM   #1
jeffg
Scooby Guru
 
Member#: 2958
Join Date: Nov 2000
Chapter/Region: NWIC
Vehicle:
2001 WRX (GC8)

Default quick Q, poor milage and rough idle - Fuel filter?

Hey everyone. I have done most of the 30k service but I have not done the fuel filter. I thought I had one around the house, but I cant find it.

anyway, I have noticed that my gas milage has really gone down in the last several tanks. I have also noticed that my idle is pretty rough and there is a momend of hessitation on tip in.

Does this sound like a fuel filter problem?

J
* Registered users of the site do not see these ads.
jeffg is offline   Reply With Quote
Old 03-12-2003, 04:57 PM   #2
kickin_81
Scooby Newbie
 
Member#: 16679
Join Date: Mar 2002
Location: MN
Vehicle:
2004 Forester XT

Default

When was the last time you checked your PCV valve or have your air filter cleaned/replaced? Do all three.
kickin_81 is offline   Reply With Quote
Old 03-13-2003, 12:15 AM   #3
nixx
Scooby Newbie
 
Member#: 7581
Join Date: Jun 2001
Location: Toronto, ON
Vehicle:
2001 Impreza 2.5RS
Silver

Default

Try replacing sparkplugs too.
If those don't work I say you need to replace your O2 sensors.
nixx is offline   Reply With Quote
Old 03-13-2003, 10:53 AM   #4
BOY
NASIOC Supporter
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

check your plugs, change your filter (they're cheap and can be bought from any auto parts store), try an ECU reset, if still bad PCV, then look at your O2 sensors.
BOY is offline   Reply With Quote
Old 03-13-2003, 11:00 AM   #5
Eric SS
Sooby Guru
 
Member#: 1914
Join Date: Jul 2000
Chapter/Region: SWIC
Location: 2013 335i, 2011 G37 coupe
Vehicle:
2000 2.5RS w/ EJ22T
swap and N20. gone. : (

Default

I was thinking O2 sensor also.
Eric SS is offline   Reply With Quote
Old 03-13-2003, 11:43 AM   #6
jeffg
Scooby Guru
 
Member#: 2958
Join Date: Nov 2000
Chapter/Region: NWIC
Vehicle:
2001 WRX (GC8)

Default

wouldnt an O2 sensor give a CEL?

I have done plugs, wires, air filter.

I did an ECU reset when I had to pull my Greddy Emanage.

I will do the fuel filter and PCV tomarrow and see if it helps.

J
jeffg is offline   Reply With Quote
Old 03-13-2003, 11:49 AM   #7
BOY
NASIOC Supporter
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

O2 sensors will go for a while without throwing a code. Jeff, you pulled the E-Manage? That was my next thought, the E-Manage but then again low milage should be expected with a piggyback ECU.
BOY is offline   Reply With Quote
Old 03-13-2003, 12:09 PM   #8
jeffg
Scooby Guru
 
Member#: 2958
Join Date: Nov 2000
Chapter/Region: NWIC
Vehicle:
2001 WRX (GC8)

Default

Yeah I pulled and sold the Emanage. Going to a Link+

Is there anyway to check and O2 sensor without a CEL?

J
jeffg is offline   Reply With Quote
Old 03-13-2003, 12:17 PM   #9
BOY
NASIOC Supporter
 
Member#: 232
Join Date: Sep 1999
Chapter/Region: MWSOC
Location: Ft Wayne, IN
Vehicle:
99 RS-T RIP
02 Forster-S

Default

Dealer's scan tool will read voltages and the dealer tech can look up acceptable values. Unfortunately unless you've got a real cool dealer the diagnostic will cost you. The code readers at the auto parts stores only read stored codes so you're kinda SOL.
BOY is offline   Reply With Quote
Old 03-13-2003, 12:29 PM   #10
jeffg
Scooby Guru
 
Member#: 2958
Join Date: Nov 2000
Chapter/Region: NWIC
Vehicle:
2001 WRX (GC8)

Default

We have an OBD reader on laptop. Maybe I will try that.

J
jeffg is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Purge Control Valve and rough idle LiquidForce Factory 2.0L Turbo Powertrain 7 09-30-2010 10:48 AM
Cruise Control Recall and rough idle kensington Mid West Subaru Owners Club Forum -- MWSOC 12 04-30-2004 10:42 PM
Hard starts and rough idle Brooke Legacy Forum 3 12-12-2003 07:00 PM
Hesitation and rough idle JasonRan Electrical & Lighting 5 12-10-2002 12:31 PM
Sputtering and rough idle in the cold? EEK! GooseMan Normally Aspirated Powertrain 6 02-15-2002 11:50 AM


All times are GMT -4. The time now is 03:12 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.