Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-16-2003, 08:47 PM   #1
six6sicks
Scooby Newbie
 
Member#: 28876
Join Date: Nov 2002
Chapter/Region: NWIC
Location: Arlington, Wa
Vehicle:
2000 Impreza 2.5 RS
Blue Ridge Pearl

Default CEL only at idle

I've been having my CEL come on since I put my exhuast on. I never noticed a pattern to it until now. It seems to only happen when I warm my car up in the A.M. Then it only goes off after I drive it for a few days. The pattern seemed to start after I installed my ProECM.
Any thoughts on what it might be. Maybe something just needs to be adjusted?
* Registered users of the site do not see these ads.
six6sicks is offline   Reply With Quote
Old 03-17-2003, 09:32 AM   #2
Pocon
Scooby Newbie
 
Member#: 17479
Join Date: Apr 2002
Location: Toronto, On - Canada
Vehicle:
1999 Impreza WRX
Silverthorn Metallic

Default

You better get that code check with a scanner. Not enough info to diagnose anything.
Pocon is offline   Reply With Quote
Old 03-17-2003, 09:07 PM   #3
sidewayz
Scooby Specialist
 
Member#: 5810
Join Date: Apr 2001
Chapter/Region: Tri-State
Location: Easton PA
Vehicle:
2001 S366 2.5RS

Default

I'll put $50 that its code p0130....I get it all the time when I let my car warm up in the morning for a bit.
sidewayz is offline   Reply With Quote
Old 03-17-2003, 10:15 PM   #4
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

My bet is that your TPS is not adjusted or functioning properly and your IDLE switch is what causes the cel.
ciper is offline   Reply With Quote
Old 03-19-2003, 10:35 AM   #5
Pocon
Scooby Newbie
 
Member#: 17479
Join Date: Apr 2002
Location: Toronto, On - Canada
Vehicle:
1999 Impreza WRX
Silverthorn Metallic

Default

Is the TPS located at the left hand side of the TB? If that's so how can it be adjusted? I suffer from code P1507; idle control system malfunction.
Pocon is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cel flashes at idle?? gleesamo Factory 2.0L Turbo Powertrain 5 04-06-2007 12:59 PM
thin white smoke coming from exhaust only at idle wrx21 Newbies & FAQs 6 12-06-2006 09:26 PM
sb swap misfire only at idle rexnprogress Subaru Conversions 2 10-09-2006 01:26 AM
UTEC: CEL on at idle...goes away after moving waveoff Engine Management & Tuning 3 07-19-2004 10:53 PM
AVCS CEL... only at idle!!! (Own3d again) MK19_ Factory 2.0L Turbo Powertrain 10 07-13-2004 04:28 AM


All times are GMT -4. The time now is 05:44 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.