Welcome to the North American Subaru Impreza Owners Club Saturday August 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Electrical & Lighting

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-20-2003, 05:18 PM   #1
quentinberg007
Scooby Guru
 
Member#: 7887
Join Date: Jun 2001
Vehicle:
2015 Dodge Charger
HelloCatty

Default Replacing dashboard light on 93 L?

As of right now, I am driving around at night with no use of my speedo, tach, or any other gages, for that matter. The bulb behind the gage cluster has either come loose or burnt out. Today I attempted to get back in there, but I'm having a hell of a time getting the gage cluster to come out. Is there some other way to get back in there to check?

I think the bulb may just be loose, concidering the light will come on once every few months, but recently, i've been completely in the dark. (and yes, i checked the dimmer dial on the turn signal switch )

~~Quentin
* Registered users of the site do not see these ads.
quentinberg007 is offline   Reply With Quote
Old 03-20-2003, 06:47 PM   #2
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

if its similar to an RS there should be three bolts that hold the cluster in.

on a 93 there as probably a speedo cable you will have to disconnect out side the car and pull that through, thats probably what is giving you the problem, and why it wont pull out easily.

HTH

Jay
munkis is offline   Reply With Quote
Old 03-20-2003, 11:48 PM   #3
quentinberg007
Scooby Guru
 
Member#: 7887
Join Date: Jun 2001
Vehicle:
2015 Dodge Charger
HelloCatty

Default

thanks i got the cluster unbolted, but it was still being held in by the cables... where do i go to unhook the speedo cable? below the car, under the hood, etc?

~~Quentin (feelin' like a n00b even though i have specialist under my name)
quentinberg007 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
replacing driving light on '06 Tribeca Shootist Electrical & Lighting 0 01-07-2009 06:53 PM
Replacing fog lights on 08 WRX with HID's Prefontaine84 Interior & Exterior Modification 1 07-10-2008 10:28 PM
('93-'01) Installing daytime running lights on 93 Impreza? stigc8 Impreza Forum 1 04-22-2008 03:12 PM
Wanted: Replace my starter on 93 Mitsubishi (easy) TODAY for $40 - Arlington, VA Jessie James Off-Topic 2 09-26-2004 12:04 PM
Dashboard light replacement help! bfg9k Service & Maintenance 2 11-29-2003 03:48 PM


All times are GMT -4. The time now is 10:36 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.