Welcome to the North American Subaru Impreza Owners Club Wednesday August 27, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 03-27-2003, 08:43 AM   #1
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default problem - fluctuating rpm at idle

So yesterday afternoon when I turned on my car my idle speed started fluctuating like crazy; from 1.7 K-> .8 -1.7. It did this once in the winter and stalled. Btw this is an automatic 02 RS - only modifications are ganzflow intake and eibach prokit springs

any ideas why? is this something I should be worried about?


Thanks all
* Registered users of the site do not see these ads.
Jejunum is offline   Reply With Quote
Old 03-27-2003, 08:50 AM   #2
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

Possibly could be the IAC valve. They like to get gunked up on those models.

You can take them apart, see if there is a bunch of carbon and such in there, and if there is you can clean things up, and put it back together.
Legacy777 is offline   Reply With Quote
Old 03-27-2003, 08:53 AM   #3
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default

Quote:
Possibly could be the IAC valve. They like to get gunked up on those models.
ok i have no idea what that means

if i take it to the dealership would they fix this? or know whats wrong?

or if this is something i could do myself give me instructions ?

hehe
Jejunum is offline   Reply With Quote
Old 03-27-2003, 02:20 PM   #4
ImprezaVA
Scooby Specialist
 
Member#: 32846
Join Date: Feb 2003
Chapter/Region: MAIC
Location: Elkton, VA
Vehicle:
1998 Impreza L-SOLD
Arcadia Green

Default

There are so many things that could contribute to a rough idle. Dirty Throttle Body, clogged PCV (it should rattle when you shake it and feel vacuum on it when running and out of valve cover), faulty injectors, as well as an assortment of ignition areas. I'm sure there are some I missed, but I hope you get it fixed.

-Charles-

Last edited by ImprezaVA; 03-28-2003 at 08:58 AM.
ImprezaVA is offline   Reply With Quote
Old 03-27-2003, 03:29 PM   #5
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default

Quote:
There are so many things that could contribute to a rough idle. Dirty Throttle Body, clogged PVC (it should rattle when you shake it and feel vacuum on it when running and out of valve cover), faulty injectors, as well as an assortment of ignition areas. I'm sure there are some I missed, but I hope you get it fixed.
should i call the dealership up and tell them?

is the ganzflow gonna be an issue with them...freaking dealers

my problem with calling them up is the fact that the fluctuation doesnt happen consistenly
Jejunum is offline   Reply With Quote
Old 03-27-2003, 03:41 PM   #6
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

Quote:
Originally posted by Jejunum


ok i have no idea what that means

if i take it to the dealership would they fix this? or know whats wrong?

or if this is something i could do myself give me instructions ?

hehe
It is something you can do yourself. Take a look at this thread.
http://forums.nasioc.com/forums/show...ight=IAC+valve

If you can find a picture of the same MY engine, I can point out which gadget is the Idle Air Control valve.

It's on the top of your throttle body.

Josh
Legacy777 is offline   Reply With Quote
Old 03-27-2003, 03:53 PM   #7
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default

would hte iac have gotten gunked up in only 1 yr of of driving?
oh and most importantly will the dealer fix this or say no u have a non stock intake...?
Jejunum is offline   Reply With Quote
Old 03-27-2003, 06:28 PM   #8
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

Quote:
Originally posted by Jejunum
would hte iac have gotten gunked up in only 1 yr of of driving?
oh and most importantly will the dealer fix this or say no u have a non stock intake...?
It's possible and probable the dealer would give you hell since you have an intake.

I'd just take the little thing off and look and see if it's gummed up. If it is....clean it....if it's not....there's possibly some other issue.

It doesn't do the idle weirdness all the time does it?

I've got a buddy with a 99 RS that does something similar to yours.....we're pretty sure it's the IAC valve. We've been meaning to take it off and clean it, but just haven't got around to it.
Legacy777 is offline   Reply With Quote
Old 03-27-2003, 11:30 PM   #9
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default

Quote:
It doesn't do the idle weirdness all the time does it?
nope not all the time; just randomly grr...

now to find a picture so u can give me explicit instructions (think instructions for the ... short bus)
Jejunum is offline   Reply With Quote
Old 03-29-2003, 08:21 AM   #10
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default

bump; anyone got pics and instructions for me?
Jejunum is offline   Reply With Quote
Old 03-29-2003, 11:21 PM   #11
PumpsGOTAWD
Scooby Specialist
 
Member#: 33175
Join Date: Feb 2003
Chapter/Region: NESIC
Vehicle:
1998 Impreza 2.5RS
98 Unicorn EVO Killer

Default

my 99rs did that rough idel problem too but it ended up that it was becuase my intake was allowing it to much air and also one of the breather hoses had come undone and i didnt know it.. it was suckin it way to much air and the car was runnin like crap . i got a new intake and fixed all the breather hoses how the were supposed to be connected and the problem disapeard. good luck
PumpsGOTAWD is offline   Reply With Quote
Old 03-30-2003, 07:03 AM   #12
Jejunum
Scooby Specialist
 
Member#: 15773
Join Date: Feb 2002
Chapter/Region: MWSOC
Location: Madison
Vehicle:
2011 Impreza WRX
Silver

Default

breather hose?


i thoguht it was impossible to have an intake allow to much air in; one is always below the theoretical maximum
Jejunum is offline   Reply With Quote
Old 03-30-2003, 01:09 PM   #13
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

Quote:
Originally posted by Jejunum
breather hose?


i thoguht it was impossible to have an intake allow to much air in; one is always below the theoretical maximum
The 99's are MAF based engines....so any air coming into the system after the MAF is unmetered, and will make the engine run worse.

Your RS is MAP based which has the sensor around the throttle body area.
Legacy777 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fluctuating RPM at a steady cruise thepigsti Factory 2.5L Turbo Powertrain 17 02-17-2010 08:21 PM
Low RPM at idle dpk777 Factory 2.0L Turbo Powertrain 6 02-26-2007 12:43 PM
Bouncing RPM at Idle...? Chigae Normally Aspirated Powertrain 10 08-02-2006 10:28 AM
Fluctuating RPM at STEADY THROTTLE any RPM mnavarro Factory 2.5L Turbo Powertrain 9 06-21-2005 07:46 PM
RPMs at idle acting funny..? SjpWrx Factory 2.0L Turbo Powertrain 4 06-29-2004 01:06 AM


All times are GMT -4. The time now is 04:35 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.