Welcome to the North American Subaru Impreza Owners Club Thursday October 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-10-2003, 11:28 PM   #1
Eric SS
Sooby Guru
 
Member#: 1914
Join Date: Jul 2000
Chapter/Region: SWIC
Location: 2013 335i, 2011 G37 coupe
Vehicle:
2000 2.5RS w/ EJ22T
swap and N20. gone. : (

Default 24k miles on car and all of a sudden weird grinding noise when braking cold.

a couple weeks ago I started getting this low speed grinding noise from my stock brakes. It's a 2000 2.5RS with 24k miles on it. stock original pads and rotors, Super Blue fluid.

It only happens when I first brake (about first 5 minutes) when I start driving the car. and then once the brakes are warmed up it doesn;t do it. It does however always squeal when braking lightly.

The grinding is almost like a chattering and It really does sound bad and loud. like metal shaving metal when you have a lathe or drill press turning to slow and the bit starts to chatter a little.

I have checked the pads and wear is excelent. still probably a good 1/2 pad left.

I checked everything out and I don;t see a kicked pad or any cracks in the rotors.

Is it just how these stock pads start reacting after a couple years? anyone else with this problem? Thanks!
* Registered users of the site do not see these ads.

Last edited by Eric SS; 04-11-2003 at 11:08 AM.
Eric SS is offline   Reply With Quote
Old 04-11-2003, 08:28 AM   #2
Legacy777
Scooby Guru
 
Member#: 4800
Join Date: Mar 2001
Chapter/Region: TXIC
Location: Houston, Tx
Vehicle:
1990 Legacy & 97 OBS
AWD 6MT EJ22T AWIC Swap

Default

I had a set of axxis metal masters that did this.

It wasn't the best sounding thing to hear.....but I couldn't find anything wrong. So about all I could attribute it to was how the pad/rotor combo is.

You could try sanding down the pad to get a fresh mating surface and see how things are.....if the noise stays....or comes back.....
Legacy777 is offline   Reply With Quote
Old 04-11-2003, 01:39 PM   #3
NTP WRX
Scooby Newbie
 
Member#: 19200
Join Date: May 2002
Chapter/Region: TXIC
Location: Houston
Vehicle:
2006 LGT Wagon
Black

Default

If it wasn't going away, I'd suggest that you've got worn pads. Many companies put in warning "stripes" in their pads that, once the pad is worn to a certain depth, it makes a squealing noise to alert you that you need to replace them. Something to check ? The fact that it goes away suggests it's something else though.

edit: DOH! I didn't see that you had checked the wear and it was okay.

Neil.
NTP WRX is offline   Reply With Quote
Old 04-14-2003, 04:33 PM   #4
barrymazza.com
Scooby Newbie
 
Member#: 5925
Join Date: Apr 2001
Location: Bloomfield, NJ
Vehicle:
2008 R32
Grey

Post

I think it is slight oxidation on the rotor. It is usually scraped off when the brakes are applied once or twice, it usually happens to me the day after it rains...

I could be wrong though.
barrymazza.com is offline   Reply With Quote
Old 04-14-2003, 06:50 PM   #5
dpjef
Scooby Newbie
 
Member#: 18984
Join Date: May 2002
Location: Belgium
Vehicle:
2002 Impreza 2.0
dark blue

Default

Got the same 'problem'. The first few times I hear a slight grinding noise at the front, but maybe it's at the rear too.
I too think that it's oxidation of the rotors. Do you live near the coast ? (i do)
dpjef is offline   Reply With Quote
Old 04-14-2003, 07:00 PM   #6
Eric SS
Sooby Guru
 
Member#: 1914
Join Date: Jul 2000
Chapter/Region: SWIC
Location: 2013 335i, 2011 G37 coupe
Vehicle:
2000 2.5RS w/ EJ22T
swap and N20. gone. : (

Default

Quote:
Originally posted by dpjef
Got the same 'problem'. The first few times I hear a slight grinding noise at the front, but maybe it's at the rear too.
I too think that it's oxidation of the rotors. Do you live near the coast ? (i do)
Opposite... I live in Phoenix. no humidity.
Eric SS is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
metal grinding noise when rolling cold daprez Brakes, Steering & Suspension 0 04-04-2006 11:58 AM
weird noise all of a sudden from turbo 3 days after v34... rbmour Factory 2.0L Turbo Powertrain 7 10-16-2005 10:01 PM
When your car all of a sudden sounds like a HONDA... Firewire Vancouver Impreza Club Forum -- VIC 8 04-21-2005 02:04 PM
Three random thoughts on my mind (comment on any and all of them if you so desire) perret318 Off-Topic 10 08-16-2004 09:45 PM
grinding noise when braking kami333 Newbies & FAQs 6 11-16-2003 04:43 PM


All times are GMT -4. The time now is 12:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.