Welcome to the North American Subaru Impreza Owners Club Thursday April 17, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-24-2003, 10:43 AM   #1
96imp
Scooby Newbie
 
Member#: 28237
Join Date: Oct 2002
Location: ohio
Vehicle:
1996 impreza L
green

Default what offset are you using?

Well we all know the recomended offset for are subarus, But what i and many others wants to know is with complete disregard to our wheel bearing life span what sizes will fit.

so every one come here and list your wheel size (height, width, and offset) what suspension you are running and what tires you have.

oh and if you had to roll your fender or not.
* Registered users of the site do not see these ads.
96imp is offline   Reply With Quote
Old 04-24-2003, 03:47 PM   #2
Billy
Scooby Specialist
 
Member#: 1391
Join Date: Apr 2000
Chapter/Region: E. Canada
Location: Toronto, ON
Vehicle:
1997 GF - silent ed.
12.677@107.87 untuned

Default

Car: 2000 RS2.5
Rims: 17x7.0 +48
Tires: 205/45-17 P-Zero Asimmetrico
Fender Rolling: None
Alignment: Factory
Suspension: WRX SH-RA struts/springs (about 1.5" drop all around)

Verdict: No rubbing on the track or at auto-x.
Billy is offline   Reply With Quote
Old 04-24-2003, 04:15 PM   #3
maciek
Scooby Newbie
 
Member#: 11216
Join Date: Oct 2001
Location: Denver CO
Vehicle:
1991 SS 1998 BG
1996 BD

Default

Car: 1998 Legacy Wagon
Rims: 17 x 7 +53
Tires: 215/45-17
Suspension: KYB AGX w/ Whiteline Springs (1" drop)

No rubbing except once w/ very heavy load in the trunk area.



maciek
maciek is offline   Reply With Quote
Old 04-24-2003, 06:59 PM   #4
jjimpreza
Scooby Newbie
 
Member#: 1269
Join Date: Apr 2000
Chapter/Region: NWIC
Location: Portland, OR
Vehicle:
2000 RS to WRX
to Forester to LGT to GF8

Default

Car: 2003 WRX
Tire: 215/45/17
Rim:OZ Superleggra 17x7
Offset +48



jjimpreza is offline   Reply With Quote
Old 04-25-2003, 10:54 AM   #5
WRXURV8
Scooby Specialist
 
Member#: 14848
Join Date: Jan 2002
Location: Philadelphia
Vehicle:
2007 Tribeca
TS w/ 20" OZ's

Default

Quote:
Originally posted by jjimpreza
Car: 2003 WRX
Tire: 215/45/17
Rim:OZ Superleggra 17x7
Offset +48



Ditto
Suspension: Eibachs (w/ Rear Camber Bolts)
Alignment: Stock
WRXURV8 is offline   Reply With Quote
Old 04-25-2003, 03:41 PM   #6
Chunky_Chicken
Scooby Specialist
 
Member#: 9782
Join Date: Aug 2001
Location: Toronto, Ontario Canada
Vehicle:
2002 E46 M3
Laguna Seca Blue

Default

2002 WRX
Two setups:

Summer: 215/45/17 ET 53mm 17"7"
running -2 front, -1.7 rear camber
DMS 40 suspension lowered 40mm front, 10mm rear

Winter: 195/65/15 ET 35mm 15"7"
running -1.5 front, -1.1 rear camber
DMS 40 suspension, lowered 5mm frint, raised 10mm rear



Slight rubbing on the coilover spring in the rear with the summer setup, not audible, but there are slight marks (track and autoX)

All clear on the winter setup. Without the raised rear and conservative camber, there might be rubbing on the inside of the fender.

-Pete
Chunky_Chicken is offline   Reply With Quote
Old 04-25-2003, 03:48 PM   #7
Opie
Floresbian
Moderator
 
Member#: 470
Join Date: Oct 1999
Chapter/Region: South East
Location: Riverview, Florida - U.S.A.
Vehicle:
2015 Forester 2.0XT
'14 XV Crosstrek Ltd

Default

Car: 2000 RS2.5
Rims: 17x7.0 +53
Tires: 215/45-17 Goodyear Eagle F1 GS-D3
Fender Rolling: None
Alignment: Front Camber: -1.5 the rest: Factory
Suspension: KYB\AGX Struts & SPT/Eibach springs

Verdict: No rubbing on the track or at auto-x.
Opie is offline   Reply With Quote
Old 04-25-2003, 04:06 PM   #8
peepshow
Scooby Specialist
 
Member#: 1777
Join Date: Jun 2000
Chapter/Region: South East
Location: Charlotte, NC USofA
Vehicle:
2005 LGT
#92 FZippy

Default

Car: MY98 Impreza wagon
Wheels: 17x7., +48mm
Tires: 215/45/17 Sumitomo HTR Z 2s
Suspension: Eibach Pro-Kit/KYB AGX
Rubbing: None, ever.


- Trent
peepshow is offline   Reply With Quote
Old 04-25-2003, 05:05 PM   #9
WR xplosive
Scooby Specialist
 
Member#: 33031
Join Date: Feb 2003
Chapter/Region: TXIC
Location: 34.13514,-118.08109
Vehicle:
2008 4B11T
P26 MZ314000

Default

Car: 2003 WRX Wagon
Rims: A-Tech Final Speed 17x7 48mm
Tires: Yokohama AVS ES100 215/45/17
Suspension: TEIN SS lowered to manufacturer's specs.
Rubbing: NONE
WR xplosive is offline   Reply With Quote
Old 04-25-2003, 07:56 PM   #10
Sauceboy01
Scooby Specialist
 
Member#: 13107
Join Date: Dec 2001
Location: Irvine, CA
Default

Track
225/50/16 40mm offset

Street
235/40/17 48mm offset + 5mm spacer


What i never understood was why everyone wants to put such a high offset on their car.. i'm running 40 and it doesn't rub at all! weird.. it looks a lot better in my opinion!

-Danny
Team Darriffftaa
Sauceboy01 is offline   Reply With Quote
Old 04-25-2003, 08:20 PM   #11
tora
Scooby Guru
 
Member#: 5851
Join Date: Apr 2001
Chapter/Region: VIC
Location: Vancouver
Vehicle:
09 Forester XT
+ NA Miata

Default

wheels= 16x7 et53 w/5mm spacers
tires= 225/50R16 Kumho MX

2001 Subaru Legacy Wagon w/ sti 4-pots.
tora is offline   Reply With Quote
Old 04-25-2003, 09:07 PM   #12
BluSuby
Scooby Specialist
 
Member#: 12154
Join Date: Nov 2001
Location: Endless Mtns of PA
Vehicle:
04 Sti
99 Outback

Default

Car: MY02 Impreza WRX
Wheels: 17x7.5, +48mm
Tires: 215/45/17 Firestone Firehawk SZ50ep
Suspension: OEM
Rubbing: None.
BluSuby is offline   Reply With Quote
Old 04-25-2003, 10:49 PM   #13
modvp
Scooby Specialist
 
Member#: 25215
Join Date: Sep 2002
Location: MD
Default

2003 Sedan
5 Zigen fireball 17x7.0 +48mm offset
225/45/17 Kumho 712

http://www.wheelmax.com/Wheels/5zigen/fire-sm.gif
modvp is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
For those of you with Forge BOV's, need help, what spring are you using? vipernj Factory 2.0L Turbo Powertrain 4 01-21-2006 11:55 PM
WRX Sedan with 18" Volk Racing Wheel- what offset are you running? clsmooth71 Brakes, Steering & Suspension 2 05-11-2002 12:27 AM
what BOV are you using? wop Factory 2.0L Turbo Powertrain 25 07-21-2001 02:41 PM
Turbo Guys what headers are you using? NickSTi Normally Aspirated Powertrain 14 03-06-2001 03:27 PM


All times are GMT -4. The time now is 10:03 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.