Welcome to the North American Subaru Impreza Owners Club Wednesday May 4, 2016
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo)

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads. 
Reply
 
Thread Tools Display Modes
Old 04-28-2003, 09:01 PM   #1
ericjames
Scooby Newbie
 
Member#: 31798
Join Date: Jan 2003
Default Car runs like ass.....sometimes

Ok guys I need your help. Last week I installed a vf22, fuel pump, and STi injectors and the car was running fine but it began to get worse and worse and I was kinda pissed. I tried to reset the ECU and it didn't do anything. So the next day I see I'm almost on empty so I go and fill up at a different gas station than I usually go to because I thought maybe it was running ****ty because of a bad tank of gas. Anyways it ran sooooo much better almost imediatly after filling up so I thought my problems were solved....untill today. My tank is about 1/4 full and the car is starting to run worse and worse. It feels really learchy and not smooth at all. It rumbles much more at idle than it should. My fuel pressure looks fine at all levels of boost so I'm kinda stumped. My only guess is that it has something to do with the fuel pump not being able to get enough fuel for some reason. What do you guys think???

Thanks in advance,
Eric
* Registered users of the site do not see these ads.
ericjames is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 04-28-2003, 09:12 PM   #2
V6TurboTA
Scooby Guru
 
Member#: 9090
Join Date: Aug 2001
Location: < of Boston
Vehicle:
09 Forester Gump
02WRX->04STi->09Gump

Default

I would try replacing the fuel filter.

I got a tank of bad gas and my car ran like crap till i replaced the fuel filter.

It might help...

~v6
V6TurboTA is offline   Reply With Quote
Old 04-28-2003, 09:24 PM   #3
Mother
Scooby Newbie
 
Member#: 33829
Join Date: Mar 2003
Chapter/Region: South East
Location: Orlando, FL
Vehicle:
2015 STI
Lightning Red

Default

Do you have any engine management (utec, xede, reflash, etc.) to control the injectors, or are you relying on the stock ECU to control your STi injectors?
Mother is offline   Reply With Quote
Old 04-28-2003, 09:42 PM   #4
The Professor
Scooby Newbie
 
Member#: 23183
Join Date: Aug 2002
Chapter/Region: Tri-State
Location: PA
Vehicle:
2002 Cobb StageIIWRX
WR Blue

Default

You are on the right track with the pump and the engine management definitely. The fact that it runs ok until a 1/4 tank should be a major clue for your local tuner.
The Professor is offline   Reply With Quote
Old 04-28-2003, 10:40 PM   #5
ericjames
Scooby Newbie
 
Member#: 31798
Join Date: Jan 2003
Default

Hey Guys,
I'm running a vishnu unichip to run the injectors and my fuel filter was just changed 2k ago.
Thanks,
Eric
ericjames is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My car rides like ass, need help KW900 Brakes, Steering & Suspension 19 02-26-2010 11:00 AM
ewg just installed. Runs like ass O Stylee Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 17 10-07-2006 05:50 PM
please help car running on 3 sometimes 2 clinders turbocolin Normally Aspirated Powertrain 9 08-18-2004 06:38 PM
This site is really running like ass tonite. Brahmzy Off-Topic 2 08-01-2003 04:30 AM
Anybody's car run like crap after... Tokay Normally Aspirated Powertrain 1 07-17-2002 10:32 PM

All times are GMT -4. The time now is 06:34 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2016 Axivo Inc.
Copyright ©1999 - 2016, North American Subaru Impreza Owners Club, Inc.