Welcome to the North American Subaru Impreza Owners Club Wednesday April 16, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC General > Newbies & FAQs

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-21-2001, 04:46 PM   #1
Rayman
Scooby Newbie
 
Member#: 5962
Join Date: Apr 2001
Location: UK
Question Power Loss

Hi,

I just recently fitted a group a dump valve on my sti version II, it seems like theres some power loss in the mid range. Any ideas? check for any hosing etc...

* Registered users of the site do not see these ads.
Rayman is offline   Reply With Quote
Old 04-21-2001, 08:38 PM   #2
dandbest
Scooby Specialist
 
Member#: 1885
Join Date: Jul 2000
Location: Bayside, NY
Vehicle:
2014 WRX
Wicked White

Post

I really don't know... You gotta understand, here in the US we don't have the WRX (well, until a month ago)we have a naturally aspirated 2.5liter engine that has about half the power of your car. That is probably why you haven't gotten any responces, not cause we don't like you, but cause we really don't know...

Danny
dandbest is offline   Reply With Quote
Old 04-21-2001, 09:37 PM   #3
Impreza Rider
Scooby Specialist
 
Member#: 756
Join Date: Jan 2000
Chapter/Region: MAIC
Location: Ashburn, Va
Vehicle:
2003 Legacy L wagon
2009 Kawasaki C14

Post

Maybe try the guys over at scoobynet.com

Just a suggestion if you haven't tried already.

Jim
Impreza Rider is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Power Loss? Need Advice. BrysImpreza Normally Aspirated Powertrain 18 06-02-2001 11:36 AM
Power loss in 3rd gear Jazz95 Newbies & FAQs 4 04-10-2001 06:59 AM
Power loss! ImprezedRS Normally Aspirated Powertrain 20 01-17-2001 05:01 PM
Power loss due to ignition kill Stavros g Technical Forum Archive 2 07-05-2000 03:24 PM
low end power loss... solutions: (tec2 ?) alastair Technical Forum Archive 8 07-03-2000 10:49 AM


All times are GMT -4. The time now is 01:51 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.