Welcome to the North American Subaru Impreza Owners Club Wednesday August 20, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Factory 2.0L Turbo Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 04-30-2003, 09:36 PM   #1
wrxin'
Scooby Newbie
 
Member#: 15207
Join Date: Feb 2002
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2005 STI
Crystal Grey Metallic

Default loosing boost any idea or is it normal

Well i just installed a header up-pipe downpipe and apexi gt cat back. i found a leak where the uppipe meets the header i corrected that tonight but im getting max boost .11 mpa until about 5800 rpm's then it drops off to about .07mpa by 6500 rpm's i also have a Turbo XS MBC. i never lost boost like this with the factory exhaust. it would hit .11 mpa and hold it all the way to 7k rpm.

Any idea's what might be my problem, i cannot hear any leaks at this point or is it the stock turbo just cannot hold boost with a catless exhaust??

Thanks for any help you can give me.

Kris

P.S. although it doesnt hold boost like before it still feels soooo much faster then before
* Registered users of the site do not see these ads.

Last edited by wrxin'; 05-01-2003 at 04:42 PM.
wrxin' is offline   Reply With Quote
Old 05-01-2003, 09:34 AM   #2
wrxin'
Scooby Newbie
 
Member#: 15207
Join Date: Feb 2002
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2005 STI
Crystal Grey Metallic

Default

Well last night i couldnt hear any leaks, but this morning going to work i hear a leak as i was getting into boost.....makeing a ticking noise almost and gets louder under more boost.......Is this the uppipe leak many talk about???
wrxin' is offline   Reply With Quote
Old 05-01-2003, 12:55 PM   #3
mbiker97
Scooby Guru
 
Member#: 7922
Join Date: Jun 2001
Chapter/Region: MWSOC
Location: Tucson
Vehicle:
04 CTS-V b/b/b
99 GMC Highrider

Default

The stock turbo cannot hold that much boost for that long. It's normal.
mbiker97 is offline   Reply With Quote
Old 05-01-2003, 01:24 PM   #4
SlvWgnCO
Scooby Newbie
 
Member#: 34686
Join Date: Mar 2003
Location: Colorado
Vehicle:
2002 WRX
Silver

Default

My uppipe leak sounded high pitched. When the pipes are cool, spray some soapy water on any suspected leak points. Big bubbles = leak.
SlvWgnCO is offline   Reply With Quote
Old 05-01-2003, 06:50 PM   #5
wrxin'
Scooby Newbie
 
Member#: 15207
Join Date: Feb 2002
Chapter/Region: MAIC
Location: Maryland
Vehicle:
2005 STI
Crystal Grey Metallic

Default okay, found the leak

Well i found the leak. its in the same place as before........where the up pipe meets the manifold. this is the second time ive had the leak here. anyone have any tips on installing this part of the job........i seem to be having trouble here.......the turbo part of the up pipe and downpipe are leak free.

thanks in advance

Kris
wrxin' is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
low boost in heat? or is it time to buy an '08? madsociety Factory 2.0L Turbo Powertrain 9 06-22-2008 06:05 PM
The E30 rear battery, a great idea...or is it? (56k gets points from Luke) teh Phil Off-Topic 18 03-24-2008 02:46 PM
BOOST SPIKE FIXED! or is it? HELP! toekneeyo Factory 2.5L Turbo Powertrain 7 04-28-2006 08:51 PM
Slightly sputering with new mods. Any ideas, or is this normal? SolidSnake Newbies & FAQs 3 03-26-2006 09:58 AM
is it normal for the boost to spike a little bit vsboxerboy Factory 2.0L Turbo Powertrain 3 04-05-2004 02:11 AM


All times are GMT -4. The time now is 02:55 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.