Welcome to the North American Subaru Impreza Owners Club Tuesday September 2, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Tire & Wheel Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Tire & Wheel

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-02-2003, 09:13 PM   #1
SubSonic
Scooby Newbie
 
Member#: 35245
Join Date: Apr 2003
Location: Huntsville
Vehicle:
2003 WRX Sedan
WR Blue Pearl

Default Questions about wheel install. please HELP!

Hi!

I got my rota battles in today. 17" w/ 215-45-17 tires.

My questions are:


1) is it safe to use the OEM stock lugs?
2) after intall, will this affect the alignment? it seems after i installed them, the car pulls a tiny bit to the right.


Please help, especially with question 1.


Steven
* Registered users of the site do not see these ads.
SubSonic is offline   Reply With Quote
Old 05-02-2003, 09:22 PM   #2
Bottom Feeder
Scooby Specialist
 
Member#: 2808
Join Date: Nov 2000
Chapter/Region: MAIC
Location: Occupied Virginia
Default

2) Check the tire pressures.

Can't help with #1.
Bottom Feeder is offline   Reply With Quote
Old 05-03-2003, 11:22 PM   #3
SubSonic
Scooby Newbie
 
Member#: 35245
Join Date: Apr 2003
Location: Huntsville
Vehicle:
2003 WRX Sedan
WR Blue Pearl

Default

Are the stock lugs okay to use on my Battles?
SubSonic is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question about swapping suspension please help! ar0b Brakes, Steering & Suspension 1 01-04-2009 03:16 PM
question about clutch adjustment, please help 4pOwnag3 Newbies & FAQs 9 11-06-2006 11:30 PM
Question about wireless modems. please help Eric SS Off-Topic 26 06-17-2005 12:33 AM
Quick help on steering wheel install please Thead Interior & Exterior Modification 5 01-06-2003 10:43 PM
newbie question about Sway bars - please help Osgood30 Brakes, Steering & Suspension 2 08-16-2002 05:34 PM


All times are GMT -4. The time now is 04:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.