Welcome to the North American Subaru Impreza Owners Club Thursday October 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Service & Maintenance

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-16-2003, 10:39 PM   #1
cky211
Scooby Specialist
 
Member#: 31129
Join Date: Dec 2002
Chapter/Region: NWIC
Location: Spokane WA
Vehicle:
02 WRX MPB
No TGV + lots of P&P

Default Do I need to change oil sooner after engine rebuild?

I replaced 8 bent valves on my 02 WRX at 7000 miles. When reassembling the heads I used some sticky red stuff from NAPA on the cam shafts and any other points that were lacking in oil.
I was just wondering if I needed to change oil sooner? Will that stuff do anything to the oil filter?


Thanks -Scott
* Registered users of the site do not see these ads.
cky211 is offline   Reply With Quote
Old 05-16-2003, 11:20 PM   #2
DrD
Scooby Guru
 
Member#: 22412
Join Date: Aug 2002
Chapter/Region: SWIC
Location: Albuquerque, NM
Vehicle:
2012 Legacy 2.5GT
Ice Silver Metallic

Default

I assume the sticky red stuff was assembly lube, and not rtv

If I were you, I would do the first change early - say 500 or 1000 miles - but that would be because you had the engine open, and some debris could have gotten in there - the assembly lube will not be an issue - it will mix in with the oil just fine.
DrD is offline   Reply With Quote
Old 05-17-2003, 12:52 AM   #3
cky211
Scooby Specialist
 
Member#: 31129
Join Date: Dec 2002
Chapter/Region: NWIC
Location: Spokane WA
Vehicle:
02 WRX MPB
No TGV + lots of P&P

Default

YES assembly lube that is what I used.


OK thanks for the tip!


-Scott
cky211 is offline   Reply With Quote
Old 05-17-2003, 03:33 AM   #4
bbbwrx
Scooby Specialist
 
Member#: 32734
Join Date: Feb 2003
Chapter/Region: RMIC
Default

7000 miles what did you do???
bbbwrx is offline   Reply With Quote
Old 05-17-2003, 01:45 PM   #5
thng
Scooby Specialist
 
Member#: 8062
Join Date: Jul 2001
Location: Moreno Valley, CA
Vehicle:
2002 WRX
Silver

Default

I was going to ask as well about how you bent the valves then I remembered how I bent all the valves in my alfa one day long ago. It was stupid and didn't need to re-live it. Would like to know how the heads turns out after some miles.
thng is offline   Reply With Quote
Old 05-17-2003, 05:03 PM   #6
cky211
Scooby Specialist
 
Member#: 31129
Join Date: Dec 2002
Chapter/Region: NWIC
Location: Spokane WA
Vehicle:
02 WRX MPB
No TGV + lots of P&P

Default

I bought the car at auction. When a wrx gets hit in the front hard enough the timing belt comes off. It is an interference engine which means with no timing belt the pistons can hit the valves and bend them.

I now have 500 miles on it since the rebuild and it runs GREAT!



-Scott
cky211 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Doing an AT fluid swap in a few days...do i NEED to change the filter? kaisersouse Normally Aspirated Powertrain 8 08-30-2005 10:14 PM
Need to change oil? 98SS Service & Maintenance 9 01-14-2005 05:08 PM
Going from a TXS st1 w/TDO4 to VF29 do I need to change the map for now? Camperguy Engine Management & Tuning 7 08-06-2003 10:20 AM
('93-'01) 13k miles-what fluids besides oil do I need to change? Robmat Impreza Forum 2 06-22-2001 06:59 PM
what oils do I need to change?? spunky Newbies & FAQs 2 10-25-2000 11:18 PM


All times are GMT -4. The time now is 08:39 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.