Welcome to the North American Subaru Impreza Owners Club Saturday May 23, 2015
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Engine Management & Tuning

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-23-2003, 09:21 PM   #1
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default UTEC interface enhancement (Long)

I just finished writing an interface to the UTEC. Basically its a wrapper around a hyper terminal session with a few enhancements. The current feature list includes automatic knock logging. With this feature when you run log <shift>1 if it detects knock it will open a new window with just the 10 entries before and five entries after the first knock event. It also automatically saves this to a file in the same directory as the executable. The name of the file will start with 'Knock-' and includes a timestamp of when it happened. Each time you get knock it will open another window and save the file. This makes it easy to find the knock events. Also with the logging with a <alt>R you can restart the log. This is usefull if you are by your self and are trying to log. You just get the log started leave it running and when you finally get an open stretch of road just press <alt>R or the space bar if the button has the focus and it will resart. <alt>S will save the log as 'Log-' + timestamp. No more of all of those menu keys to stop/pause capturing text and selecting a filename.

The feature I am currently working on is an enhanced dashboard. It also utilizes log <shift>1. It keeps peek values next to the current values. When you click on the peek value you will see a pop-up that has what all the other parameters were at when you hit that peek. I should have that by the end of next week. (edit : is now available)


I know its only a small enhancement and may have bugs but it really helps in tuning.


I would recommend everyone that has downloaded it get the latest. I had made a rookie mistake with the com port stuff.


http://autologger.empiricdesigncorp.com/autologger.exe


The dns might take a while to propogate. So keep trying.
* Registered users of the site do not see these ads.

Last edited by LiquidForce; 05-30-2003 at 11:02 AM.
LiquidForce is offline   Reply With Quote
Sponsored Links
* Registered users of the site do not see these ads.
Old 05-23-2003, 10:33 PM   #2
gpatmac
Scooby Guru
 
Member#: 18446
Join Date: May 2002
Chapter/Region: MAIC
Location: Stratford, CT
Vehicle:
2002 WRX wagon
psm

Default

WRXhackers
gpatmac is offline   Reply With Quote
Old 05-23-2003, 10:42 PM   #3
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

I am a member there but you still need a place to host the file. I believe all that site does is post the link to it.
LiquidForce is offline   Reply With Quote
Old 05-23-2003, 10:46 PM   #4
JustDSM
Scooby Newbie
 
Member#: 17502
Join Date: Apr 2002
Location: Cheyenne, WY
Default

I'd be more than happy to host it temporarily. Email it to me and I'll have it uploaded within minutes.
JustDSM is offline   Reply With Quote
Old 05-23-2003, 10:51 PM   #5
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

pm me your email and i'll send you the source and executeable.
LiquidForce is offline   Reply With Quote
Old 05-24-2003, 07:25 AM   #6
TheMadScientist
Scooby Guru
 
Member#: 23717
Join Date: Aug 2002
Chapter/Region: NESIC
Location: Beverly, MA
Vehicle:
2005 Big red

Default

I think taht WRXHackers will host for you. You just have to submit it for reveiw.
http://www.wrxhackers.com/modules.ph...op=AddDownload

Try there
TheMadScientist is offline   Reply With Quote
Old 05-24-2003, 11:22 AM   #7
RiftsWRX
Scooby Guru
 
Member#: 6124
Join Date: Apr 2001
Chapter/Region: MWSOC
Location: Glendale Hts, IL, USA
Vehicle:
2000 NFR AP1 S2000
'07 Honda FIT sport (5MT)

Default

Feel free to email me the program and info and I'll be honored to showcase it on my site.

Bravo for your contribution to the community!

Jorge (RiftsWRX)
www.ProjectWRX.com
RiftsWRX is offline   Reply With Quote
Old 05-24-2003, 12:16 PM   #8
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

I got so motivated today I started working on an automatic way to log runs. It works by sensing that the rpms have hit 6000. It then reads backwards until it reaches a point where the rpms are below 2000. It keeps going forward from the 6000 rpm point until it sees 2000 rpm again. then it will pop open a new window with just that log data and saves it to a file automatically. Again all of this will only work using <shift>1 log. I should have this updated version ready by Monday.



BTW I choose delphi because it lets you build a stand alone executeable. No need for messy installs and dll hell.


edit: it has been added to wrxhackers but I guess it needs to be reviewed before its available.

Last edited by LiquidForce; 05-24-2003 at 12:32 PM.
LiquidForce is offline   Reply With Quote
Old 05-24-2003, 12:24 PM   #9
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

JustDSM you have email. Let me know if the attachment worked. I sometimes have problems with hotmail and the firewall I am behind.


thanks
Mike K
LiquidForce is offline   Reply With Quote
Old 05-25-2003, 12:17 AM   #10
digitaltekniq
Scooby Specialist
 
Member#: 18029
Join Date: Apr 2002
Location: ATX
Default

I've started work on my interpretation of what the UI should be - now that I finally pulled my finger out and bought a UTEC - things are starting to hot up!
digitaltekniq is offline   Reply With Quote
Old 05-25-2003, 12:31 AM   #11
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

I finshed the auto logging feature. Now all you have to do is just start the log and drive. It will automatically save any runs where you hit 6000rpms. It will also automatically save if you have knock.

I also fixed a couple of minor bugs. At the same time I probably created a few new ones.

I'll try to get the new one out there tommorow.

Feedback is appreciated.

RiftsWRX pm me your email address and i'll send the new version to you with the source.
LiquidForce is offline   Reply With Quote
Old 05-25-2003, 07:24 AM   #12
JustDSM
Scooby Newbie
 
Member#: 17502
Join Date: Apr 2002
Location: Cheyenne, WY
Default

Liquid: I'm going to be out of town for the next few days on buisness so I'll be unable to update the file I'm currently hosting. I'll be back in a few days however...
JustDSM is offline   Reply With Quote
Old 05-25-2003, 02:59 PM   #13
mtb_dude
Scooby Specialist
 
Member#: 12619
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: LI, NY
Vehicle:
02 WRX Wagon
#47 SM w/RA gears

Default

LOL It works! Wow what a cool little util. I only have the auto-knock log feature, guess the next version isn't up on the sites yet. I can give you a temporary ftp server until JustDSM gets back.
mtb_dude is offline   Reply With Quote
Old 05-25-2003, 05:14 PM   #14
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

I enabled http on my server but I don't have a static ip. this link will only work until bellsouth decides to give me another ip.

edit: removed dead link

Last edited by LiquidForce; 05-29-2003 at 10:32 AM.
LiquidForce is offline   Reply With Quote
Old 05-28-2003, 09:11 AM   #15
x99percent
Scooby Specialist
 
Member#: 27108
Join Date: Oct 2002
Chapter/Region: MWSOC
Location: Detroit-ish, MI
Vehicle:
2004 STi
2004 A4

Default

*Very* cool program!


Here's some feedback:

- Allow the user to adjust the "start", "trigger", and "shut-off" rpm for the logging. I made a 2nd and 3rd gear pull down an on-ramp, and the auto-logging continued for a while as I was cruising down the highway at <3000rpm. I stopped the auto-logging by pushing in the clutch and letting the rpm drop to idle.

Ex: start = 2000, trigger = 6000, shut-off = 3000


- Many of the "close" buttons in the upper-right hand corner of the windows didn't work for me (WinXP home). I had to close logger windows with Alt-F4.

- How about an option to name the log files as .txt or .csv? Right now, I just rename the logs to *.csv for easy importing into MS Excel.
x99percent is offline   Reply With Quote
Old 05-28-2003, 10:31 AM   #16
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

Quote:
- Allow the user to adjust the "start", "trigger", and "shut-off" rpm for the logging. I made a 2nd and 3rd gear pull down an on-ramp, and the auto-logging continued for a while as I was cruising down the highway at <3000rpm. I stopped the auto-logging by pushing in the clutch and letting the rpm drop to idle.

Ex: start = 2000, trigger = 6000, shut-off = 3000
It already has the trigger point as a user defineable point. I'll add the other two parameters as well.

Quote:
- Many of the "close" buttons in the upper-right hand corner of the windows didn't work for me (WinXP home). I had to close logger windows with Alt-F4.
I have the same problem. It's probably something with delphi 5 and windows xp. I developed this on xp so I am not sure what happens with older versions of windows.

Quote:
- How about an option to name the log files as .txt or .csv? Right now, I just rename the logs to *.csv for easy importing into MS Excel.
I'll just default the name to *.csv.


Work is really slow right now. So I should be able to get these changes out today.

Thanks for the feedback.
Mike K
LiquidForce is offline   Reply With Quote
Old 05-28-2003, 01:02 PM   #17
mtb_dude
Scooby Specialist
 
Member#: 12619
Join Date: Nov 2001
Chapter/Region: Tri-State
Location: LI, NY
Vehicle:
02 WRX Wagon
#47 SM w/RA gears

Default

Yeah I have to say this wrapper rocks!

I have another interesting idea, since most runs will be done at over 60% tps, maybe you could use that as a "run" trigger also? Even a slow poke shifter would take less than say 7 log events to change gears so you can account for the shift by waiting up to so many log events to consider the run completed? Otherwise reset the counter and continue logging to the Run log? I'm pretty familiar with programming but not Delphi so maybe it's not possible or really time consuming.

I dunno, trying to contribute with out doing any work I guess!
mtb_dude is offline   Reply With Quote
Old 05-28-2003, 01:39 PM   #18
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

the dashboard feature with the gauges and peek value memory is almost ready. I have already added the other changes to configure the auto logging configuration. Looking to release the latest before the ride home today.

I had originally gone down the route of using the load to determine logging but it did get kind of messy trying to keep track of when the load would drop off during shifting.
LiquidForce is offline   Reply With Quote
Old 05-28-2003, 03:56 PM   #19
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

new version is now ready. My gauges on the dashboard screen need a little work but the peek value stuff works. When you click on the peek value of a measurement you will get a pop up of what all the other parameters were when you hit that peek. The dashboard requires that you have log <shift> 1 started before you can use it.

All of the automatic logging works even in dashboard mode.


source available by request

Last edited by LiquidForce; 05-29-2003 at 10:30 AM.
LiquidForce is offline   Reply With Quote
Old 05-28-2003, 11:52 PM   #20
x99percent
Scooby Specialist
 
Member#: 27108
Join Date: Oct 2002
Chapter/Region: MWSOC
Location: Detroit-ish, MI
Vehicle:
2004 STi
2004 A4

Default

The dashboard thing is neat.. it's nice to have the peak values right there.

More feedback:

- When the graphical dashboard comes up, can the focus be put on the "reset values" button? That way, resetting the values takes just a hit of the spacebar.

- I don't think the knock value shown in the dashboard is reading the right thing. I was a little concerned when I saw a knock total well over 3500!

- The "Setup" menu and the "Save Current Log" button both have the S underlined.. when I hit Alt-S, I think the button took precedence.


You should set up a PayPal account for donations


EDIT: just saw that you edited your post since this afternoon. Perhaps you've already fixed some of this stuff?
x99percent is offline   Reply With Quote
Old 05-29-2003, 09:49 AM   #21
JustDSM
Scooby Newbie
 
Member#: 17502
Join Date: Apr 2002
Location: Cheyenne, WY
Default

Liquid: I'm back.. Go ahead and send me the updated file and I'll host it for you.
JustDSM is offline   Reply With Quote
Old 05-29-2003, 10:30 AM   #22
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default

Bug Fixes and Tweaks:

Fixed the auto-logging configuration screen. It would report that a value was out of range when it wasn't.

Knock count on dashboard. Was actually pulling the value from the load column. (With an knock count of 3500 you would be looking for a new car )

Quick key men options now do not conflict with each other.

The reset button now has the focus when the dashboard comes up.

The yellow on the boost gauge is vacuum and the red begins at 15psi.

Com port configuration bug. It was aving the configuration to the wintec registry entry but trying to read from the AutoLogger registry.

I have had a request to integrate the ouptut from a techedge wideband. I am looking into this. So far I don't see a reason why I can't add it. I'll keep everyone posted.


JustDSM I lost your email address. Once I get this back I will send you the file and then I can edit all of the links so people can get the latest.



btw my paypal is mikekillackey@hotmail.com if you feel so inclined.

Last edited by LiquidForce; 05-29-2003 at 11:25 AM.
LiquidForce is offline   Reply With Quote
Old 05-29-2003, 11:14 AM   #23
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

it doesnt work for me not even a little.
double click it, unable to open COM port
tried using the same com that my UTEc uses, nope
Tried Com 1 nope. Tried a few difference port settings, nothin.
This sucks.
Davenow is offline   Reply With Quote
Old 05-29-2003, 11:19 AM   #24
LiquidForce
Scooby Specialist
 
Member#: 12811
Join Date: Nov 2001
Chapter/Region: South East
Location: Roswell Ga
Vehicle:
2002 2.5l Wrx
517whp/516wtq (Stage pi)

Default Hey davenow

I think I may have screwed the comport setting in the previous version. I changed the name from wintec to autologger and I think I f'd up the registry entries for the com port.

What version do you have? Wintec or autologger?


If you save this as autloger.reg and then doulble click it it should fix your problem. Make sure to adjust the comport if necessay.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\AutoLogger\comPort]
"Port"="COM2"
"BaudRate"="19200"
"StopBits"="1"
"DataBits"="8"
"Parity"="None"
"FlowControl"="Hardware"

Last edited by LiquidForce; 05-29-2003 at 11:43 AM.
LiquidForce is offline   Reply With Quote
Old 05-29-2003, 11:50 AM   #25
Davenow
Scooby Guru
 
Member#: 23676
Join Date: Aug 2002
Chapter/Region: NESIC
Location: de_dust and Orgrimar
Vehicle:
.

Default

I already have those settings for the port(s)
I have wintec, the one you posted in the beginning.
Its a problem with wintec adressing my ports, and its in wintec, because the UTEC has no problem using either of my ports (COM1 and COM4)
Also, you cant simply save those settings, it give an error when youdbl click the file. Something about not being done in binary
EDIT I havent tried 19200 in the baud rate setting yet, I have tried 9600 and 56000.

Could this be because I am using a USB to serial adapter? I wouldnt think that would be the problem since the UTEC is fine on it.
Davenow is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
UTEC Interface Thread NavyBlueSubaru UTEC 1067 02-19-2012 11:07 AM
Enhanced UTEC Interface ...? ScreaminFast Engine Management & Tuning 4 09-20-2003 11:23 PM
UTEC Interface Enhancement LiquidForce Factory 2.0L Turbo Powertrain (EJ Series Factory 2.0L Turbo) 6 05-29-2003 11:42 AM
UTEC software or interface nekard Engine Management & Tuning 5 10-22-2002 04:16 PM
UTEC interface program question? davidm_sh Engine Management & Tuning 3 10-09-2002 11:07 AM


All times are GMT -4. The time now is 04:30 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2015 Axivo Inc.
Copyright ©1999 - 2015, North American Subaru Impreza Owners Club, Inc.