Welcome to the North American Subaru Impreza Owners Club Wednesday April 23, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-26-2003, 12:09 PM   #1
DDImpreza
Scooby Newbie
 
Member#: 34525
Join Date: Mar 2003
Location: mass
Vehicle:
1999 impreza rs
white/ carbon fiber

Default help my car wont start

i have a 99 rs. i have apex n1 cat back a weapon r intake and apex safc. heres the problem i was driving down the street last night it was raining and i was screwing around with a bmw i was in third gear and everything just cut out. iwas at wot. i pulled into a parking lot. i tried to restart it but it just start and stalls. i give it gas and nothing happens just stalls out faster. i disconnected the mass air flow and tried to start. but even with it disconnected it does the same thing. reset the ecu same problem. i have a bout 1/3 tank of gass. about two months ago the wiring harness for the maf broke the wires connecting the maf. because of the intake i guess it was too tight. so i extended them and made my own custom plug. so the harness could have some slack. im almost positive thats not the problem because it worked mint for two months. im thinking it might have something to do with fuel. any ideas???? i had it towed to the dealer because i couldnt get it started. this sucks !!!!!
* Registered users of the site do not see these ads.
DDImpreza is offline   Reply With Quote
Old 05-27-2003, 09:34 AM   #2
tmat3
Scooby Specialist
 
Member#: 2817
Join Date: Nov 2000
Location: NYC and Troy, NY
Vehicle:
2001 Impreza 2.5RS
BRP

Default

It could be caused by a number of problems. But, check for these:

1) Check if the engine is getting sparks. Ignition coil can be faulty.
2) Check for the fuel pressure. Fuel pump may be faulty.
3) You said you had a SAFC. Make sure the connections at the ECU are tight and good.
tmat3 is offline   Reply With Quote
Old 05-27-2003, 11:57 PM   #3
DDImpreza
Scooby Newbie
 
Member#: 34525
Join Date: Mar 2003
Location: mass
Vehicle:
1999 impreza rs
white/ carbon fiber

Default

got it back from the dealer it was the mass air flow sensor. i guess because i have a carbon fiber hood and the vent is open i have a foam filter on a elbow style intake it was getting real wet and the moisture or water screwed up the maf .. oh well thts my third one. its weird because the first time it went it was totally different problem.. i dont know not a mechanic... but thanks for the help and ideas.. oh yeah to solve the problem i took the plate off my stock hood and closed up the hole on the hood.
DDImpreza is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help...my car wont start! akcel Electrical & Lighting 14 02-13-2008 02:17 PM
help, my car wont start Ronaldo Vancouver Impreza Club Forum -- VIC 27 11-11-2004 09:29 PM
Please help ---My car wont start. drtaka Factory 2.0L Turbo Powertrain 5 07-13-2003 04:48 PM
help my car wont start DDImpreza New England Impreza Club Forum -- NESIC 2 05-27-2003 11:58 PM


All times are GMT -4. The time now is 06:15 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.