Welcome to the North American Subaru Impreza Owners Club Friday August 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-27-2003, 07:30 AM   #1
jslegacy
Scooby Specialist
 
Member#: 17034
Join Date: Mar 2002
Chapter/Region: MAIC
Location: fair lakes,va
Vehicle:
2005 Lotus Elise
Mercedes C230 6spd

Default my legacy got a little hot

After going out for a sprited drive for about 45 minutes of some really hard driving, hard acceleration, hard braking , you know the deal. well i decided to go on home i was going through a neighborhood going like 15-20mph tryin to let things cool down.

Well i look down at my gauges and my temp guage went up above the top wavy line and almost 2/3s of the way up and then i sped up a little to like 30 or so and it went back down to the normal level.

On my car i have 68k miles and i do know about the head gaskets going around 75-80k is this happening prematurally or am i just worried over nothing, yeah it over heated but i still have some time, or just in case get a new thermostat?

thanx for any suggestions


jeremy
* Registered users of the site do not see these ads.
jslegacy is offline   Reply With Quote
Old 05-27-2003, 08:49 AM   #2
omahasubaru
Scooby Guru
 
Member#: 1594
Join Date: Jun 2000
Chapter/Region: MWSOC
Location: Gretna, NE
Vehicle:
1995 WRX
2002 Legacy

Default

Check your oil... if it is a bit more milky than normal your head gaskets are leaking...

To be safe... replace the head gaskets, thermostat, radiator hoses... Overheat it badly or too many times & you'll be replacing more than just head gaskets.
omahasubaru is offline   Reply With Quote
Old 05-27-2003, 10:23 AM   #3
jslegacy
Scooby Specialist
 
Member#: 17034
Join Date: Mar 2002
Chapter/Region: MAIC
Location: fair lakes,va
Vehicle:
2005 Lotus Elise
Mercedes C230 6spd

Default

i will check the hoses and all of my fluid levels and see how they feel. I dont drive it on a daily basis probably three times a week, so i guess i can take it out again on a normal drive to see if it heats up again.

This is a first time it happened ever, if the fluids seem ok, i guess i will wait for it to happen again before i start replacing head gaskets.

jeremy
jslegacy is offline   Reply With Quote
Old 05-27-2003, 01:11 PM   #4
snowone
Scooby Specialist
 
Member#: 6035
Join Date: Apr 2001
Chapter/Region: NWIC
Location: PNW!
Vehicle:
05 92-X Saabaru
GF8 05/06 STi

Default

Head gasket is most likely going... watch it close! Check coolant tank on radiator, and look for oily residue. Make sure you have gaskets redone before TOO long, and get the new and improved parts, eh!

Mine went at 70k, after a hard driving road trip from Sea to SF put it over the edge. Good luck!


Legacy FAQ: Blown Gaskets
snowone is offline   Reply With Quote
Old 05-27-2003, 01:50 PM   #5
jslegacy
Scooby Specialist
 
Member#: 17034
Join Date: Mar 2002
Chapter/Region: MAIC
Location: fair lakes,va
Vehicle:
2005 Lotus Elise
Mercedes C230 6spd

Default

any ok if it does happen to be my head gaskets, any idea on which type i should replace them with? Also what else i should replace while i am taking apart the block?

Last question for now, how long would it take if i could get a few people to help me with it?


jeremy
jslegacy is offline   Reply With Quote
Old 05-27-2003, 01:59 PM   #6
CRAZY KEN
Scooby Specialist
 
Member#: 1176
Join Date: Mar 2000
Chapter/Region: MAIC
Location: Potomac, MD
Vehicle:
2012 Legacy GT Ltd
Pearl Statin White

Default WHAT TO REPLACE...

Cams
Pistons
Rods
Valves Springs
Port & Polish
Cam Gears

...oh you mean maintenance wise...

timing belt
wires
plugs

CRAZY KEN
CRAZY KEN is offline   Reply With Quote
Old 05-27-2003, 02:07 PM   #7
jslegacy
Scooby Specialist
 
Member#: 17034
Join Date: Mar 2002
Chapter/Region: MAIC
Location: fair lakes,va
Vehicle:
2005 Lotus Elise
Mercedes C230 6spd

Default

i would replace all of that stuff but i have a Lotus on order so, yeahhhhhh.


jeremy
jslegacy is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got a little something to compliment my fmic! 2005wrbluesti Member's Car Gallery 29 01-09-2007 06:41 PM
The Legacy GT just got a little lower gjhsu Member's Car Gallery 53 12-15-2006 05:58 PM
Got my boys groped by a hot medical student Porter Off-Topic 100 11-22-2005 08:55 PM
see what my legacy got for tonite =) masube Legacy Forum 4 01-02-2005 03:55 AM
I got a little dent on my car.... Black&Blue Interior & Exterior Modification 6 12-11-2002 12:04 AM


All times are GMT -4. The time now is 09:44 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.