Welcome to the North American Subaru Impreza Owners Club Wednesday September 3, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 05-30-2003, 05:17 PM   #1
mvstype
Scooby Specialist
 
Member#: 4736
Join Date: Mar 2001
Chapter/Region: SCIC
Location: don't PM me
Vehicle:
95 12 sec. Legacy
Same Color as a Booger

Angry Got my car back from body shop

It looked good. They put on a GT hood, (I have a L wagon) front facia, lights. While I was driving back to work on the freeway and the AC starts going warm. I look at the temp gauge and it is all the way up. My work is a block from the ramp so I pull in the parking lot. It has coolent in the radiator. What should I do? Should I have them take it to a Subaru dealer to check it out?

MV
* Registered users of the site do not see these ads.
mvstype is offline   Reply With Quote
Old 05-30-2003, 05:49 PM   #2
monovich
Scooby Specialist
 
Member#: 8124
Join Date: Jul 2001
Location: Denver, Colorado
Vehicle:
1998 Old Grey Mule
Regacy Rype R

Default

hmm, you don't have a GT do you?
monovich is offline   Reply With Quote
Old 05-30-2003, 05:49 PM   #3
NiTRoN
Scooby Specialist
 
Member#: 30556
Join Date: Nov 2002
Chapter/Region: MWSOC
Location: Cleveland, Ohio
Vehicle:
2000 Legacy GT (BE)
over 250,000 Miles

Default

could be a thermostat that's messing up... what about if you shut the AC off.. does it stay hot?
NiTRoN is offline   Reply With Quote
Old 05-30-2003, 06:56 PM   #4
mvstype
Scooby Specialist
 
Member#: 4736
Join Date: Mar 2001
Chapter/Region: SCIC
Location: don't PM me
Vehicle:
95 12 sec. Legacy
Same Color as a Booger

Default

The shop sent someone out to look at the car. It had some air in the water lines & not enough coolant. It is now fixed. They also said that they would paay to have it looked at by a Subaru dealer and fix anything that happened to the car because of the over heating.

monovich - I have a wintergreen L wagon with WRX rims & re92's. It now has a GT hood that it did not have before.

MV
mvstype is offline   Reply With Quote
Old 05-30-2003, 07:00 PM   #5
US2JDM
Scooby Guru
 
Member#: 5893
Join Date: Apr 2001
Chapter/Region: E. Canada
Location: Fairport, NY
Vehicle:
1997 Black GC4
1995 White BK6

Default

Quote:
Originally posted by mvstype
The shop sent someone out to look at the car. It had some air in the water lines & not enough coolant. It is now fixed. They also said that they would paay to have it looked at by a Subaru dealer and fix anything that happened to the car because of the over heating.

monovich - I have a wintergreen L wagon with WRX rims & re92's. It now has a GT hood that it did not have before.

MV
That was mvstype! LOL ^_^

KE KE!!1
US2JDM is offline   Reply With Quote
Old 05-30-2003, 07:00 PM   #6
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

"It has coolent in the radiator"

You mean it has no coolant in the radiator?
ciper is offline   Reply With Quote
Old 05-30-2003, 07:23 PM   #7
mvstype
Scooby Specialist
 
Member#: 4736
Join Date: Mar 2001
Chapter/Region: SCIC
Location: don't PM me
Vehicle:
95 12 sec. Legacy
Same Color as a Booger

Default

Quote:
Originally posted by ciper
"It has coolent in the radiator"

You mean it has no coolant in the radiator?
It had some but not enough. It has the correct amount now.

It should also say pay not paay.

Quote:
That was mvstype! LOL ^_^
I have been sighted.

Gotta get coolent!
MV
mvstype is offline   Reply With Quote
Old 05-30-2003, 08:31 PM   #8
US2JDM
Scooby Guru
 
Member#: 5893
Join Date: Apr 2001
Chapter/Region: E. Canada
Location: Fairport, NY
Vehicle:
1997 Black GC4
1995 White BK6

Default

Hey MV, stop by Life Plaza on Sunday and show off the new shizzle!
US2JDM is offline   Reply With Quote
Old 05-31-2003, 07:19 PM   #9
munkis
Scooby Guru
 
Member#: 1847
Join Date: Jul 2000
Chapter/Region: Tri-State
Location: brokenmotorsports.com
Vehicle:
Team Broken: V6 GF
rallyarmor.com

Default

Did they have to do anything to the cooling system?

im guessing you had an accident, and they had to replace quite a bit of stuff?

legacys always get air trapped in the cooling system after it has been drained.

that is why there is a bleed screw on the passenger side of the radiator.

thats where it should be filled with coolant untill it comes out the other side.

Jay
munkis is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
FINALLY got my car back from body shop! Pearl Jam General Community 4 02-28-2008 11:08 PM
Just got my car back from the shop (again) HoRo1 Southern California Impreza Club Forum -- SCIC 1 08-15-2004 06:37 PM
I got my car back from the shop creature546 Southern California Impreza Club Forum -- SCIC 18 12-22-2003 12:09 PM
Finally got my car back from the shop phenomenon Vancouver Impreza Club Forum -- VIC 0 07-22-2002 04:18 PM
Ahhh.... Just got the car back from body shop.:) Eric Gagnon Member's Car Gallery 15 05-30-2001 09:38 AM


All times are GMT -4. The time now is 04:14 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.