Welcome to the North American Subaru Impreza Owners Club Monday September 22, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-05-2003, 09:09 AM   #1
Boujie
Scooby Newbie
 
Member#: 5444
Join Date: Apr 2001
Location: Bloomfield, NJ, USA
Vehicle:
2000 2.5RS
BRP

Angry Chirping noise...help!

Ok so I've had this chirping/squeaking noise ever since I had a new clutch and flywheel put in. Was told it was the throwout bearing so I waited til that clutch started slipping and then went with an exedy clutch/flywheel kit. The damn noise is still there. When I push the clutch in the noise goes away. Let the clutch out and it's back. I can pull the clutch fork forward and the noise goes away. Once I let go it comes back though. Any ideas on what could be causing it? Slave cylinder? Throwout bearing again?! I have no idea.

-Frank
* Registered users of the site do not see these ads.
Boujie is offline   Reply With Quote
Old 06-05-2003, 09:11 PM   #2
Albert
Scooby Specialist
 
Member#: 3288
Join Date: Dec 2000
Location: San Diego, CA. USA
Vehicle:
1998 Impreza 2.5RS
Rally Blue Pearl

Default

Who did the Exedy kit install?

Have you packed the slave cylinder with grease yet?

If you already did the symptom you describe is identical to a bad TOB. It's also possible your clutch fork is bent and is accelerating your TOB wear.
Albert is offline   Reply With Quote
Old 06-06-2003, 10:50 AM   #3
Boujie
Scooby Newbie
 
Member#: 5444
Join Date: Apr 2001
Location: Bloomfield, NJ, USA
Vehicle:
2000 2.5RS
BRP

Default

I had a local mechanic that I've known for years do the install. Haven't tried packing the slave cylinder with grease. What kind of grease should i use? You may laugh at my n00bishism.

Thanks for your help. I truly appreciate it.

-Frank
Boujie is offline   Reply With Quote
Old 06-06-2003, 12:17 PM   #4
Subie Gal
GC84Ever
Super Moderator
 
Member#: 301
Join Date: Sep 1999
Chapter/Region: NWIC
Location: WA
Vehicle:
1970 FF-1 & '70 Van
02 WRX/01 RS

Default

simple question.

did you change the tob???

you never said this was changed along with the clutch.

if it was.. then definately time to consider slave/master cylinder swaps... i had this problem "cricket" noise.. until i changed the cylinders....

good luck to ya.
jamie www.subiegalracing.com
_____________________________________

Subie Gal is offline   Reply With Quote
Old 06-06-2003, 05:48 PM   #5
Albert
Scooby Specialist
 
Member#: 3288
Join Date: Dec 2000
Location: San Diego, CA. USA
Vehicle:
1998 Impreza 2.5RS
Rally Blue Pearl

Default

Good catch Jamie...there is no specific mention of installing a new TOB.


If you still want to try the slave cylinder grease thingy all you'll nedd is about a half teaspoon of high temp roller bearing grease. The grease will help damper the rattle of the slave cylinder pushrod when there is no pressure applied to the clutch (ie at a stop light). Basically just pop off the rubber accordian booth from the end of the slave cylinder, (don't loose the little brass pushrod). Pack the grease into the opening, reinstall the pushrod and booth then finally put a small dab of grease where the pushrod contacts the clutch fork.
Albert is offline   Reply With Quote
Old 06-07-2003, 04:04 AM   #6
Boujie
Scooby Newbie
 
Member#: 5444
Join Date: Apr 2001
Location: Bloomfield, NJ, USA
Vehicle:
2000 2.5RS
BRP

Default

Oh yea...yes the TOB was replaced. Sorry about that.

-Frank
Boujie is offline   Reply With Quote
Old 06-07-2003, 05:14 PM   #7
Albert
Scooby Specialist
 
Member#: 3288
Join Date: Dec 2000
Location: San Diego, CA. USA
Vehicle:
1998 Impreza 2.5RS
Rally Blue Pearl

Default

good!!

****BTW, what kind of shape was the old one in? Were any of the end seals ruptured, did it spin freely and in good operational condition?




now...
...grease the slave m/c pushrod.
if that doesn't resolve the issue, replace the slave m/c, if that still doesn't do it your clutch fork is likely bent IF the old TOB was in bad shape.
Albert is offline   Reply With Quote
Old 06-09-2003, 12:25 PM   #8
Boujie
Scooby Newbie
 
Member#: 5444
Join Date: Apr 2001
Location: Bloomfield, NJ, USA
Vehicle:
2000 2.5RS
BRP

Default

Going to grease her up sometime this week and see if that helps
If the slave cylinder needs to be replaced is there a good aftermarket I should replace it with?
Thanks again for the help!

-Frank
Boujie is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Squeaking/Chirping noise, help me diagnose JanssenTodd Factory 2.5L Turbo Powertrain 1 09-06-2009 07:15 PM
Chirping Noise? Help... Akina Newbies & FAQs 4 01-19-2007 12:49 AM
Car making a chirping noise, need help imisplacedmine Newbies & FAQs 11 05-31-2006 08:29 AM
WRX develops chirp noise? toobee1 Factory 2.0L Turbo Powertrain 36 05-08-2002 01:50 AM
Chirpping noise coming from right front tire? ImprezedRS Brakes, Steering & Suspension 1 08-21-2001 01:44 PM


All times are GMT -4. The time now is 03:48 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.