Welcome to the North American Subaru Impreza Owners Club Saturday July 12, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Archives > NASIOC Archives > SVX Forum Archive

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
 
 
Thread Tools Display Modes
Old 02-07-2001, 10:11 PM   #1
kastle
Frank Army
 
Member#: 1457
Join Date: May 2000
Chapter/Region: SWIC
Location: Phoenix, AZ
Vehicle:
1999 Outback Sport
Steel Blue Mica

Post more SVX-T problems

Robert tested it with different boost pressures, without using boost at all and we were still having problems. At around 4500 RPMs it the car would buckle under and just about stop accellerating. Kind of like if there was a plastic bag clogging the intake.

I told Robert I'm bringing it up Friday and I don't want it back till it works. He's done a phenominal job with the car. It ran very nice up in Prescott, but for some reason not down here.

I will continue to have Robert work on the SVX-T and make the stupid thing work. Once I get that done, I think I will have him do the RS.

While the SVX-T isn't running well, I just can't blame Robert. He's trying his best, as seen tonight with a flashlight trying to work on the car in the dark.

Damn car!
* Registered users of the site do not see these ads.
kastle is offline  
Old 02-08-2001, 09:16 AM   #2
CRZ_MSL
Scooby Newbie
 
Member#: 1610
Join Date: Jun 2000
Post

Good luck to you and your mechanic.

Problems are understandable, it's not like he is turbocharging a Civic, where all the potential problems have been worked out to the point you can now buy a bolt-on turbo kit.
CRZ_MSL is offline  
Old 02-08-2001, 05:01 PM   #3
glenstiles
Scooby Newbie
 
Member#: 2827
Join Date: Nov 2000
Location: Woodland, CA
Vehicle:
2002 WRX wagon
Silver, baby, silver

Post

It can be very difficult being the pioneer. Very frustrating to say the least, are there any more turbo SVX owners around that could help out?

Glen
glenstiles is offline  
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem X is more critical than problem Y Chromer Off-Topic 8 12-18-2009 12:25 PM
More bad GF problems bigwrxguy Off-Topic 104 05-23-2007 10:12 AM
More fun new problems... borked MAF? Suggestions welcomed scooterforever Factory 2.0L Turbo Powertrain 2 11-11-2006 04:10 PM
Surging more of a problem on a cold turbo? biggreen96 Pre-2002 Factory Turbo Powertrain 21 01-20-2006 09:52 PM
more stupid pm problems... Benjamin Tang Vancouver Impreza Club Forum -- VIC 10 10-03-2001 01:17 AM


All times are GMT -4. The time now is 11:18 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.