Welcome to the North American Subaru Impreza Owners Club Friday September 19, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Transmission (AT/MT) & Driveline

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-09-2003, 09:06 AM   #1
Blindeye_03
Scooby Guru
 
Member#: 4418
Join Date: Feb 2001
Chapter/Region: South East
Location: SE
Default problem with my new clutch??

Ok, I went to a shop and had them install my exedy clutch and lightweight flywheel. I dont know if this is normal, but last night I was driving w/ the windows down around my neighborhood very slow (like 5mph) and heard a metalliac clanging sound, almost like the sound of a bolt being thrown on metal.


Any ideas??

-justin
* Registered users of the site do not see these ads.
Blindeye_03 is offline   Reply With Quote
Old 06-09-2003, 04:38 PM   #2
GQ
Scooby Specialist
 
Member#: 4830
Join Date: Mar 2001
Chapter/Region: SCIC
Location: San Diego, CA
Vehicle:
12 DucatiSF/Abarth
Red/Nero

Default

Lube slave cylinder rod and or bleed the clutch slave cylinder. Might fix your problem and is simple to do.
GQ is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem with my new 06 ghostrr Newbies & FAQs 44 01-11-2006 07:38 AM
Help: Problems with my new neibohors 4or2wheels Tri-State Area Forum 30 04-12-2004 06:08 PM
HUGE PROBLEMS with my new car! StuBeck Legacy Forum 22 06-13-2003 06:10 PM
A problem with my new 03 WRX AcceleratedConcepts Factory 2.0L Turbo Powertrain 7 10-05-2002 08:49 AM
('93-'01) Problems with my new 2.5RS CyberLogic Impreza Forum 6 04-30-2001 08:11 AM


All times are GMT -4. The time now is 07:47 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.