Welcome to the North American Subaru Impreza Owners Club Friday October 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
Click here to visit TireRack
Brakes & Suspension Forum sponsored by The Tire Rack

Losing traction? Need new tires?
Click here to visit the NASIOC Upgrade Garage...
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Brakes, Steering & Suspension

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 06-12-2003, 08:26 PM   #1
jkjersey
Scooby Newbie
 
Member#: 8399
Join Date: Jul 2001
Chapter/Region: Tri-State
Location: Mount Laurel, NJ
Vehicle:
GC8 JDM STI V swap
cardinal red

Default brake problem with GC8

I own a 1995 impreza that has ABS. A couple months ago the cv joint was replaced by a mechanic. When I got my car back the ABS light would turn on after a couple minutes. Then I would start it up other days and drive for awhile and get no light to turn on. Now as soon as I turn it on the ABS light is on. I can not trigger my ABS in the rain. I checked the fuse also. I do not think it is a coincidence that before my cv joint was replaced my ABS worked and after it did not. I then have been driving and @ random my wheel feels like it has a shimmer even when I do not brake (someone said wheel weight came off)? Well anyways today my car fell allot slower all of a sudden and then when I stopped I felt immense heat when I was examing my right front wheel where the cv joint was replaced and a faint smell (didn't smell burnt too much but slight) to the left drivers side it was normal no heat coming from the wheel area. What problem do you think is possible. I am afraid of a subaru dealer ripping me off fixing it and putting stock impreza 95 parts on when if I need parts I prefer putting wrx brakes on my lighter car.
Here is an older link if you think it is related for background info guys.
Please help.
http://forums.nasioc.com/forums/show...=abs+and+joint

Jay
* Registered users of the site do not see these ads.
jkjersey is offline   Reply With Quote
Old 06-13-2003, 10:12 AM   #2
linsavy
Scooby Specialist
 
Member#: 11620
Join Date: Oct 2001
Location: Ontario
Vehicle:
1997 GF4-STiV3 clone

Default

Well,
You could have a damaged ABS sensor at that wheel.
Perhaps the CV joint was incorrectly installed and has failed or yourwheel bearing is failing.
The brakes themselves can be swapped for RS or WRX calipers and rotors. This won't interfere with the ABS. If the dealer says you need your calipers rebuilt find a set of used RS calipers and rotors instead.
You should have brought this back to the mechanic as soon as you noticed the ABS issue. A good shop would have put it right.
linsavy is offline   Reply With Quote
Old 06-13-2003, 03:52 PM   #3
Luke@tirerack
Tire Rack Moderator
 
Member#: 1215
Join Date: Apr 2000
Location: The Tire Rack
Vehicle:
800 -428-8355
ext. 4362

Default

it's one of these things ......

1.) bad sensor ( damaged during cv joint work ??)
2.) sensor connector ( CV work again makes this a possiblity)
3.) wrong air gap to the sensor ( again CV work ??)
4.) reluctor ring missing or damaged ( cv work?)
5.) bearing issues changing the air gap to the sensor

check those items ... you will find the problem
Luke@tirerack is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Brakes for early GC8 WRX interchangable with regular Impreza brakes? MaxPower Brakes, Steering & Suspension 0 05-30-2010 06:38 PM
Brake problem on 01' 2.5RS gc8 RyansJDMgc8 Brakes, Steering & Suspension 2 10-05-2004 04:56 AM
Brakes? Problems with ABS? jimtesla Baja Forum 5 06-30-2004 12:52 AM
Potential problem with GC8 JIC FLT-A2 install? edkwon Brakes, Steering & Suspension 3 04-12-2003 01:43 PM
Problems with GC8 SYMS kit? dyswtric27 Interior & Exterior Modification 8 03-19-2002 12:52 AM


All times are GMT -4. The time now is 09:58 PM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.