Welcome to the North American Subaru Impreza Owners Club Wednesday July 30, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Subaru Models > Legacy Forum

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-08-2003, 12:26 PM   #1
shipjumper
Scooby Specialist
 
Member#: 6307
Join Date: May 2001
Chapter/Region: NESIC
Location: defrosted FINALLY, VT
Vehicle:
what I has no car...
am carless

Default clunk clunk

ok heres my issue. I have a 1991 legacy turbo. I have put in a set of KYB AGX and a 23mm front and rear adj sway bar.

heres the problem, when going over bumps or loading and unloading the front two corners I get a clunk, or a pop, a popping clunk, like something is hitting something or jumping threads.

has anyone else encountered this? is this a common thing for AGX owners?

let me know! its annoying!
* Registered users of the site do not see these ads.
shipjumper is offline   Reply With Quote
Old 07-08-2003, 01:47 PM   #2
jkyes
Scooby Newbie
 
Member#: 707
Join Date: Jan 2000
Location: cottage grove, mn, usa
Vehicle:
99 Legacy GT
Quick silver

Default

front or rear?

there was a recent post about some noise problems some peole where having in the rear of there car. i just found out my brullen muffler was rubbing up against the body of the car, and the noise i was having up front was a bad ball joint, so that is now replaced.

here is the link to another noisy car problem.

http://forums.nasioc.com/forums/show...hreadid=368718
jkyes is offline   Reply With Quote
Old 07-08-2003, 02:19 PM   #3
shipjumper
Scooby Specialist
 
Member#: 6307
Join Date: May 2001
Chapter/Region: NESIC
Location: defrosted FINALLY, VT
Vehicle:
what I has no car...
am carless

Default

its only front end and when im going over a bump, sidewalk rise, pothole, hard corner load on one side, etc
shipjumper is offline   Reply With Quote
Old 07-08-2003, 03:01 PM   #4
ciper
Scooby Guru
 
Member#: 15543
Join Date: Feb 2002
Location: san francisco, ca
Vehicle:
90BJ Legacy LS ABS
AWD 946 Rio Red Jpn built

Default

Two of the most common reasons

Loose strut top bolt
Loose (or bent) sway bar mount

Where did you get a front 23mm adjustable? I have NEVER seen one.
ciper is offline   Reply With Quote
Old 07-08-2003, 05:07 PM   #5
richeich
Scooby Specialist
 
Member#: 1353
Join Date: Apr 2000
Vehicle:
2001 Impreza 2.5RS
Silver

Default

Did you replace the struts yourself? If so, did you get the springs re-installed the right way. When I did mine (first timer), I put them back together the wrong way, kinda twisted around. The top and bottom caps have a certain side that needs to face out. Anyway, mine was making that popping, clunking sound when the front suspension was working. Turns out the passenger side spring was rubbing against the inside of the fenderwell, making the noise. Took it apart again, paid attention, realized the error of my ways, and learned something. (Hopefully I'll remember it!)

Anyway, hopefully that's not an offensive suggestion. It's just something I've done in the past.

Rich
richeich is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clunk Clunk Clunk Ryanr1490 Transmission (AT/MT) & Driveline 5 12-17-2007 12:59 PM
Clunk Clunk Clunk (suspension prob?) SplatterThrash Brakes, Steering & Suspension 16 07-08-2006 01:38 PM
Clunk Clunk Clunk Clunk subajay New England Impreza Club Forum -- NESIC 6 11-19-2005 08:39 PM
clunk clunk in the front......clunk in the back Silver on Blacks Brakes, Steering & Suspension 9 11-02-2005 05:35 AM
Clunk..Clunk...Clunk Scooby South Brakes, Steering & Suspension 7 03-01-2001 02:15 PM


All times are GMT -4. The time now is 02:16 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.