Welcome to the North American Subaru Impreza Owners Club Thursday July 31, 2014
Home Forums WikiNASIOC Products Store Modifications Upgrade Garage
NASIOC
Here you can view your subscribed threads, work with private messages and edit your profile and preferences Home Registration is free! Visit the NASIOC Store NASIOC Rules Search Find other members Frequently Asked Questions Calendar Archive NASIOC Upgrade Garage Logout
Go Back   NASIOC > NASIOC Technical > Normally Aspirated with bolt-on Forced Induction Powertrain

Welcome to NASIOC - The world's largest online community for Subaru enthusiasts!
Welcome to the NASIOC.com Subaru forum.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, free of charge, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, so please join our community today!

If you have any problems with the registration process or your account login, please contact us.
* Registered users of the site do not see these ads.
Reply
 
Thread Tools Display Modes
Old 07-08-2003, 09:54 PM   #1
Hondaslayer
Purified Dick
Moderator
 
Member#: 4562
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
1995 Legacy LSi
1998 Forester, lifted.

Default Got my link and RC injectors today!Now for the questions..

First off it plugs in place of the ecm correct?Then I bolt it down with the supplied brackets right?Are there any installation instructions online?

Also for the RC injectors which wire goes where for the inector pigtail?



Ben,
* Registered users of the site do not see these ads.
Hondaslayer is offline   Reply With Quote
Old 07-09-2003, 09:26 AM   #2
Marcin
Scooby Specialist
 
Member#: 2874
Join Date: Nov 2000
Chapter/Region: MWSOC
Location: Wood Dale IL
Vehicle:
2005 CGM WRX WGN
Jorge Tunned BattleWagon

Default

ABOUT DARN time! Come on now. I had my second kit Trunkmounted for almost a year already, and you just got the Link x10

J/k

Yes it will plug into your harness, given you got the plug and play harness with the link. You need to run a vaccum line for the onboard MAP sensor trough the firewall to the ECU location.
Make sure there is NO RESTRICTOR IN THE VACCUM line. (like the vaccum gauge line on OEM performance gauge cluster)

The link ECU is a bit taller than the OEM ecu so cover it up with something do it doesnt get scrached up by the floor plate after you reinstall it.

Cheers

Edit: corrected sensor

Last edited by Marcin; 07-09-2003 at 11:32 AM.
Marcin is offline   Reply With Quote
Old 07-09-2003, 10:07 AM   #3
rhdude
Scooby Guru
 
Member#: 6637
Join Date: May 2001
Chapter/Region: MAIC
Location: Manassas
Vehicle:
2009 Acura MDX Sport

Default

Quote:
Originally posted by Marcin

Yes it will plug into your harness, given you got the plug and play harness with the link. You need to run a vaccum line for the onboard MAF sensor trough the firewall to the ECU location.

MAP sensor
rhdude is offline   Reply With Quote
Old 07-09-2003, 10:29 AM   #4
Wedge
Scooby Specialist
 
Member#: 2279
Join Date: Sep 2000
Chapter/Region: South East
Location: The MIA
Vehicle:
2000 Slingshot
Pastelito Racing

Default

Also. Swap your O2 sensors, so the rear o2 sensor is on your downpipe, get rid of your front o2 sensor (or just use it to plug the hole after the cat)
LINK reads better there.
Wedge is offline   Reply With Quote
Old 07-09-2003, 10:19 PM   #5
kaos200
Scooby Guru
 
Member#: 2692
Join Date: Oct 2000
Chapter/Region: SCIC
Location: SoCal
Default

Quote:
Originally posted by Wedge
Also. Swap your O2 sensors, so the rear o2 sensor is on your downpipe, get rid of your front o2 sensor (or just use it to plug the hole after the cat)
LINK reads better there.

wait the Link PNP uses the rear 02???
kaos200 is offline   Reply With Quote
Old 07-09-2003, 11:23 PM   #6
Wedge
Scooby Specialist
 
Member#: 2279
Join Date: Sep 2000
Chapter/Region: South East
Location: The MIA
Vehicle:
2000 Slingshot
Pastelito Racing

Default

http://www.wrxhackers.com/modules.ph...iewtopic&t=329

That's from Bill (skywalker) @ I-SpeedUSA
Wedge is offline   Reply With Quote
Old 07-10-2003, 08:06 PM   #7
Hondaslayer
Purified Dick
Moderator
 
Member#: 4562
Join Date: Feb 2001
Chapter/Region: NWIC
Location: Auburn, WA
Vehicle:
1995 Legacy LSi
1998 Forester, lifted.

Default

As of right now the car has no a/f or o2 sensors.I plan on running the rear sensor (wideband IIRC) where abouts is a good place to put it?

Also which wire goes where for the injector pigtails?


Ben,


Thanks for all the help.



Wait wait wait, WTH are these? I go on vacation for 2 days and we get new smilies?? SWEET!!
Hondaslayer is offline   Reply With Quote
Old 07-14-2003, 09:04 AM   #8
wcbjr
Scooby Guru
 
Member#: 4001
Join Date: Feb 2001
Location: I love spherical bearings!
Vehicle:
2006 Legacy GT
Obsidian black

Default

IIRC, the ordering positioning of the wires doesn't matter. But here's what I did. Left goes to left, right goes to right when holding the injectors side by side. Worked fine for me with the Link and the RC440's I had.

Yes, switch the O2 sensors. The best place to put the sensor IMO is right after the turbo in the downpipe.
wcbjr is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Got my protune at GRD, just in time for the shootout. Amplified2000 Mid West Subaru Owners Club Forum -- MWSOC 4 09-25-2007 07:12 PM
For Sale!!!need To Get Rid Of! T04 Hybrid Turbo,2.0 Block,and Rc Injectors 800 CrAzY5o0wHp Tri-State Area Forum 1 05-20-2005 09:25 PM
I got my review and a raise today! Brad Pittiful Off-Topic 30 03-17-2005 07:57 PM
Should I sell my car and buy a Rex? That is the question. jpwrx02 Newbies & FAQs 31 02-26-2004 02:37 PM
Got my Vishnu re-mapped chip today ... Question? makofoto Engine Management & Tuning 7 05-05-2003 02:46 AM


All times are GMT -4. The time now is 10:05 AM.


Powered by vBulletin® Version 3.7.0
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Powered by Searchlight © 2014 Axivo Inc.
Copyright ©1999 - 2014, North American Subaru Impreza Owners Club, Inc.